indicator-weather crashed with SIGSEGV in dbusmenu_menuitem_property_get_variant()

Bug #830495 reported by Patrik Lundquist on 2011-08-21
This bug affects 310 people
Affects Status Importance Assigned to Milestone
Weather Indicator
Medium
Unassigned
indicator-weather (Ubuntu)
Medium
Unassigned
libdbusmenu (Ubuntu)
Undecided
Unassigned

Bug Description

Crashed when computer was resumed from standby.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: indicator-weather 11.05.31-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
Uname: Linux 3.0.0-8-generic x86_64
Architecture: amd64
CheckboxSubmission: 9f39854e610f4a6ac3758faa5e9c1555
CheckboxSystem: b845c366ea09c60efa3a45c1b5b21525
CrashCounter: 1
Date: Sun Aug 21 13:51:24 2011
ExecutablePath: /usr/bin/indicator-weather
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/indicator-weather
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f83b9b2149b <dbusmenu_menuitem_property_get_variant+43>: cmp %rax,(%rdx)
 PC (0x7f83b9b2149b) ok
 source "%rax" ok
 destination "(%rdx)" (0x700000008) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: indicator-weather
StacktraceTop:
 dbusmenu_menuitem_property_get_variant () from /usr/lib/libdbusmenu-glib.so.4
 dbusmenu_menuitem_properties_variant () from /usr/lib/libdbusmenu-glib.so.4
 dbusmenu_menuitem_build_variant () from /usr/lib/libdbusmenu-glib.so.4
 dbusmenu_menuitem_build_variant () from /usr/lib/libdbusmenu-glib.so.4
 ?? () from /usr/lib/libdbusmenu-glib.so.4
Title: indicator-weather crashed with SIGSEGV in dbusmenu_menuitem_property_get_variant()
UpgradeStatus: Upgraded to oneiric on 2011-08-12 (9 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

StacktraceTop:
 dbusmenu_menuitem_property_get_variant (mi=0x1d5af00, property=0x1de40a3 "visible") at /build/buildd/libdbusmenu-0.4.90/./libdbusmenu-glib/menuitem.c:1286
 dbusmenu_menuitem_properties_variant (mi=0x1d5af00, properties=<optimized out>) at /build/buildd/libdbusmenu-0.4.90/./libdbusmenu-glib/menuitem.c:1511
 dbusmenu_menuitem_build_variant (mi=0x1d5af00, properties=0x1e29540, recurse=-2) at /build/buildd/libdbusmenu-0.4.90/./libdbusmenu-glib/menuitem.c:1606
 dbusmenu_menuitem_build_variant (mi=<optimized out>, properties=0x1e29540, recurse=-1) at /build/buildd/libdbusmenu-0.4.90/./libdbusmenu-glib/menuitem.c:1622
 bus_get_layout (server=<optimized out>, params=<optimized out>, invocation=0x1d24360) at /build/buildd/libdbusmenu-0.4.90/./libdbusmenu-glib/server.c:1214

Changed in indicator-weather (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Changed in indicator-weather (Ubuntu):
status: New → Confirmed
visibility: private → public
Federico Vera (fedevera) wrote :

I suffer the same bug on Precise, but not only on resuming, it happens randomly while the system is on.

Stephan Springer (geryon) wrote :

Duplicate of bug 835967?

I am still having this bug on Ubuntu 12.04 beta 1.

mediterran81 (kyoshuu) wrote :

I confirm the bug on Ubuntu 12.04 Beta 1. Something is wrong with the indicator especially right after login or conditions refreshing.

John Ginis (jhnginis) wrote :

+1

Stephan Springer (geryon) wrote :

Got this crash again today a few minutes after resuming from suspend-to-RAM.

indicator-weather 11.11.28-0ubuntu1
libdbusmenu-glib4 0.5.95-0ubuntu1
libglib2.0-0 2.31.22-0ubuntu1

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libdbusmenu (Ubuntu):
status: New → Confirmed

12.04 beta 2 - crash happens randomly when system is on, but usually after resume from standby.

cometdog (ericctharley) wrote :

Happens randomly on 12.04 beta 2 while system is on; I have never put the system in standby.

Rainer Rohde (rainer-rohde) wrote :

Just crashed randomly.

Paolo (paolomon) wrote :

random crash here too

tags: added: precise
Roy (roi-jacobson1) wrote :

still active...

Chanchao (custom) wrote :

And..still happens on Quantal (Alpha 3 currently)

I can verify that I've also seen this in 12.10 alpha (indicator weather version 12.07.30-0ubuntu1). And, this happened without the system going into standby.

todaioan (alan-ar06) on 2012-08-08
Changed in indicator-weather (Ubuntu):
status: Confirmed → Incomplete
status: Incomplete → Confirmed
Stephen Cradock (s-cradock) wrote :

happens for me running a gnome classic session in quantal up to date September 8th 2012. No Unity, running compiz.

This happens to me in Quantal in Unity from time to time. I don't do anything in particular to cause it.

tags: added: quantal
todaioan (alan-ar06) on 2012-09-18
Changed in indicator-weather (Ubuntu):
status: Confirmed → Incomplete
status: Incomplete → Fix Released
Changed in libdbusmenu (Ubuntu):
status: Confirmed → Fix Committed
Keith Drummond (victor9098) wrote :

Just happened to me running Ubuntu 12.10 beta. The desktop seemed to be running normally when the indicator disappeared and the bug reporter launched.

C de-Avillez (hggdh2) wrote :

Marking both task Triaged -- no visible fix has been provided.

@toda: please do not change status without an explanation of why you are changing it.

Changed in indicator-weather (Ubuntu):
status: Fix Released → Triaged
Changed in libdbusmenu (Ubuntu):
status: Fix Committed → Triaged
tags: added: raring
Changed in weather-indicator:
status: New → Confirmed
Nick Moffitt (nick-moffitt) wrote :

Still getting this in raring.

tuxkillbill (tuxkillbill-free) wrote :

Also for me in 13.04

wavesailor (wavesailor) wrote :

Happens to me in 12.04 at least once a month. Not sure what triggers it though as I'm not doing anything unusual at the time it crashes.

Joshua Tasker (jtasker) wrote :

This has been fixed in 13.05.17 (available at the Weather Indicator PPA), if anyone still experiences it with that version please reopen this bug.

Changed in weather-indicator:
status: Confirmed → Fix Released
importance: Undecided → Medium
milestone: none → 13.05.17
Hanine HAMZIOUI (hanynowsky) wrote :

Just got this bug today on 13.04. Everything is updated.
I am surprised it's marked as fixed.
Any further tests I could perform?

Tero Ratilainen (unksi) wrote :

If I understand right, the fix has been released on a PPA, from which the package cannot be installed due to dependecy issues... I do not consider this fixed.

can you repoen it and mark it as not fixed

> Date: Mon, 3 Jun 2013 14:28:54 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 830495] Re: indicator-weather crashed with SIGSEGV in dbusmenu_menuitem_property_get_variant()
>
> Just got this bug today on 13.04. Everything is updated.
> I am surprised it's marked as fixed.
> Any further tests I could perform?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1173924).
> https://bugs.launchpad.net/bugs/830495
>
> Title:
> indicator-weather crashed with SIGSEGV in
> dbusmenu_menuitem_property_get_variant()
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/weather-indicator/+bug/830495/+subscriptions

tomy (i-r-tomash) wrote :

then this bug needs to be reopened and marked as not fixed right?

> Date: Mon, 3 Jun 2013 14:39:45 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 830495] Re: indicator-weather crashed with SIGSEGV in dbusmenu_menuitem_property_get_variant()
>
> If I understand right, the fix has been released on a PPA, from which
> the package cannot be installed due to dependecy issues... I do not
> consider this fixed.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1173924).
> https://bugs.launchpad.net/bugs/830495
>
> Title:
> indicator-weather crashed with SIGSEGV in
> dbusmenu_menuitem_property_get_variant()
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/weather-indicator/+bug/830495/+subscriptions

Mathieu Marquer (slasher-fun) wrote :

See above: it's been fixed in the main project, but not in the Ubuntu package, for which the status is still "Triaged".

Tero Ratilainen (unksi) wrote :

Heh, I guess I need to learn to read. ;) Yeah it is as "Triaged" still.

To post a comment you must log in.