LIBDBUSMENU-GTK-CRITICAL **: dbusmenu_gtk_parse_get_cached_item: assertion `GTK_IS_MENU_ITEM(widget)' failed

Bug #733918 reported by Raphael Gradenwitz on 2011-03-12
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
DBus Menu
Fix Released
High
Ted Gould
Unity Foundations
Undecided
Ted Gould
libdbusmenu (Ubuntu)
Undecided
Ted Gould

Bug Description

New build of a fresh checked out transmission [svn://svn.transmissionbt.com/Transmission/trunk] against the newest libdbusmenu-gtk3 (libdbusmenu-gtk-dev) Version 0.3.101-0ubuntu1 produces this message:

(transmission-gtk:3284): LIBDBUSMENU-GTK-CRITICAL **: dbusmenu_gtk_parse_get_cached_item: assertion `GTK_IS_MENU_ITEM(widget)' failed
[https://trac.transmissionbt.com/ticket/4107]

or even crashes the program (transmission) which was built against this version of the lib. Building against the previous version does not produce this messages or crashes.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: libdbusmenu-gtk3 0.3.101-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Uname: Linux 2.6.38-6-generic x86_64
Architecture: amd64
Date: Sat Mar 12 17:57:29 2011
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100427.1)
ProcEnviron:
 LANGUAGE=de_DE:en
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: libdbusmenu
UpgradeStatus: Upgraded to natty on 2011-02-27 (12 days ago)

Related branches

Same message with other applications like google-chrome in this example:

(google-chrome:5152): LIBDBUSMENU-GTK-CRITICAL **: dbusmenu_gtk_parse_get_cached_item: assertion `GTK_IS_MENU_ITEM(widget)' failed

Christian Assig (chrassig) wrote :

Starting deluge currently produces similar error messages on my natty installation, causing deluge to crash.

I get the following error when starting nm-applet. I guess that's why the nm-applet does not show up in the unity panel:

(nm-applet:23374): LIBDBUSMENU-GTK-CRITICAL **: dbusmenu_gtk_parse_get_cached_item: assertion `GTK_IS_MENU_ITEM(widget)' failed

(nm-applet:23374): LIBDBUSMENU-GTK-CRITICAL **: dbusmenu_gtk_parse_get_cached_item: assertion `GTK_IS_MENU_ITEM(widget)' failed
** (nm-applet:23374): DEBUG: old state indicates that this was not a disconnect 0

crys (schaefec) wrote :

Same here with at least geeqie and handbrake-gtk (ghb). Geequie starts without any further issues but ghb only shows an emtpy canvas.

Changed in libdbusmenu (Ubuntu):
assignee: nobody → Ted Gould (ted)

Honestly, the message is probably overly loud, we need to look into
that. But, it's probably not what's causing your application to crash.
Something else is...

Could someone provide a backtrace of one of the crashes please? That
would probably be most helpful in figuring out what the issue is.
Thanks!

  affects ubuntu/libdbusmenu
  status incomplete

  affects dbusmenu
  status incomplete
  importance high
  assign me

Changed in libdbusmenu (Ubuntu):
status: New → Incomplete
Changed in dbusmenu:
assignee: nobody → Ted Gould (ted)

OK, in my case the crashes where NOT caused by libdbusmenu! Excuse me.. That was purely coincidental
But the 'Over loud' messages are a kind of Spam on the console!

Regards,
Raphael

Ted Gould (ted) wrote :

Okay, so I'm assuming this bug is about the message being unnecessarily misleading. Fixing.

Changed in dbusmenu:
status: Incomplete → In Progress
Ted Gould (ted) on 2011-03-16
Changed in dbusmenu:
status: In Progress → Fix Committed
Ted Gould (ted) on 2011-03-16
Changed in dbusmenu:
milestone: none → 0.3.102
Ted Gould (ted) on 2011-03-16
Changed in dbusmenu:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdbusmenu - 0.3.102-0ubuntu1

---------------
libdbusmenu (0.3.102-0ubuntu1) natty; urgency=low

  * New upstream release.
    ∘ Remove child items when they're removed by GTK
    ∘ Adding opened and closed events for menu visibility
    ∘ Handle empty image types
    ∘ Remove critical warning on parser menuitem check (LP: #733918)
    ∘ Fix dependencies in pkgconfig files (LP: #733263)
    ∘ Handle NULL labels (LP: #733688)
    ∘ Fix memory leaks from variants (LP: #722972)
 -- Ted Gould <email address hidden> Wed, 16 Mar 2011 14:08:13 -0500

Changed in libdbusmenu (Ubuntu):
status: Incomplete → Fix Released
Ted Gould (ted) on 2011-03-16
Changed in unity-foundations:
assignee: nobody → Ted Gould (ted)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers