xchat - separators are shown as 'Label Empty'

Bug #729187 reported by Omer Akram on 2011-03-04
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
DBus Menu
Fix Released
Low
Chris Coulson
Unity Foundations
Low
Chris Coulson
libdbusmenu (Ubuntu)
Low
Chris Coulson
Natty
Low
Chris Coulson

Bug Description

this is really simple to reproduce. Open xchat click on the 'xchat' menu see on the places where there should be a separator is a greyed out menu item called 'Label Empty'

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: libdbusmenu-gtk3 0.3.100-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
Architecture: i386
Date: Fri Mar 4 21:43:12 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110226)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: libdbusmenu
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Omer Akram (om26er) wrote :
Sebastien Bacher (seb128) wrote :

is that using xchat or xchat-gnome? is that still an issue?

Changed in dbusmenu:
importance: Undecided → Low
Changed in libdbusmenu (Ubuntu):
importance: Undecided → Low
Omer Akram (om26er) wrote :

its xchat and yes the issue is still there.

Changed in dbusmenu:
status: New → Confirmed
Changed in libdbusmenu (Ubuntu):
status: New → Confirmed
Ted Gould (ted) wrote :

Omer,

What dbusmenu version do you have now? I think that an update in the last couple of days should have fixed that. Could you check the version and make sure to restart xchat?

Thank you,
Ted

Omer Akram (om26er) wrote :

I am upto date I have libdbusmenu 0.3.100-0ubuntu4

Sebastien Bacher (seb128) wrote :

The current natty beta1 candidate versions show the same issue in pidgin now

tags: added: parser
Changed in libdbusmenu (Ubuntu Natty):
assignee: nobody → Ted Gould (ted)
Changed in dbusmenu:
assignee: nobody → Ted Gould (ted)
Changed in libdbusmenu (Ubuntu Natty):
assignee: Ted Gould (ted) → Chris Coulson (chrisccoulson)
Changed in dbusmenu:
assignee: Ted Gould (ted) → Chris Coulson (chrisccoulson)
David Barth (dbarth) on 2011-03-28
Changed in unity-foundations:
milestone: none → unity-3.8.0-beta
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → Low
status: New → Confirmed
Ron Lusk (luskwater) wrote :

This affects not only Pidgin, but also a My-Weather-Indicator app that I downloaded.

Chris Coulson (chrisccoulson) wrote :

I guess the My-Weather-Indicator app is creating empty GtkMenuItem's for separators, rather than using GtkSeparatorMenuItem ;)

Ted Gould (ted) on 2011-03-31
Changed in dbusmenu:
status: Confirmed → Fix Committed
milestone: none → 0.3.17
Ted Gould (ted) on 2011-03-31
Changed in dbusmenu:
milestone: 0.3.17 → 0.4.1
Ted Gould (ted) on 2011-03-31
Changed in dbusmenu:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdbusmenu - 0.4.1-0ubuntu1

---------------
libdbusmenu (0.4.1-0ubuntu1) natty; urgency=low

  * New upstream release.
    * Managed variant iterators better to stop crash when dealing
      with apps that have multiple shortcuts (LP: #741726)
    * Handled GtkMenuItems with no labels as separators (LP: #729187)
 -- Ted Gould <email address hidden> Thu, 31 Mar 2011 13:56:54 -0500

Changed in libdbusmenu (Ubuntu Natty):
status: Confirmed → Fix Released
David Barth (dbarth) on 2011-04-04
Changed in unity-foundations:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers