indicator menu items missing since the recent natty update

Bug #723873 reported by Sebastien Bacher on 2011-02-23
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
DBus Menu
Fix Released
High
Unassigned
indicator-messages (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
libdbusmenu (Ubuntu)
High
Chris Coulson
Natty
High
Chris Coulson

Bug Description

Using today's update in natty if you turn the bluetooth off and on in the gnome-bt indicator the menu is missing some items, reverting https://code.edge.launchpad.net/~ted/dbusmenu/good-defaults-are-well-good/+merge/50691 fixes the issue

Related branches

Sebastien Bacher (seb128) wrote :

the missing entries are the one to send files, browse devices or configure devices, the devices submenus are also empty

Changed in libdbusmenu (Ubuntu):
assignee: nobody → Ted Gould (ted)
importance: Undecided → High
milestone: none → natty-alpha-3
Sebastien Bacher (seb128) wrote :

the indicator-messages menu is only listing the titles of running softwares as well it seems

summary: - recent commit breaking indicator refreshing
+ indicator menu items missing since the recent natty update
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-messages - 0.3.92-0ubuntu2

---------------
indicator-messages (0.3.92-0ubuntu2) natty; urgency=low

  * src/launcher-menu-item.c
    - Make sure menu entries are displayed for launchers that aren't running (LP: #723873)
 -- Ken VanDine <email address hidden> Wed, 23 Feb 2011 16:06:37 -0500

Changed in indicator-messages (Ubuntu Natty):
status: New → Fix Released
Changed in dbusmenu:
status: New → Fix Released
status: Fix Released → New
Chris Coulson (chrisccoulson) wrote :

Confirming also that https://code.edge.launchpad.net/~ted/dbusmenu/good-defaults-are-well-good/+merge/50691 is breaking sensitivity in some Firefox menu items too

Kalle Valo (kvalo) on 2011-02-25
Changed in dbusmenu:
status: New → Triaged
importance: Undecided → High
Changed in libdbusmenu (Ubuntu Natty):
assignee: Ted Gould (ted) → Chris Coulson (chrisccoulson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdbusmenu - 0.3.99-0ubuntu3

---------------
libdbusmenu (0.3.99-0ubuntu3) natty; urgency=low

  * Fix LP: #723873 - ensure that changing a menuitem property to a default
    value gets propagated properly in the client
    - add debian/patches/fix-defaults-in-client.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Tue, 01 Mar 2011 00:47:24 +0000

Changed in libdbusmenu (Ubuntu Natty):
status: New → Fix Released
Ted Gould (ted) on 2011-03-01
Changed in dbusmenu:
status: Triaged → Fix Committed
Ted Gould (ted) on 2011-03-03
Changed in dbusmenu:
status: Fix Committed → Fix Released
Mauricio Pretto (pretto) wrote :

this fix did not fix my problem which was marked as duplicate of this on
the report is here
https://bugs.launchpad.net/ubuntu/+source/libdbusmenu/+bug/725469
I still have the same problem

Chris Coulson (chrisccoulson) wrote :

Mauricio, it fixed the thunderbird issue for me and some other people, but now one other person has also said that they have the same problem as you. Do you use IRC? Could you join #ubuntu-mozillateam on irc.freenode.net and ping me (chrisccoulson)? I'd like to get this one figured out asap

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers