Ubuntu

nautilus crashed with SIGSEGV in g_type_check_instance_cast(), from settings_notify_cb(), in dbusmenu's parser.c

Reported by Fo2adZz on 2012-09-20
784
This bug affects 92 people
Affects Status Importance Assigned to Milestone
DBus Menu
High
Lars Uebernickel
glib2.0 (Ubuntu)
Quantal
High
Unassigned
libdbusmenu (Ubuntu)
High
Unassigned
Quantal
High
Unassigned
nautilus (Ubuntu)
High
Unassigned
Quantal
High
Unassigned

Bug Description

This problem happens randomly on ubuntu 12.10, as of the updates to quantal and quantal-proposed on September 20. Nautilus did not change in these upgrades. Glib and libdbusmenu did, and those libraries are both prominent in the stacktrace. (I can't tell yet which is really the culprit, so, excuse my imprecision, I'm adding them both to the report.)

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: nautilus 1:3.5.90.really.3.4.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
Date: Thu Sep 20 18:47:08 2012
ExecutablePath: /usr/bin/nautilus
GsettingsChanges: b'org.gnome.nautilus.window-state' b'geometry' b"'800x550+564+24'"
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120917)
ProcCmdline: nautilus -n
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f38128b2e8c <g_type_check_instance_cast+28>: mov (%rax),%rbp
 PC (0x7f38128b2e8c) ok
 source "(%rax)" (0x700000008) not located in a known VMA region (needed readable region)!
 destination "%rbp" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 g_type_check_instance_cast () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libdbusmenu-gtk3.so.4
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: nautilus crashed with SIGSEGV in g_type_check_instance_cast()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Fo2adZz (fouad-hassouneh) wrote :

StacktraceTop:
 g_type_check_instance_cast (type_instance=type_instance@entry=0x188f800, iface_type=25005616) at /build/buildd/glib2.0-2.33.14/./gobject/gtype.c:3997
 settings_notify_cb (settings=0x165fa80, pspec=0x165f990, data=0x188f800) at /build/buildd/libdbusmenu-12.10.1/./libdbusmenu-gtk/parser.c:1327
 g_closure_invoke (closure=0x1c530e0, return_value=0x0, n_param_values=2, param_values=0x7fff6d7dbb70, invocation_hint=0x7fff6d7dbb10) at /build/buildd/glib2.0-2.33.14/./gobject/gclosure.c:777
 signal_emit_unlocked_R (node=node@entry=0x15f9530, detail=detail@entry=700, instance=instance@entry=0x165fa80, emission_return=emission_return@entry=0x0, instance_and_params=instance_and_params@entry=0x7fff6d7dbb70) at /build/buildd/glib2.0-2.33.14/./gobject/gsignal.c:3551
 g_signal_emit_valist (instance=0x165fa80, signal_id=<optimized out>, detail=700, var_args=var_args@entry=0x7fff6d7dbdc8) at /build/buildd/glib2.0-2.33.14/./gobject/gsignal.c:3300

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Iain Lane (laney) on 2012-09-21
visibility: private → public
description: updated
Edward Donovan (edward.donovan) wrote :

Iain, thanks so much for making this public. Private master bugs are an 'orrible shackle, hopefully that won't happen, soon.

So, I added glib2.0 and libdbusmenu to the bug, and updated the description. It looks like the problem is in one of those, and probably not in nautilus, which didn't change the day the bug appeared in quantal. So it might be most accurate to mark the nautilus component 'Invalid', but I'm afraid that could confuse people and perhaps lead them to think this is not the bug they're looking for. So I left that alone. Thanks.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in glib2.0 (Ubuntu):
status: New → Confirmed
Changed in libdbusmenu (Ubuntu):
status: New → Confirmed

I think this is true for any crash of the nautilus process that starts on login, and manages the desktop window, but I want to note this for anyone trying to match bugs to their symptoms. Until you start nautilus again,

* right-click on the desktop does nothing.

* nautilus' quicklist, from the Launcher, stops showing your bookmarked folders, and becomes a generic quicklist.

Ursula Junque (ursinha) on 2012-09-24
tags: added: rls-q-tracking
Changed in nautilus (Ubuntu):
importance: Medium → High
Download full text (4.8 KiB)

Daniel,
It regretted to inform you email on the above subject is no use for the
following reasons:

I am newbie to ubuntu and linux. I use WinXP most of time.
Since ubuntu 12.10 has been crashed and just now has been re-installed
from scratch.

 *Reason*:Trying to install ubuntu 12.04(for the purpose of Ocropus Project
for which python 2.7.3 required -works fine - whereas in ubuntu 12.10
failed to work) as a result entire OS winxp and ubuntu 12.10 crashed. In
order to recovery/restore to original position - I re-installed ubuntu
12.10. Now I am able to boot the both OS viz winxp(*which is important for
me*) as well as ubuntu 12.10.

*how problem arised*: I had downloaded both versions of ubuntu
12.04(64bit) and also 12.04(without 64bit) burned CD/RW - but failed to
install and crashed - due error at sector (where I dont know - displayed in
light green color on the monitor) Again I tried using another burned
CD/RW also failed.
Now again as a final attempt I am re-downloading ubuntu 12.04(i386.iso) and
waiting for completion. If this also fails, I am thinking install old
version 10.10
and then upgrade to 12.04.
It appears that iso of ubuntu 12.04 in the website are corrupted? Now I am
perplexed and afraid to use ubuntu of future version - lest I loose winXp
and data etc. unless there is ubuntu recovery CD for restoring lost/damaged
grub.

*Suggested solution*: I wish for benefit of newbie/users like me, the
following suggestions are made below for consideration.
Create one General Recovery CD for all ubuntu versions - to restore/recover
the lost grub as well as all OS if any. due to unforeseen circumstances.

OR if Recovery Mode/option added to the Grub in the installed ubuntu -
it should be able to restore the damaged/lost grub to original position
automatically.
For this purpose it should be introduced in all existing ubuntu and future
one. This option will encouraged the newbies/users like me to use ubuntu
without any fear/frustration and thus preven runaway from ubuntu.

The position may kindly be brought to the kind notice of appropriate
authority
/team - for consideration and implementation.
With warmest regards,
-sriranga(79yrs)

On Mon, Sep 24, 2012 at 9:34 AM, Daniel van Vugt <
<email address hidden>> wrote:

> ** Changed in: nautilus (Ubuntu)
> Importance: Medium => High
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1053972).
> https://bugs.launchpad.net/bugs/1053670
>
> Title:
> nautilus crashed with SIGSEGV in g_type_check_instance_cast()
>
> Status in “glib2.0” package in Ubuntu:
> Confirmed
> Status in “libdbusmenu” package in Ubuntu:
> Confirmed
> Status in “nautilus” package in Ubuntu:
> Confirmed
>
> Bug description:
> This problem happens randomly on ubuntu 12.10, as of the updates to
> quantal and quantal-proposed on September 20. Nautilus did not change
> in these upgrades. Glib and libdbusmenu did, and those libraries are
> both prominent in the stacktrace. (I can't tell yet which is really
> the culprit, so, excuse my imprecision, I'm adding them both to the
> report.)
>
> ProblemType: Crash
> DistroRelease: Ubuntu 1...

Read more...

From the appearance of settings_notify_cb() in the crash, this appears to be coming from https://code.launchpad.net/~mterry/dbusmenu/proxy-gtk-menu-images/+merge/123576 which was added for bug #927236

summary: - nautilus crashed with SIGSEGV in g_type_check_instance_cast()
+ nautilus crashed with SIGSEGV in g_type_check_instance_cast(), from
+ settings_notify_cb(), in dbusmenu's parser.c
Charles Kerr (charlesk) on 2012-09-24
Changed in dbusmenu:
status: New → In Progress
assignee: nobody → Lars Uebernickel (larsu)
importance: Undecided → Critical
milestone: none → 12.10.2
Lars Uebernickel (larsu) on 2012-09-24
Changed in dbusmenu:
status: In Progress → Fix Committed
Changed in nautilus (Ubuntu):
status: Confirmed → Invalid
Changed in libdbusmenu (Ubuntu):
importance: Undecided → High
status: Confirmed → In Progress
Changed in glib2.0 (Ubuntu):
status: Confirmed → Invalid
importance: Undecided → High
Changed in libdbusmenu (Ubuntu Quantal):
milestone: none → ubuntu-12.10-beta-2

Excellent! Nice work, Lars and Charles. Thank you.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libdbusmenu - 12.10.1-0ubuntu2

---------------
libdbusmenu (12.10.1-0ubuntu2) quantal-proposed; urgency=low

  * Backport upstream fix for segfault issue (lp: #1053670)
 -- Sebastien Bacher <email address hidden> Mon, 24 Sep 2012 21:36:35 +0200

Changed in libdbusmenu (Ubuntu Quantal):
status: In Progress → Fix Released

I guess I'll remove the glib component, since it turned out not to be involved at all. Thanks.

no longer affects: glib2.0 (Ubuntu)
affects: glib2.0 (Ubuntu Quantal) → Ubuntu Quantal

Ugh, I guess I don't have privileges to really remove that component, since it has a milestone. It just left a milestone attached to Ubuntu. I'll put glib back to make less of a mess, but if someone with privileges wants to remove it all, it'd neater. Sorry & thanks.

affects: Ubuntu Quantal → glib2.0 (Ubuntu Quantal)
Charles Kerr (charlesk) on 2012-09-25
Changed in dbusmenu:
importance: Critical → High
Mathieu Marquer (slasher-fun) wrote :

Still crashes for me, see bug #1056419

Changed in dbusmenu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers