Update libctl to use guile-1.8

Bug #339618 reported by Evan Broder on 2009-03-08
2
Affects Status Importance Assigned to Milestone
libctl (Debian)
Fix Released
Unknown
libctl (Ubuntu)
Undecided
Unassigned
meep (Ubuntu)
Undecided
Unassigned
mpb (Ubuntu)
Undecided
Unassigned

Bug Description

This is a direct crossposting of my Debian bug, since I'm trying to get this fixed for the MIT Athena computing cluster infrastructure which is going to be using Jaunty.

libctl is currently the only library that uses guile 1.6 instead of 1.8. I'd appreciate it if that dependency could be upgraded.

My specific use case is that we would like to have both libctl-dev and libgeda-dev installed in the MIT Athena computing environment, but can't because they depend on different versions of guile-dev, which conflict with each other.

Included is a debdiff for libctl. The two packages that rdepend on libctl (meep and mpb) will have to be rebuilt against the new library (and mpb needs a small tweak to debian/control as well), so I've included debdiffs to update those as well.

I've tested that the packages build, install, and run with my patches, but since I'm not really familiar with the software, I don't really know how to test the builds past starting up the programs.

Evan Broder (broder) wrote :
Evan Broder (broder) wrote :
Evan Broder (broder) wrote :
Changed in libctl:
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libctl - 3.0.3-1ubuntu1

---------------
libctl (3.0.3-1ubuntu1) jaunty; urgency=low

   * Upgrade guile-1.6-dev dependency to guile-1.8-dev (LP: #339618)

 -- Evan Broder <email address hidden> Sun, 08 Mar 2009 13:38:14 -0400

Changed in libctl (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package meep - 0.20.3-1ubuntu1

---------------
meep (0.20.3-1ubuntu1) jaunty; urgency=low

  * Rebuild for new libctl version (LP: #339618).

 -- Evan Broder <email address hidden> Sun, 08 Mar 2009 13:59:40 -0400

Changed in meep (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mpb - 1.4.2-12ubuntu1

---------------
mpb (1.4.2-12ubuntu1) jaunty; urgency=low

  * Rebuild for new libctl version (LP: #339618).

 -- Evan Broder <email address hidden> Sun, 08 Mar 2009 14:06:54 -0400

Changed in mpb (Ubuntu):
status: New → Fix Released
Changed in libctl (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.