Sync libcsfml 1.5-1 (universe) from Debian testing (main)

Bug #491069 reported by Charlie_Smotherman on 2009-12-01
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libcsfml (Ubuntu)
Wishlist
Unassigned

Bug Description

Please sync libcsfml 1.5-1 (universe) from Debian testing (main)

Explanation of the Ubuntu delta and why it can be dropped:
The package now builds with libsfml-dev (>= 1.5)

Changelog entries since current lucid version 1.4-2ubuntu2:

libcsfml (1.5-1) unstable; urgency=low

  * New upstream 1.5 release
    * Builds against newer libsfml (Closes: #542982)
    * SONAME bump for libraries
    * Drop debian/gcc4.3.diff (implemented upstream)
    * Refresh debian/correct-destdir
  * Improve descriptions
  * Clean up rules file -- some quirks no longer needed because of
    improvements in upstream buildsystem
  * Bump standards version to 3.8.3 (no changes)
  * remove duplicate priority entries in control
  * Add README.source

 -- Christoph Egger <email address hidden> Wed, 30 Sep 2009 01:29:32 +0200

Changed in libcsfml (Ubuntu):
importance: Undecided → Wishlist
Fabrice Coutadeur (fabricesp) wrote :

FTBFS because of missing dependency:
...
After installing, the following source dependencies are still unsatisfied:
libsfml-dev(inst 1.4+repack1-1build1 ! >= wanted 1.5)
Source-dependencies not satisfied; skipping libcsfml

Fabrice

Charlie_Smotherman (cjsmo) wrote :

Wow, not sure why it built for me, hmmm. I retried to build and sure enough it needs libsfml-1.5-dev. There is a sync request for libsfml to bring lucid up to 1.5 bug #486393 however that was set to invalid and autosync has not picked up on it yet. Will monitor

Best regards
Charlie Smotherman

Changed in libcsfml (Ubuntu):
status: New → Incomplete
Benjamin Drung (bdrung) wrote :

I am unsubscribing ubuntu-universe-sponsors for now. Please subscribe them again, when there is something to do for us.

Charlie_Smotherman (cjsmo) wrote :

Now that the libsfml sync is complete this sync can now go forward

Changed in libcsfml (Ubuntu):
status: Incomplete → New
Fabrice Coutadeur (fabricesp) wrote :

Sync request ack'd

Changed in libcsfml (Ubuntu):
status: New → Triaged
James Westby (james-w) wrote :

[Updating] libcsfml (1.4-2ubuntu2 [Ubuntu] < 1.5-3 [Debian])
 * Trying to add libcsfml...
  - <libcsfml_1.5-3.diff.gz: downloading from http://ftp.debian.org/debian/>
  - <libcsfml_1.5.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
  - <libcsfml_1.5-3.dsc: downloading from http://ftp.debian.org/debian/>
I: libcsfml [universe] -> libcsfml-dev_1.4-2ubuntu2 [universe].

Changed in libcsfml (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers