Libcroco uses wrong green color

Bug #1163999 reported by Petr Kadlec on 2013-04-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libcroco
Fix Released
Medium
libcroco (Ubuntu)
Medium
Unassigned
Precise
Low
Unassigned
Quantal
Low
Unassigned

Bug Description

[Impact]

libcroco [1] had a bug [2] in its versions 0.6.5 and 0.6.6, which results in e.g. librsvg rendering wrong green color. The bug has been fixed since 0.6.7 [3], but the Ubuntu 12.04 Precise LTS version contains the broken version 0.6.5-1 (and Quantal uses a newer, but still broken, 0.6.6-1; Raring seems to use the current (fixed) 0.6.8-1). [4] Because Wikimedia Foundation wikis (including Wikipedia and Wikimedia Commons) suffer from this bug in SVG rendering [5], I was referred to here to report it/ask for the library to be updated, prior to patching it locally.

This fix libcroco so that it again complies with the CSS & SVG standards.

[Test Case]

[Regression Potential]
This is a one line patch that has been shipped in libcroco 0.6.7 for six months.

[Rest of original bug report]

As I am not acquainted with Ubuntu/Debian policies/requirements/workflow for such changes, I hope I am not reporting it in a _completely_ wrong place… If so, feel free to forward this, or point me to a better place. Thanks.

   [1] https://launchpad.net/ubuntu/+source/libcroco
   [2] https://bugzilla.gnome.org/show_bug.cgi?id=672332#c4
   [3] https://git.gnome.org/browse/libcroco/log/
   [4] https://launchpad.net/libcroco/+packages
   [5] https://bugzilla.wikimedia.org/show_bug.cgi?id=46540

Jeremy Bicha (jbicha) on 2013-04-03
summary: - Libcroco needs update to a fixed version
+ Libcroco uses wrong green color
Changed in libcroco:
importance: Unknown → Medium
status: Unknown → Fix Released
Jeremy Bicha (jbicha) wrote :

Attaching patches for precise and quantal since I need sponsorship for this package.

Jeremy Bicha (jbicha) wrote :
description: updated
Changed in libcroco (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Sebastien Bacher (seb128) wrote :

Thanks, accepting the precise nomination, not sure we can to keep spending our limited SRU team resources on minor issues for quantal though so keeping that one unapproved

Changed in libcroco (Ubuntu):
status: Triaged → Fix Released
Changed in libcroco (Ubuntu Precise):
importance: Undecided → Low
status: New → Triaged
Jeremy Bicha (jbicha) wrote :

Why can't the SRU team just accept and verify the quantal 1-line patch at the same time as the precise one? Make the non-LTS SRU procedures less rigorous then instead of abandoning Quantal before Raring is even final.

Dimitri John Ledkov (xnox) wrote :

Approving quantal nomination, for the sake of not causing regressions from precise with this sru -> quantal upgrades.
But I would be ok for verification to be done on precise only, as the codepath is exactly the same. It's just colors really =)

@seb128 we had similarish one in gtk which I caught. Is pango reverting as well? Or does pango now has "correct" green as well?

Dimitri John Ledkov (xnox) wrote :

uploaded into quantal & precise proposed unapproved queues. Next a member of SRU team should verify and accept those uploads.

Unsubscribing Ubuntu Sponsors team.

Changed in libcroco (Ubuntu Precise):
status: Triaged → In Progress
Changed in libcroco (Ubuntu Quantal):
status: New → In Progress
importance: Undecided → Low

Hello Petr, or anyone else affected,

Accepted libcroco into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libcroco/0.6.5-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libcroco (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in libcroco (Ubuntu Quantal):
status: In Progress → Fix Committed
Dave Walker (davewalker) wrote :

Hello Petr, or anyone else affected,

Accepted libcroco into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libcroco/0.6.6-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

The fix for this bug has been awaiting testing feedback in the -proposed repository for precise for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
Petr Kadlec (mormegil) wrote :

I tested the -proposed update in both Precise and Quantal and everything works fine. The current Precise rsvg-convert was affected by this bug, after an upgrade of libcroco3 to -proposed (Version: 0.6.5-1ubuntu0.1), the error went away.

Ditto for Quantal, the -proposed version (Version: 0.6.6-1ubuntu0.1) works correctly. (Tested by running rsvg-convert on the SVG file linked in the abovementioned Wikimedia bugreport.)

tags: added: verification-done
removed: removal-candidate verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libcroco - 0.6.5-1ubuntu0.1

---------------
libcroco (0.6.5-1ubuntu0.1) precise; urgency=low

  * debian/patches/git-revert-green-change.patch:
    - Revert change to the "green" color since it violates the CSS and
      SVG standards (LP: #1163999)
 -- Jeremy Bicha <email address hidden> Tue, 09 Apr 2013 13:43:15 +0100

Changed in libcroco (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libcroco - 0.6.6-1ubuntu0.1

---------------
libcroco (0.6.6-1ubuntu0.1) quantal; urgency=low

  * debian/patches/git-revert-green-change.patch:
    - Revert change to the "green" color since it violates the CSS and
      SVG standards (LP: #1163999)
 -- Jeremy Bicha <email address hidden> Tue, 09 Apr 2013 13:37:11 +0100

Changed in libcroco (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.