[MIR] b-d for libffado

Bug #730760 reported by Matthias Klose on 2011-03-07
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libconfig (Debian)
Fix Released
Unknown
libconfig (Ubuntu)
High
Unassigned
Natty
High
Unassigned

Bug Description

introduced with sync, needs a MIR

and maybe fix bug #537189

Matthias Klose (doko) on 2011-03-07
Changed in libconfig (Ubuntu Natty):
importance: Undecided → High
milestone: none → ubuntu-11.04-beta-1
status: New → Confirmed
Matthias Klose (doko) wrote :

the libconfig code was already in main in the superseded version of the libffado source package.

the upstream libconfig version already is at 1.4.6, but this shouldn't be addressed for natty

Michael Terry (mterry) wrote :

Rejected because there are no symbols files for the two libraries. But fine besides.

Though, it would be nice if there was an Ubuntu bug subscriber. :)

Changed in libconfig (Ubuntu Natty):
status: Confirmed → Incomplete
holstein (mikeholstein) wrote :

i have just became aware of this issue, and have subscribed to the reports.. demoting this package is not really an option for ubuntustudio... this would mean that out of the box, JACK would not have firewire support... i will continue to do what i can to help resolve this issue in a timely manner.. thanks

see also https://bugs.launchpad.net/ubuntu/+source/dbus-c++/+bug/730759

Luke Yelavich (themuso) wrote :

Since libffado is the only package using libconfig, ubuntu-audio can take care of it for now. Will add ubuntu-audio to its bugmail.

Luke Yelavich (themuso) wrote :

I have just uploaded a new package revision to the package to add symbols files, and sent the change to Debian.

Changed in libconfig (Ubuntu Natty):
status: Incomplete → New
Michael Terry (mterry) wrote :

OK, looks fine now, thanks Luke!

Changed in libconfig (Ubuntu Natty):
status: New → Fix Committed
Colin Watson (cjwatson) wrote :

Promoted.

Changed in libconfig (Ubuntu Natty):
status: Fix Committed → Fix Released
Dimitri John Ledkov (xnox) wrote :

It has been agreed today on #ubuntu-devel and #ubuntu-release to sync libconfig from debian, dropping the ubuntu-only delta which introduced the symbols file. Unfortunately debian did not pick up this patch, there are two libraries in the package (c and separate c++) which make symbols tracking more tricky. Having such delta in Ubuntu is not useful, as clearly in this case, upstream is properly tracking ABI/API and debian has made a correct soname bump in the synced version.

The bug report with submiting symbols patch to debian is linked to this MIR report for reference.

Changed in libconfig (Debian):
status: Unknown → New
Changed in libconfig (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.