"compiz --replace" crash on intel in 'std::logic_error'

Bug #414535 reported by Philippe Le Rohellec on 2009-08-16
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libcompizconfig (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: compiz

I'm running metacity and trying to switch to compiz using "compiz --replace" but it's failing with a core dump:

$ compiz --replace
Checking for Xgl: not present.
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
Detected PCI ID for VGA:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Checking screen 1Comparing resolution (1024x600) to maximum 3D texture size (2048): Passed.
Checking for Software Rasterizer: Not present.
Checking for nVidia: not present.
Checking for FBConfig: present.
running under gnome seesion, checking for gnomecompat
Checking for Xgl: not present.
terminate called after throwing an instance of 'std::logic_error'
  what(): basic_string::_S_construct NULL not valid
Aborted (core dumped)

I'm not sure where the core file ends up.

 $ lsb_release -rd
Description: Ubuntu karmic (development branch)
Release: 9.10

$ apt-cache policy compiz
compiz:
  Installed: 1:0.8.2-0ubuntu15
  Candidate: 1:0.8.2-0ubuntu15
  Version table:
 *** 1:0.8.2-0ubuntu15 0
        500 http://us.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

I'm running this on an Acer Aspire One AOA 150.

philippe@rhodes ~ $ lspci -nn | grep -i intel
00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GME Express Memory Controller Hub [8086:27ac] (rev 03)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GME Express Integrated Graphics Controller [8086:27ae] (rev 03)
00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)
...

Ben Davis (bendavis78) wrote :

I have the exact same problem on Jaunty with NVidia
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600M GT (rev a1)

Compiz is actually able to restart fine from the appearance prefs dialog, which, from looking at the source code just runs "compiz --replace", but for whatever reason running that same command in a terminal will fail with the above error.

Ben Davis (bendavis78) wrote :

Actually, after some googling I found the workaround is to make sure your LANG environment variable is set. Setting LANG=en_US.utf-8 did the trick for me.

That's right, setting LANG to en_US.utf-8 does resolve the issue. Thanks Ben.

Travis Watkins (amaranth) wrote :

The error message is a C++ one but the only place C++ it used is the KDE window decorator. Are you guys running KDE?

Travis Watkins (amaranth) wrote :

Actually, it looks like C++ is used if you use the kconfig backend for settings storage as well. Perhaps you first ran compiz on KDE but are now using it on GNOME? It would still be using kconfig in that case.

Ben Davis (bendavis78) wrote :

This is using Gnome, in Ubuntu Jaunty. It only seems to happen when the LANG variable is not set.

Travis Watkins (amaranth) wrote :

Sorry, more comment spam. Can one of you run `apport-collect 414535` so we can get the information needed to debug this problem?

Architecture: i386
DistroRelease: Ubuntu 9.04
MachineType: Dell Inc. Inspiron 1520
NonfreeKernelModules: nvidia
Package: compiz 1:0.8.2-0ubuntu8.1
PackageArchitecture: all
ProcCmdLine: root=UUID=dfd7f54d-00dd-4257-b32d-b22f9464ec5f ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.utf8
ProcVersionSignature: Ubuntu 2.6.28-15.48-generic
Uname: Linux 2.6.28-15-generic i686
UserGroups: adm admin audio cdrom crontab dialout dip floppy fuse lpadmin plugdev vboxusers video www-data

Ben Davis (bendavis78) wrote :
Ben Davis (bendavis78) wrote :
Ben Davis (bendavis78) wrote :
Ben Davis (bendavis78) wrote :
Ben Davis (bendavis78) wrote :
Ben Davis (bendavis78) wrote :
Ben Davis (bendavis78) wrote :
Ben Davis (bendavis78) wrote :
Ben Davis (bendavis78) wrote :
Ben Davis (bendavis78) wrote :
Ben Davis (bendavis78) wrote :
Ben Davis (bendavis78) wrote :
Ben Davis (bendavis78) wrote :
Travis Watkins (amaranth) wrote :

Wow, based on your .xsession-errors it looks like your session....exploded. Unfortunately there is nothing in there that is helpful. Can you trigger this crash again, let apport submit the bug when the crash handler comes up, and then post a comment here saying the bug number for that bug?

Ben Davis (bendavis78) wrote :

Travis, there's no crash handler here. This bug only happens when running "compiz --replace" from commandline when no LANG is set. It works fine otherwise. You might be able to reproduce it yourself by running:

LANG="" compiz --replace

I'm running Gnome but I use some KDE apps on that system.
No crash handler for me neither.

On Mon, Aug 24, 2009 at 8:15 AM, Ben Davis <email address hidden> wrote:

> Travis, there's no crash handler here. This bug only happens when
> running "compiz --replace" from commandline when no LANG is set. It
> works fine otherwise. You might be able to reproduce it yourself by
> running:
>
> LANG="" compiz --replace
>
> --
> "compiz --replace" crash on intel in 'std::logic_error'
> https://bugs.launchpad.net/bugs/414535
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “compiz” package in Ubuntu: New
>
> Bug description:
> Binary package hint: compiz
>
> I'm running metacity and trying to switch to compiz using "compiz
> --replace" but it's failing with a core dump:
>
> $ compiz --replace
> Checking for Xgl: not present.
> xset q doesn't reveal the location of the log file. Using fallback
> /var/log/Xorg.0.log
> Detected PCI ID for VGA:
> Checking for texture_from_pixmap: present.
> Checking for non power of two support: present.
> Checking for Composite extension: present.
> Checking screen 1Comparing resolution (1024x600) to maximum 3D texture size
> (2048): Passed.
> Checking for Software Rasterizer: Not present.
> Checking for nVidia: not present.
> Checking for FBConfig: present.
> running under gnome seesion, checking for gnomecompat
> Checking for Xgl: not present.
> terminate called after throwing an instance of 'std::logic_error'
> what(): basic_string::_S_construct NULL not valid
> Aborted (core dumped)
>
> I'm not sure where the core file ends up.
>
>
> $ lsb_release -rd
> Description: Ubuntu karmic (development branch)
> Release: 9.10
>
> $ apt-cache policy compiz
> compiz:
> Installed: 1:0.8.2-0ubuntu15
> Candidate: 1:0.8.2-0ubuntu15
> Version table:
> *** 1:0.8.2-0ubuntu15 0
> 500 http://us.archive.ubuntu.com karmic/main Packages
> 100 /var/lib/dpkg/status
>
> I'm running this on an Acer Aspire One AOA 150.
>
> philippe@rhodes ~ $ lspci -nn | grep -i intel
> 00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GME Express Memory
> Controller Hub [8086:27ac] (rev 03)
> 00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GME
> Express Integrated Graphics Controller [8086:27ae] (rev 03)
> 00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME,
> 943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)
> ...
>

Changed in compiz (Ubuntu):
importance: Undecided → Low
milestone: none → ubuntu-9.10-beta
status: New → Triaged
Changed in compiz (Ubuntu):
milestone: ubuntu-9.10-beta → none
status: Triaged → In Progress
affects: compiz (Ubuntu) → libcompizconfig (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libcompizconfig - 0.8.4-0ubuntu1

---------------
libcompizconfig (0.8.4-0ubuntu1) karmic; urgency=low

  * new upstream release:
    - crash in 'std::logic_error' (LP: #414535)
  * debian/watch:
    - added watch file

 -- Travis Watkins <email address hidden> Wed, 14 Oct 2009 17:09:43 -0500

Changed in libcompizconfig (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers