translations for compiz-core still missing

Bug #236061 reported by kawaji on 2008-05-30
2
Affects Status Importance Assigned to Milestone
libcompizconfig (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

updated to compiz-core 1:0.7.4-0ubuntu7 , and translations still missing from core.xml file.

compiz.mo files are included in ubuntu-langpack packages.
But compiz.mo file is useless because CCSM reads .xml files for plugins settings GUI.
Translated strings in .po files need to be written to core.xml file when compiz-core package compiled.

Travis Watkins (amaranth) wrote :

The real bug is ccsm won't read from the mo file, compiz adding the translations to xml files on compile time is not going to happen. Reading from those XML files is slow enough already.

kawaji (jiro-kawada) wrote :

I forgot to mention that compiz-plugins 1:0.7.4-0ubuntu7 package have the same issue.
Because translations for plugins included in compiz-plugins package can be found in compiz.mo file but not in each plugin's .xml files.

kawaji (jiro-kawada) wrote :

I have checked the package source.
http://archive.ubuntu.com/ubuntu/pool/main/c/compiz/compiz_0.7.4.orig.tar.gz
Why almost all translated strings in .po files are comment-outed ?

that's the reason translated strings not written to xml files when the maintainer compiled the packages.

kawaji (jiro-kawada) wrote :

>The real bug is ccsm won't read from the mo file.

Then. Should I post that to compi-fusion BTS ?

But compiz-gnome 1:0.7.4-0ubunt7 package have the same issue , translated strings not written in .schemas files
because those strings comment-outted in .po files.
thus, plugin options not localized on gconf-editor.

It's bad... Currently, Ubuntu hardy is the only linux distribution compiz basic plugins not translated.

Travis Watkins (amaranth) wrote :

The translations are included in the XML files again and I can confirm that running `LANG=pt_BR.UTF-8 ccsm` results in a CCSM with all plugins and options translated.

Changed in libcompizconfig (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers