[Gutsy] Wrong default settings for gtk-window-decorator (white boarder bug)

Bug #141361 reported by Forlong on 2007-09-20
4
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
High
Michael Vogt
libcompizconfig (Ubuntu)
High
Michael Vogt

Bug Description

Binary package hint: compiz-gnome

There's a known bug with the gtk-window-decorator on intel chips and ATI cards with the open radeon driver, where you get white boarders instead of shadows around the panel, panel menus and context menus.

This bug can be prevented when increasing the shadow radius to 8.5000 or 9.0000
So the default setting should be changed to something like this.

I already reported this upstream some time ago: http://bugs.opencompositing.org/show_bug.cgi?id=465
But since this bug has to be resolved by the developers of the drivers, distributions have to take care of "obscuring" this for now.

Michael Vogt (mvo) on 2007-09-21
Changed in compiz:
assignee: nobody → mvo
importance: Undecided → High
status: New → In Progress
Steve Langasek (vorlon) wrote :

bug (and fix) confirmed here, change approved for gutsy.

Changed in libcompizconfig:
assignee: nobody → mvo
importance: Undecided → High
status: New → Fix Released
Changed in compiz:
status: In Progress → Fix Released
Michael Vogt (mvo) wrote :

compiz (1:0.5.2+git20070918-0ubuntu5) gutsy; urgency=low

  * debian/compiz-gnome.gconf-defaults:
    - correctly fix schema value for shadow_radius (LP: #141361)

 -- Michael Vogt <email address hidden> Fri, 21 Sep 2007 21:09:00 +0200

Michael Vogt (mvo) wrote :

libcompizconfig (0.5.2+git20070919-0ubuntu2) gutsy; urgency=low

  * debian/patches/01_default_options.patch:
    - fix shadow_radius value (LP: #141361)

 -- Michael Vogt <email address hidden> Fri, 21 Sep 2007 21:08:37 +0200

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers