libcommons-lang3-java version 3.0.1-1 FTBFS on i386 in precise, surefire plugin does not detect use of JUnit 4

Bug #935219 reported by Andreas Moog on 2012-02-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libcommons-lang3-java (Debian)
Fix Released
Unknown
libcommons-lang3-java (Ubuntu)
High
James Page
Precise
High
James Page
surefire (Ubuntu)
Undecided
James Page
Precise
Undecided
James Page

Bug Description

This is a semi-automatic report based on the latest archive rebuild results [1].
Apologies if it reaches you in error.

Excerpt from the buildlog:

  org.apache.commons.lang3.ArrayUtilsRemoveMultipleTest.testRemoveAllLongArrayOutOfBoundsIndex(): Index: 2, Length: 2
  org.apache.commons.lang3.ArrayUtilsRemoveMultipleTest.testRemoveAllNullLongArray(): Index: 0, Length: 0
  org.apache.commons.lang3.ArrayUtilsRemoveMultipleTest.testRemoveAllShortArrayNegativeIndex(): Index: -1, Length: 2
  org.apache.commons.lang3.ArrayUtilsRemoveMultipleTest.testRemoveAllShortArrayOutOfBoundsIndex(): Index: 2, Length: 2
  org.apache.commons.lang3.ArrayUtilsRemoveMultipleTest.testRemoveAllNullShortArray(): Index: 0, Length: 0

Tests run: 2039, Failures: 197, Errors: 0, Skipped: 0

[INFO] ------------------------------------------------------------------------
[ERROR] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] There are test failures.

Please refer to /build/buildd/libcommons-lang3-java-3.0.1/target/surefire-reports for the individual test results.
[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 16 seconds
[INFO] Finished at: Tue Feb 07 02:57:12 UTC 2012
[INFO] Final Memory: 16M/175M
[INFO] ------------------------------------------------------------------------
make: *** [mvn-build] Error 1
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20120207-0257
FAILED [dpkg-buildpackage died]

The full buidlog can be found at https://launchpad.net/ubuntu/+archive/test-rebuild-20120201/+build/3155145/+files/buildlog_ubuntu-precise-i386.libcommons-lang3-java_3.0.1-1_FAILEDTOBUILD.txt.gz.

[1] http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20120201-precise.html

Related branches

Andreas Moog (ampelbein) on 2012-02-18
Changed in libcommons-lang3-java (Ubuntu):
importance: Undecided → High
Changed in libcommons-lang3-java (Debian):
status: Unknown → New
James Page (james-page) on 2012-03-19
Changed in libcommons-lang3-java (Ubuntu Precise):
status: New → Confirmed
James Page (james-page) wrote :

I think that some of this is being caused by the new version of surefire which we have in precise.

It appears that surefire does not correctly detect that the version of Junit being using is >= 4.7 so reverts Junit 3 behaviour which breaks alot of the tests.

Raising a task for surefire as well as I think the fix may be required there.

summary: - libcommons-lang3-java version 3.0.1-1 FTBFS on i386 in precise
+ libcommons-lang3-java version 3.0.1-1 FTBFS on i386 in precise, surefire
+ plugin does not detect use of JUnit 4
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package surefire - 2.10-2ubuntu1

---------------
surefire (2.10-2ubuntu1) precise; urgency=low

  * d/patches/fix-junit-provider-selection.patch: Correctly detect 4.x
    version of JUnit from Debian Maven Repository so that JUnit47Provider
    is selected for execution of unit tests when appropriate (LP: #935219).
 -- James Page <email address hidden> Mon, 19 Mar 2012 15:01:07 +0000

Changed in surefire (Ubuntu Precise):
status: New → Fix Released
James Page (james-page) on 2012-03-19
Changed in libcommons-lang3-java (Ubuntu Precise):
assignee: nobody → James Page (james-page)
Changed in surefire (Ubuntu Precise):
assignee: nobody → James Page (james-page)
James Page (james-page) wrote :

libcommons-lang3-java now builds and tests fine.

Marking 'Fix Released'.

Changed in libcommons-lang3-java (Ubuntu Precise):
status: Confirmed → Fix Released
Changed in libcommons-lang3-java (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.