Specifying cgset -r multiple times fails

Bug #1271531 reported by Ken Sharp on 2014-01-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libcgroup (Ubuntu)
Undecided
Unassigned
Nominated for Precise by ChristianEhrhardt
Nominated for Trusty by ChristianEhrhardt

Bug Description

From the man page:

-r <name=value>
              defines name of the file to set and the value which should be written to that file. This parameter can
              be used multiple times.

However:

$ cgset -r cpu.cfs_quota_us=10000 -r cpu.cfs_period_us=50000 gomez
controller cpu can't be add

...it fails.

Seems to work with memory.* for some reason. Checking with cgget confirms that the values have not been set.

This works fine:
$ cgset -r cpu.cfs_period_us=50000 gomez
$ cgset -r cpu.cfs_quota_us=10000 gomez

Also: that error message needs improvement.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: cgroup-bin 0.37.1-1ubuntu10.1
ProcVersionSignature: Ubuntu 3.11.0-15.23~precise1-generic 3.11.10
Uname: Linux 3.11.0-15-generic i686
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: i386
Date: Wed Jan 22 12:49:06 2014
InstallationMedia: Ubuntu-Server 12.04.1 LTS "Precise Pangolin" - Release i386 (20120817.3)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: libcgroup
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.cgconfig.conf: [modified]
mtime.conffile..etc.cgconfig.conf: 2014-01-22T12:10:10.370249

Ken Sharp (kennybobs) wrote :
Ken Sharp (kennybobs) wrote :

$ cgset -r cpu.cfs_quota_us=8000,cpu.cfs_period_us=50000 gomez
cgset: the group can't be modified

So that doesn't work either.

$ cgset -r cpu.cfs_quota_us=8000:cpu.cfs_period_us=50000 gomez
cgset: the group can't be modified

Nor does that.

Ken Sharp (kennybobs) on 2015-04-18
tags: added: amd64 trusty
Bob (bob53181) wrote :

cgset -r cpu.cfs_quota_us=100000 -r cpu.cfs_period_us=1000 groupname
cgset -r cpu.cfs_period_us=100000 -r cpu.cfs_quota_us=1000 groupname

Both work for me, although the first probably should not. I have libcgroup 0.41-7, probably similar to libcgroup 0.41-6ubuntu1 in
Ubuntu 15.10 Wily Werewolf. Since this is the currently stable version, maybe you should check if it works there and close the bug as fixed.

Ken Sharp (kennybobs) wrote :

Of course it's not fixed.

Changed in libcgroup (Ubuntu):
status: New → Fix Released
ChristianEhrhardt (paelzer) wrote :

Working in Xenial, not sure what was the background thou, so I can't point onto what might have to be backported.

cgset there is from cgroup-tools 0.41-7ubuntu1

Confirmed the issue at least on trusty - since I'm not really into the background atm I'm not sure on severity at all - but I at least can confirm the behavior.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers