machine sleeps immediately after waking

Bug #1740169 reported by ill on 2017-12-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libcec (Ubuntu)
Low
Unassigned

Bug Description

When connected to a computer and tv that supports hdmi-cec, the tv will apparently send more than one sleeps signal upon turning off, queuing this to the PC. So upon waking from sleep it will immediately go back to sleep, meaning I have to turn the pc back on multiple times until it stays on. There is no reason to queue sleep commands.
---
ApportVersion: 2.20.7-0ubuntu3.7
Architecture: amd64
DistUpgraded: 2017-10-19 14:20:08,250 ERROR got error from PostInstallScript ./xorg_fix_proprietary.py (g-exec-error-quark: Failed to execute child process “./xorg_fix_proprietary.py” (No such file or directory) (8))
DistroCodename: artful
DistroRelease: Ubuntu 17.10
DistroVariant: ubuntu
InstallationDate: Installed on 2017-04-22 (292 days ago)
InstallationMedia: Xubuntu 17.04 "Zesty Zapus" - Release amd64 (20170412)
Package: xorg 1:7.7+19ubuntu3
PackageArchitecture: amd64
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-32-generic.efi.signed root=UUID=1ea63dd6-7995-4f89-8bf0-abe7f9c7edae ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 4.13.0-32.35-generic 4.13.13
Tags: artful ubuntu
Uname: Linux 4.13.0-32-generic x86_64
UpgradeStatus: Upgraded to artful on 2017-10-19 (112 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 12/14/2017
dmi.bios.vendor: Intel Corp.
dmi.bios.version: BNKBL357.86A.0060.2017.1214.2013
dmi.board.name: NUC7i3BNB
dmi.board.vendor: Intel Corporation
dmi.board.version: J22859-303
dmi.chassis.type: 3
dmi.modalias: dmi:bvnIntelCorp.:bvrBNKBL357.86A.0060.2017.1214.2013:bd12/14/2017:svn:pn:pvr:rvnIntelCorporation:rnNUC7i3BNB:rvrJ22859-303:cvn:ct3:cvr:
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.83-1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.2.4-0ubuntu1~17.10.2
version.libgl1-mesa-glx: libgl1-mesa-glx 17.2.4-0ubuntu1~17.10.2
version.xserver-xorg-core: xserver-xorg-core 2:1.19.5-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.10.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20170309-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1740169/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → xorg (Ubuntu)

ill, thank you for reporting this and helping make Ubuntu better.

Could you please run the following command once from a terminal by ensuring you have the package xdiagnose installed, and that you click the Yes button for attaching additional debugging information:
apport-collect 1740169

Changed in xorg (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

apport information

tags: added: apport-collected artful ubuntu
description: updated

apport information

ill (illumilore) wrote : DpkgLog.txt

apport information

apport information

apport information

ill (illumilore) wrote : Lspci.txt

apport information

ill (illumilore) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

ill (illumilore) wrote : UdevDb.txt

apport information

ill, given this is issue is HDMI CEC related, there is no evidence this has anything to do with xorg. Despite this:

1) Could you please advise to the full manufacturer and model of the TV?

2) Is this something that started to happen after an update?

tags: added: latest-bios-0060
affects: xorg (Ubuntu) → libcec (Ubuntu)
ill (illumilore) wrote :

lg webos tv. I never selected xorg package...

Is there a way to make ubuntu not queue sleep commands? I think the tv sends out about 5 shutdown commands using cec, then if the machine doesn't sleep fast enough it will queue them.

So once it gets a sleep command, ignore others until it wakes up again.

ill:
>"lg webos tv."

Unfortunately, that isn't a full model. Please see LG's website for reference:
http://www.lg.com/us/experience-tvs/smart-tv

>"I never selected xorg package..."

The bug was originally reported against the xorg package when you first reported it.

>"Is there a way to make ubuntu not queue sleep commands? I think the tv sends out about 5 shutdown commands using cec, then if the machine doesn't sleep fast enough it will queue them. So once it gets a sleep command, ignore others until it wakes up again."

You don't have to repeat what was already in the Bug Description. Despite this:

1) Is this something that started to happen after an update? If so, which?

2) A new version of libcec is available via http://cdimage.ubuntu.com/daily-live/current/ in the Proposed repository (4.0.2+dfsg1-2). Please test this, and advise to the results.

3) Please provide the relevant libcec logs before, during, and after the shutdown commands are sent.

Launchpad Janitor (janitor) wrote :

[Expired for libcec (Ubuntu) because there has been no activity for 60 days.]

Changed in libcec (Ubuntu):
status: Incomplete → Expired
ill (illumilore) wrote :

) Is this something that started to happen after an update? If so, which?

No, it always happened

Please test this, and advise to the results.

I will have to test this when it comes out in a week

Changed in libcec (Ubuntu):
status: Expired → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers