libcdio should be 0.92

Bug #1302241 reported by Leo B
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
libcdio (Ubuntu)
Fix Released
Wishlist
Unassigned

Bug Description

Description of problem:

Relevant to virtualization / devops / automation, libcdio from 0.83 to 0.90 it cannot read Linux .iso files that use Rock Ridge for file name encoding.

With libcdio up to 0.90 iso-read gives bad results for .iso files > 4GB. Relevant to virtualization / devops / automation, some Linux distro images are that large.

Steps to reproduce problem:

1. From bug report https://savannah.gnu.org/bugs/index.php?39373 get most recent file iso-read-test.sh at https://savannah.gnu.org/bugs/download.php?file_id=30554

2. Run that file either plain or with a single parameter 5000, such as
./iso-read-test.sh
./iso-read-test.sh 5000

3. At the end of output see a lot of "read DEFECT" where you should see nothing but "read back OK".

Actual results:

At the end of output see a lot of "read DEFECT".

Expected results:

You should see nothing but "read back OK".

Additional info:

There were more than one problems in libcdio 0.90, not just the 4G limit. E.g. Rock Ridge support (often needed for Linux) wasn't compiled in by default.

libcdio 0.92 fixes a lot of problems, and has been out for several months, and has been working well so far.

Relevant fixes cannot be isolated for patching 0.83.

There also is a discussion in docs files at https://github.com/srguiwiz/nrvr-commander/blob/master/docs/which-version-iso-read.txt

One example use at https://github.com/srguiwiz/nrvr-commander but this affects any attempt to make virtual machines from distro image .iso files as plain user.

An Ubuntu LTS should release with a healthy libcdio 0.92.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libcdio (Ubuntu):
status: New → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, trusty is feature frozen though, you need a ffe for that update (see https://wiki.ubuntu.com/FreezeExceptionProcess for details)

tags: added: upgrade-software-version
Changed in libcdio (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Jeremy Bicha (jbicha) wrote :
Changed in libcdio (Ubuntu):
status: Confirmed → Fix Committed
Changed in libcdio (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers