FFe: ibus-cangjie 2.1-1 (universe) from Debian unstable (main)

Bug #1294157 reported by Anthony Wong on 2014-03-18
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ibus-cangjie (Ubuntu)
Wishlist
Unassigned
libcangjie (Ubuntu)
Wishlist
Unassigned
pycangjie (Ubuntu)
Wishlist
Unassigned

Bug Description

Please sync ibus-canglie 2.1-1 (universe) from Debian unstable (main)

Explanation of FeatureFreeze exception:
Please see comment #2 for the explanation from upstream author.

Changed in libcangjie (Ubuntu):
importance: Undecided → Wishlist
Changed in ibus-cangjie (Ubuntu):
importance: Undecided → Wishlist
Changed in pycangjie (Ubuntu):
importance: Undecided → Wishlist
Iain Lane (laney) wrote :

Upstream are always going to tell you that their newest stuff is the best - I'm interested in how much testing you have done to verify this fact?

What has changed in these releases? That'll give you an idea of where to focus testing to see how solid they are.

Mathieu Bridon (bochecha) wrote :

Hey Iain,

I'm upstream for these 3 packages, so let me try to help here. :-)

I'm also a Fedora packager, so I do understand your concern about not pushing something just because it's the latest, but only if it's better for the users.

In the present case, those x.1 releases are really what should have been the x.0 ones. You know, the bugs you find right after you finally release something. ;-)

The full changelog for the three packages is here:
http://blog.fedora-fr.org/bochecha/post/2014/02/New-releases-from-the-Cangjians

IMHO, ibus-cangjie 2.1 really needs to get into Ubuntu 14.04 ASAP. Without this version, the users won't be able to change the settings for the input method, because the settings dialog just doesn't work.

The good news is that ibus-cangjie 2.1 would work fine with libcangjie 1.0 and pycangjie 1.0, so if you prefer being conservative, then you could update only ibus-cangjie. :-)

The changes in pycangjie are all really trivial: none of them touches the code. There is one that I feel is important though, as it adds the documentation to the tarball (and as such to the Ubuntu package?), which can be useful if someone wants to build an application using the pycangjie API. But the docs are available online anyway, so it's not critical either way.

As for libcangjie, there could be a bit more risks, as some changes happened to the code. However, we didn't break the API/ABI between 1.0 and 1.1, so either version would be fine for Ubuntu. We did fix a few memory leaks though, and added the API docs to the tarball (same omission as pycangjie), so it would still be nice to have it in 14.04.

Finally, for what it's worth, those same versions have been in Fedora for a few months now, so they did receive some testing.

To sum it all up: these are minor releases with only few changes. I'd prefer you upgrade everything, but if not please at least upgrade ibus-cangjie, because version 2.0 is busted.

Thanks. :-)

summary: - FFe: Sync libcangjie 1.1-1 (universe), pycangjie 1.1-1 (universe) and
- ibus-canglie 2.1-1 (universe) from Debian unstable (main)
+ FFe: ibus-canglie 2.1-1 (universe) from Debian unstable (main)
summary: - FFe: ibus-canglie 2.1-1 (universe) from Debian unstable (main)
+ FFe: ibus-cangjie 2.1-1 (universe) from Debian unstable (main)
Anthony Wong (anthonywong) wrote :

I have tested the following combination, and the input method works flawlessly, so I agree with Mathieu to only sync ibus-cangjie to 2.1-1, thanks.

ii ibus-cangjie 2.1-1 amd64 Cangjie and Quick input methods for IBus
ii indicator-keyboard 0.0.0+14.04.20140328.1-0ubuntu1 amd64 Keyboard indicator
ii libcangjie2:amd64 1.0-1 amd64 Cangjie input method library
ii libcangjie2-data 1.0-1 all Cangjie input method library (common database)
ii python3-pycangjie 1.0-1build1 amd64 Python wrapper to libcangjie

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ibus-cangjie (Ubuntu):
status: New → Confirmed
Changed in libcangjie (Ubuntu):
status: New → Confirmed
Changed in pycangjie (Ubuntu):
status: New → Confirmed
Iain Lane (laney) wrote :

Thanks Mathieu for your detailed explanation - it's much appreciated. :-)

Thanks Anthony for your testing, likewise!

Ack FFe - I'll sync this now.

Changed in libcangjie (Ubuntu):
status: Confirmed → Won't Fix
Changed in pycangjie (Ubuntu):
status: Confirmed → Won't Fix
Iain Lane (laney) wrote :

Nope, still needs to be a merge.

Iain Lane (laney) wrote :

Uploaded, ta

Changed in ibus-cangjie (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ibus-cangjie - 2.1-1ubuntu1

---------------
ibus-cangjie (2.1-1ubuntu1) trusty; urgency=low

  * Merge from Debian unstable (LP: #1294157). Remaining changes:
    + Use autotools-dev to update config.{sub,guess} for new arches.

ibus-cangjie (2.1-1) unstable; urgency=low

  * New upstream release.
 -- Iain Lane <email address hidden> Mon, 31 Mar 2014 13:46:09 +0100

Changed in ibus-cangjie (Ubuntu):
status: Fix Committed → Fix Released
Anthony Wong (anthonywong) wrote :

Thanks laney!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers