login sound does not play

Bug #862374 reported by Damian Beltrami on 2011-09-29
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
libcanberra (Ubuntu)
Undecided
Unassigned

Bug Description

the drum and login sound no longer plays in 11.10 beta 2

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-session-canberra 0.28-0ubuntu8
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Thu Sep 29 23:01:53 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_AU:en
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: libcanberra
UpgradeStatus: Upgraded to oneiric on 2011-09-29 (0 days ago)

Luke Yelavich (themuso) wrote :

I see you upgraded to oneiric. Was the login sound working prior to upgrade? As for the drums sound at login, that is a known issue that still needs addressing.

Are you able to play any other audio in oneiric?

Changed in libcanberra (Ubuntu):
status: New → Incomplete

Hi Luke,

Yes - had drums (I'm pretty sure) and the login sound after upgrade to Oneric. I believe this regressed somewhere around the Beta 2 upgrade.

I have sound through normal apps and I can find the login sound file and play it but if I try to run the command that plays the login file (canberra-gtk) manually I get a "failed to load module error"

mario escoto (mario7410) wrote :

I got the same error and I've been searching for a fix for about 2 weeks now.

mario escoto (mario7410) wrote :

I actually lost my sound when I got gnome 3 installed on oneiric beta 1, I'm pretty sure that's when it stopped working. I could be wrong.

David Henningsson (diwic) wrote :

There was a problem with libcanberra which was just fixed, which might or might not affect this problem as well: Can you see if version 0.28-0ubuntu10 of libcanberra resolves this problem? At least it should fix canberra-gtk-play.

I have applied all updates and am on 0.28-0ubuntu10.
Still no drums or login sound.

Heri Godina (hgodina25) wrote :

I installed 11.10 Beta 2 yesterday and after installing gnome-shell and all the required updates, I started to experience the same issue listed in this report. Upon troubleshooting the issue for a few hours, I found that /usr/bin/canberra-gtk-play does not look for the 'ogg' files under "/usr/share/sounds/ubuntu/stereo/". Instead, it expects the 'ogg' files to be under "/usr/share/sounds/".

Also, when attempting to manually run the "/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"", the following message was displayed in the terminal window:

Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap"
Failed to play sound: File or data not found

To clear the Gtk-WARNING message and get the login sound (drums) back, I performed the following steps:

1. sudo apt-get install gtk2-engines-pixbuf
     > This cleared the Gtk-WARNING
2. sudo cp /usr/share/sounds/ubuntu/stereo/* /usr/share/sounds/*

I hope this is fixed in the final release of ubuntu 11.10!

Hi Heri,

Thanks but this has not worked for me.

I have many issues like this where seemingly small details have regressed from 11.04. I hope it is just a Beta issue and they will be fixed by doing a clean install once 11.10 is released or soon after through updates.

Clean install of Ubuntu 11.10 has returned the login sound.
There are no drums, but I am not sure if this has been removed completely or is still a bug

Launchpad Janitor (janitor) wrote :

[Expired for libcanberra (Ubuntu) because there has been no activity for 60 days.]

Changed in libcanberra (Ubuntu):
status: Incomplete → Expired
Ahmed Fakhry (3d-immortal) wrote :

The same problem occurred to me suddenly, although I'm using ubuntu 11.10 the final release, and it's been working with me very well for the last 5 months. Just yesterday, it stopped playing the log-in sound, and I don't know why. To help you better identify the problem, this occurred after I had a dependency problem with the software update, and I had to fix it using
sudo apt-get install -f

I had to follow the instructions in comment #8 in this page to make the login sound work again.

Marcus Liebhardt (murcsack) wrote :

Here, too!
I have two 11.10 ubuntu's running in parallel. In one (the newer, fresh one) the login-in sound works fine and all sound files are placed in /usr/share/sounds/ubuntu/stereo.
In the other system, where I fiddled around a bit, login sound stopped suddenly and I had to copy the files to /usr/share/sounds.
Unfortunately, I can't really tell at which point it stopped working. But a bunch of package installations have definitely been involved in my doing (including an sudo apt-get install -f).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions