libcairo-ruby version 1.8.1-1build1 failed to build on i386

Bug #749099 reported by Matthias Klose on 2011-04-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libcairo-ruby (Debian)
Fix Released
Unknown
libcairo-ruby (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

libcairo-ruby version 1.8.1-1build1 failed to build on i386
Link to failed build: https://launchpad.net/ubuntu/+archive/test-rebuild-20110329/+buildjob/2398985

Direct link to the build log: https://launchpad.net/ubuntu/+archive/test-rebuild-20110329/+buildjob/2398985/+files/buildlog_ubuntu-natty-i386.libcairo-ruby_1.8.1-1build1_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 1416 lines into the build log:

 --with-override-variables
 --without-override-variables
 --with-pkg-config
 --without-pkg-config
 --with-override-variables
 --without-override-variables
 --with-pkg-config
 --without-pkg-config
 --with-override-variables
 --without-override-variables
./pkg-config.rb:131:in `parse_pc': .pc for gobject-2.0 doesn't exist. (RuntimeError)
 from ./pkg-config.rb:69:in `declaration'
 from ./pkg-config.rb:32:in `requires_private'
 from ./pkg-config.rb:87:in `collect_cflags'
 from ./pkg-config.rb:36:in `cflags'
 from ./pkg-config.rb:88:in `collect_cflags'
 from ./pkg-config.rb:87:in `collect'
 from ./pkg-config.rb:87:in `collect_cflags'
 from ./pkg-config.rb:36:in `cflags'
 from ./pkg-config.rb:258:in `cflags'
 from ./pkg-config.rb:301:in `have_package'
 from extconf.rb:81
yes
make: *** [install/libcairo-ruby1.8] Error 1
dpkg-buildpackage: error: /usr/bin/fakeroot debian/rules binary gave error exit status 2
******************************************************************************
Build finished at 20110403-1023
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/libcairo-ruby-1.8.1

Steve Langasek (vorlon) wrote :

Yes, libcairo-ruby includes a pkg-config.rb in its source which completely bypasses pkg-config. libcairo-ruby should be using pkg-config instead of reimplementing it.

Changed in libcairo-ruby (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
tags: added: multiarch
tags: added: oneiric
Changed in libcairo-ruby (Ubuntu):
milestone: none → oneiric-alpha-1
Changed in libcairo-ruby (Ubuntu Oneiric):
milestone: oneiric-alpha-1 → oneiric-alpha-2
Changed in libcairo-ruby (Ubuntu Oneiric):
milestone: oneiric-alpha-2 → none
tags: added: universe
Matthias Klose (doko) on 2011-09-08
Changed in libcairo-ruby (Ubuntu Oneiric):
importance: Medium → High
Changed in libcairo-ruby (Debian):
status: Unknown → New
Matthias Klose (doko) wrote :

remove and black-list

2011-09-22 19:15:32 INFO Removing candidates:
2011-09-22 19:15:32 INFO libcairo-ruby 1.8.1-1build1 in oneiric
2011-09-22 19:15:32 INFO Removed-by: Matthias Klose
2011-09-22 19:15:32 INFO Comment: FTFBS in oneiric, source renamed to ruby-cairo, see LP: #749099, Debian #634441
2011-09-22 19:15:32 INFO 1 package successfully removed.

Changed in libcairo-ruby (Ubuntu Oneiric):
status: Triaged → Fix Released
Changed in libcairo-ruby (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.