Please transition libbonoboui to multi-arch

Bug #977952 reported by Tom Ellis on 2012-04-10
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
libbonoboui (Ubuntu)
Medium
Canonical Foundations Team
Precise
Medium
Adam Stokes

Bug Description

[Impact]
Please transition libbonoboui to support multi-arch.

This package is still required by some third party applications.

[Test Case]
Build and install i386 packages on amd64 and attempt to link against the architecture specific library.

[Regression Potential]
Regression minimal as this change applies to building of library. All reverse build depends of this library need to have a test-rebuild done to make sure this change does not break them.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libbonoboui2-0 2.24.5-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
ApportVersion: 2.0-0ubuntu5
Architecture: amd64
Date: Tue Apr 10 12:15:29 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120401)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: libbonoboui
UpgradeStatus: No upgrade log present (probably fresh install)

Tom Ellis (tellis) wrote :
Changed in libbonoboui (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Tom Ellis (tellis) wrote :

I've attached a debdiff for review, to go along with the one from the libbonobui bug #977947

I've been testing this in my multi-arch ppa and it seems OK.
https://launchpad.net/~tellis/+archive/multiarch/

Tom Ellis (tellis) on 2012-04-17
Changed in libbonoboui (Ubuntu):
status: New → Confirmed

The attachment "libbonoboui_2.24.5-0ubuntu2.debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Jani Monoses (jani) wrote :

Can you update this for quantal?

Changed in libbonoboui (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libbonoboui - 2.24.5-0ubuntu2

---------------
libbonoboui (2.24.5-0ubuntu2) quantal; urgency=low

  * Rebuild with multi-arch support (LP: #977952)
 -- Tom Ellis <email address hidden> Tue, 17 Apr 2012 15:48:54 +0100

Changed in libbonoboui (Ubuntu):
status: Confirmed → Fix Released
Steve Langasek (vorlon) on 2012-06-04
Changed in libbonoboui (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Medium
Changed in libbonoboui (Ubuntu):
importance: Low → Medium
Changed in libbonoboui (Ubuntu Precise):
milestone: none → ubuntu-12.04.1
Sebastien Bacher (seb128) wrote :

unsubscribing sponsors since there is nothing to sponsor yet, we probably need to get libbonobo SRUed first if we want this one

Vibhav Pant (vibhavp) on 2012-06-14
Changed in libbonoboui (Ubuntu Precise):
assignee: nobody → Vibhav Pant (vibhavp)
Chris J Arges (arges) wrote :

This bug is blocked on http://pad.lv/977947 being fixed.

Vibhav Pant (vibhavp) on 2012-06-22
Changed in libbonoboui (Ubuntu Precise):
assignee: Vibhav Pant (vibhavp) → nobody
Adam Stokes (adam-stokes) wrote :

SRU added, and added new debdiff to target precise-proposed

description: updated
Adam Stokes (adam-stokes) wrote :

precise-proposed debdiff

Adam Stokes (adam-stokes) wrote :

There is a merge proposal and SRU waiting for libbonobo as well.

Thanks
Adam

Changed in libbonoboui (Ubuntu Precise):
assignee: nobody → Adam Stokes (adam-stokes)

Hello Tom, or anyone else affected,

Accepted libbonoboui into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libbonoboui/2.24.5-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in libbonoboui (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed
Adam Stokes (adam-stokes) wrote :

Verified installation and location of libraries are in their arch specific locations

tags: added: verification-done-precise
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libbonoboui - 2.24.5-0ubuntu1.1

---------------
libbonoboui (2.24.5-0ubuntu1.1) precise-proposed; urgency=low

  * Rebuild with multi-arch support (LP: #977952)
 -- Tom Ellis <email address hidden> Tue, 17 Apr 2012 15:48:54 +0100

Changed in libbonoboui (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers