libglade2-0 can't find libbonobo.so or libcanvas.so (those need to be multiarched)

Bug #1003964 reported by Graham Inggs on 2012-05-24
112
This bug affects 19 people
Affects Status Importance Assigned to Milestone
libbonoboui (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned
libglade2 (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned
libgnomecanvas (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

Impact: some optional libraries loaded by glade interface can't be found leading to non working uis

Test Case: install and run gurlchecker
without the patch the toolbar has no icon, with the fixed version it's working

Regression Potential: very limited, the patch is only adding an extra check for the fallback directory in the error case

---

Since upgrading to Precise Pangolin on an x86_64 system, some applications are failing with messages like the following:

libglade-WARNING **: Could not load support for `bonobo': libbonobo.so: cannot open shared object file: No such file or directory

The problem is libbonoboui2-0 and libgnomecanvas2-0 place shared libraries in /usr/lib/libglade/2.0/ but libglade2-0 expects to find them in /usr/lib/x86_64-linux-gnu/libglade/2.0/.

Graham Inggs (ginggs) on 2012-05-24
no longer affects: libgnomecanvas
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libbonoboui (Ubuntu):
status: New → Confirmed
Changed in libgnomecanvas (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you give an example of such application?

Changed in libgnomecanvas (Ubuntu):
status: Confirmed → Incomplete
Changed in libbonoboui (Ubuntu):
status: Confirmed → Incomplete
Graham Inggs (ginggs) wrote :

Sorry, 'gurlchecker' is an easy example. See https://bugs.launchpad.net/ubuntu/+source/gurlchecker/+bug/973673

Changed in libbonoboui (Ubuntu):
importance: Undecided → Low
status: Incomplete → New
Changed in libgnomecanvas (Ubuntu):
status: Incomplete → New
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

ok, confirmed, setting low because those libraries are deprecated for years and very few softwares use them still

Changed in libbonoboui (Ubuntu):
status: New → Confirmed
Changed in libgnomecanvas (Ubuntu):
status: New → Confirmed
Changed in libbonoboui (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → Low
Changed in libgnomecanvas (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → Low
Changed in libbonoboui (Ubuntu Precise):
milestone: none → precise-updates
Changed in libgnomecanvas (Ubuntu Precise):
milestone: none → precise-updates
summary: - libglade2-0 can't find libbonobo.so or libcanvas.so
+ libglade2-0 can't find libbonobo.so or libcanvas.so (those need to be
+ multiarched)
Sebastien Bacher (seb128) wrote :

bug #977952 has a libbonoboui port to multiarch, we might want add compat code to load from the old location in precise though

Changed in libglade (Ubuntu Precise):
importance: Undecided → Low
Changed in libglade (Ubuntu):
importance: Undecided → Low
Changed in libglade (Ubuntu Precise):
milestone: none → precise-updates
status: New → Confirmed
Changed in libglade (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

 libbonoboui (2.24.5-0ubuntu2) quantal; urgency=low
 .
   * Rebuild with multi-arch support (LP: #977952)

Changed in libbonoboui (Ubuntu):
status: Confirmed → Fix Released
affects: libglade (Ubuntu) → libglade2 (Ubuntu)

Confirmed to fix my reported problem with Camorama (bug 992730). Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libglade2 - 1:2.6.4-1ubuntu2

---------------
libglade2 (1:2.6.4-1ubuntu2) quantal; urgency=low

  * debian/patches/glade_multiarch_compat.patch:
    - look to the old glade lib for compatibility (lp: #1003964)
 -- Sebastien Bacher <email address hidden> Mon, 04 Jun 2012 19:26:04 +0200

Changed in libglade2 (Ubuntu):
status: Confirmed → Fix Released
description: updated
Changed in libglade2 (Ubuntu Precise):
status: Confirmed → Fix Committed

Hello Graham, or anyone else affected,

Accepted libglade2 into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Graham Inggs (ginggs) wrote :

Gurlchecker no longer segfaults with the new libglade2.

tags: added: verification-done
removed: verification-needed
cotillion (tobias-schwan) wrote :

I can confirm,

after installing the proposed package camorama was working.

Thank you!

gurlchecker works fine now.

David Ring
See www.vinuxproject.org for Ubuntu / Debian for Blind and Visually
Impaired Users - it talks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libglade2 - 1:2.6.4-1ubuntu1.1

---------------
libglade2 (1:2.6.4-1ubuntu1.1) precise-proposed; urgency=low

  * debian/patches/glade_multiarch_compat.patch:
    - look to the old glade lib for compatibility (lp: #1003964)
 -- Sebastien Bacher <email address hidden> Mon, 04 Jun 2012 19:26:04 +0200

Changed in libglade2 (Ubuntu Precise):
status: Fix Committed → Fix Released
Graham Inggs (ginggs) wrote :

LP: #1013211 contains a multi-arch patch for libgnomecanvas.

Changed in libbonoboui (Ubuntu Precise):
status: Confirmed → Fix Released
Changed in libgnomecanvas (Ubuntu):
status: Confirmed → Fix Released
Changed in libgnomecanvas (Ubuntu Precise):
status: Confirmed → Fix Committed
Graham Inggs (ginggs) on 2012-11-04
Changed in libgnomecanvas (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions