Please transition libbonobo to multi-arch

Bug #977947 reported by Tom Ellis on 2012-04-10
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
libbonobo (Ubuntu)
Medium
Adam Stokes
Precise
Medium
Steve Langasek
Quantal
Medium
Adam Stokes

Bug Description

[Impact]
Please transition libbonobo to support multi-arch.

This package is still required by some third party applications.

[Test Case]
Build and install i386 packages on amd64 and attempt to link against the architecture specific library.

[Regression Potential]
Regression minimal as this change applies to building of library. All reverse-build-deps need to have a test-rebuild done to make sure that moving the libs does not break them.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libbonobo2-0 2.32.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
ApportVersion: 2.0-0ubuntu5
Architecture: amd64
Date: Tue Apr 10 12:11:21 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120401)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: libbonobo
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Tom Ellis (tellis) wrote :
Changed in libbonobo (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Tom Ellis (tellis) wrote :

I've attached a debdiff for review.

I've been testing this in my multi-arch ppa and it seems OK.
https://launchpad.net/~tellis/+archive/multiarch/

Changed in libbonobo (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) wrote :

Hi Tom,

This patch needs work, similar to the one for orbit2.

 - libbonobo2-0 ships a file in a directory /usr/lib/bonobo/monikers/, which needs to be architecture qualified. No problem, this becomes /usr/lib/$arch/bonobo/monikers/libmoniker_std_2.so.
 - the resolution of the moniker file happens via /usr/lib/bonobo/servers/Bonobo_Moniker_std.server. Since it now references a file path that's architecture-dependent, the file needs to be moved to an architecture-qualified directory. However, this file is shipped in libbonobo2-common, which is an Architecture: all package. So this file needs at the same time to be in a multi-arch: foreign, architecture: any package - probably by moving it to libbonobo2-0, since that's the package containing the module itself.
 - Since there are other packages that install files to /usr/lib/bonobo/servers/, libbonobo needs to retain support for this directory as a fallback, similar to what's implemented in orbit2.

Changed in libbonobo (Ubuntu):
status: Confirmed → Incomplete
Steve Langasek (vorlon) wrote :

Oh, and one more point: the libbonobo2-0 that installs /usr/lib/$arch/orbit-2.0/Bonobo_module.so needs to have a versioned dependency on the liborbit2 that adds support for reading from this directory. This dependency will need to be added manually in libbonobo2.

Changed in libbonobo (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium

The attachment "libbonobo_2.32.1-0ubuntu2.debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Steve Langasek (vorlon) on 2012-04-23
Changed in libbonobo (Ubuntu Quantal):
status: New → Triaged
importance: Undecided → Medium
Changed in libbonobo (Ubuntu Precise):
milestone: none → ubuntu-12.04.1
description: updated
Changed in libbonobo (Ubuntu Precise):
assignee: Canonical Foundations Team (canonical-foundations) → Adam Stokes (adam-stokes)
Changed in libbonobo (Ubuntu Quantal):
assignee: nobody → Adam Stokes (adam-stokes)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libbonobo - 2.32.1-0ubuntu2

---------------
libbonobo (2.32.1-0ubuntu2) quantal; urgency=low

  * Rebuild with multi-arch support (LP: #977947)
  * Add versioned dependency on the version of liborbit2 that will look
    in the multiarch path for its modules.
  * Drop the .la file which is no longer used.
 -- Adam Stokes <email address hidden> Fri, 29 Jun 2012 14:59:54 -0400

Changed in libbonobo (Ubuntu Quantal):
status: Triaged → Fix Released
Steve Langasek (vorlon) wrote :

uploaded to precise-proposed.

Changed in libbonobo (Ubuntu Precise):
status: Triaged → In Progress
assignee: Adam Stokes (adam-stokes) → Steve Langasek (vorlon)

Hello Tom, or anyone else affected,

Accepted libbonobo into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libbonobo/2.32.1-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in libbonobo (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Adam Stokes (adam-stokes) wrote :

Verified installation and libraries are in their respective arch specific locations on Precise

tags: added: verification-done-precise
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libbonobo - 2.32.1-0ubuntu1.1

---------------
libbonobo (2.32.1-0ubuntu1.1) precise-proposed; urgency=low

  * Rebuild with multi-arch support (LP: #977947)
  * Add versioned dependency on the version of liborbit2 that will look
    in the multiarch path for its modules.
  * Drop the .la file which is no longer used.
 -- Adam Stokes <email address hidden> Fri, 29 Jun 2012 14:59:54 -0400

Changed in libbonobo (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers