bonobo-activation-server segfaults and many gnome applets do not start when the date is set too early

Bug #422215 reported by Nathaniel Wilson on 2009-08-31
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libbonobo (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-panel

If the system clock is set to too early a date, there are many gnome-panel applets that will not start. Some of them are the clock applet, the notification area, and the user switcher.

I'm not sure what the threshold date is, but my ibook g4 has a bad logic board and resets the date to Jan. 1st 1904 on every boot. If I start the computer without an internet connection, I get a lot of error messages when gnome loads. If internet is available, then the time gets updated before the panel loads and there are no problems.

If you want to reproduce this error, just set the system time to a ridiculously old date and start ubuntu without internet available.

Sebastien Bacher (seb128) wrote :

Thanks for the bug report. This particular bug has already been reported, but feel free to report any other bugs you find.

affects: gnome-panel (Ubuntu) → libbonobo (Ubuntu)
Changed in libbonobo (Ubuntu):
importance: Undecided → Low
status: New → Invalid
robepisc (robepisc) on 2010-07-30
Changed in libbonobo (Ubuntu):
status: Invalid → Confirmed
robepisc (robepisc) wrote :

Sorry Sebastien, after extensive search (well, I did my best...) I couldn't find any bug this one is a duplicate of and you forgot to indicate this information.

So I reopen and confirm this bug on my Lucid machine, whose CMOS battery has died some months ago.

On every boot, the clock is set to Jan 1st 1904 and this makes bonobo-activation-server segfault, because of an overflow in a timestamp comparison, since that time is far below the UNIX epoch.
See https://bugs.launchpad.net/ubuntu/+source/libbonobo/+bug/90923/comments/22 (a comment by Glen Turner in an unrelated bug which is however pertinent here) for details.

What's worst is that this makes gnome-panel emit a number of "applet failed to load" popups. In general, anything requiring Bonobo fails to boot, making my Gnome sessions almost unusable.

summary: - Many gnome applets do not start when the date is set too early
+ bonobo-activation-server segfaults and many gnome applets do not start
+ when the date is set too early
robepisc (robepisc) wrote :

I suppose the same error may happen in many other programs which expect the current time is above 1970-01-01.
So probably it would be a good idea for hwclock's upstart job to force the HW clock to 1970-01-01 whenever it is below that.
Please, tell me if I should open another bug for that (on package "util-linux"?).

Whenever bonobo-activation-server segfaults, running "sudo hwclock -r" returns this:
The Hardware Clock registers contain values that are either invalid (e.g. 50th day of month) or beyond the range we can handle (e.g. Year 2095).

And here's what goes into dmesg:
[ 98.919182] bonobo-activati[1519]: segfault at 4 ip 08052922 sp b7579e30 error 4 in bonobo-activation-server[8048000+15000]
[ 100.794036] bonobo-activati[1526]: segfault at 4 ip 08052922 sp b6d97e30 error 4 in bonobo-activation-server[8048000+15000]
[ 195.958973] bonobo-activati[1587]: segfault at 4 ip 08052922 sp b6d45e30 error 4 in bonobo-activation-server[8048000+15000]
[ 197.164949] bonobo-activati[1593]: segfault at 4 ip 08052922 sp b6d38e30 error 4 in bonobo-activation-server[8048000+15000]
[ 198.349928] bonobo-activati[1598]: segfault at 4 ip 08052922 sp b6ee1e30 error 4 in bonobo-activation-server[8048000+15000]

Glen Turner (gdt-gdt) wrote :

robepisc pointed this discussion out to me. See bug 90923 comment 19 onwards.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers