Ubuntu

/usr/lib/neon/vfp/libavformat.so.52: symbol __aeabi_d2lz, version LIBAVCODEC_52 not defined in file libavcodec.so.52 with link time reference

Reported by Marcin Juszkiewicz on 2011-05-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libav (Debian)
Fix Released
Unknown
libav (Ubuntu)
Low
Ubuntu ARM Team

Bug Description

Today during attempt to play DivX encoded cartoon on PandaBoard I got:

linaro@linaro:~$ gst123 /media/9C2A-28A2/Noddy\ -\ Glodne\ kurczaki.avi

(process:1469): GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0

(process:1469): GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0

(process:1469): GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0

(process:1469): GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/goption.c:2132: ignoring no-arg, optional-arg or filename flags (16) on option of type 6

(process:1469): Gtk-WARNING **: Locale not supported by C library.
 Using the fallback 'C' locale.

(gst-plugin-scanner:1472): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstffmpeg.so': /usr/lib/neon/vfp/libavformat.so.52: symbol __aeabi_d2lz, version LIBAVCODEC_52 not defined in file libavcodec.so.52 with link time reference

Playing file:///media/9C2A-28A2/Noddy - Glodne kurczaki.avi

Codec : MPEG 1 Audio, Layer 3 (MP3) (audio) DivX MPEG-4 Vers Bitrate : 192.0 kbit/s

Interesting issue...

On Tue, May 24, 2011 at 12:58:23 (CEST), Marcin Juszkiewicz wrote:

[...]

> (gst-plugin-scanner:1472): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstffmpeg.so': /usr/lib/neon/vfp/libavformat.so.52: symbol __aeabi_d2lz, version LIBAVCODEC_52 not defined in file libavcodec.so.52 with link time reference

Can you please remove the file /usr/lib/neon/vfp/libavformat.so.52?
gstreamer should then fallback to /usr/lib/libavformat.so.52. I'm
curious if that works then.

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Marcin Juszkiewicz (hrw) wrote :

(gst-plugin-scanner:2025): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstffmpeg.so': /usr/lib/libavformat.so.52: symbol __aeabi_d2lz, version LIBAVCODEC_52 not defined in file libavcodec.so.52 with link time reference

Reinhard Tartler (siretart) wrote :

Loïc,

can you please reassign this issue to some arm porter? I think the confflags for armel are broken.

Changed in libav (Ubuntu):
assignee: nobody → Loïc Minier (lool)
Reinhard Tartler (siretart) wrote :

confirming based on plausible report. Still, this bug needs an arm porter to investigate more closely

Changed in libav (Ubuntu):
assignee: Loïc Minier (lool) → Ubuntu armel porters (ubuntu-armel)
status: New → Confirmed
tags: added: arm-porting-queue
Changed in libav (Ubuntu):
importance: Undecided → Low
Changed in libav (Debian):
status: Unknown → Confirmed
Changed in libav (Debian):
status: Confirmed → Fix Released
Fabrice Coutadeur (fabricesp) wrote :

Hi,

According to the Debian bug report and my own experience with a similar issue when building dvdstyler, it was a toolchain issue on arm that has been fixed since then.

Do you confirm that you still have the issue on your Pandaboard, with 0.10.12-1ubuntu1?I will try to reproduce it in a schroot, but It's quite complicated for the moment.

thanks,
Fabrice

Changed in libav (Ubuntu):
status: Confirmed → Incomplete
Marcin Juszkiewicz (hrw) wrote :

With gst123 I do not have this error anymore.

Changed in libav (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.