avplay: fails to decode opus

Bug #1265196 reported by Doug McMahon on 2013-12-31
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libav (Debian)
Fix Released
Unknown
libav (Ubuntu)
Wishlist
Unassigned

Bug Description

Also affects some players that use avcodec/format like mpv, audacious, deadbeef, ect.
Test case:
Try to play an opus file with avplay

Result:
avplay version 9.10-6:9.10-1ubuntu7, Copyright (c) 2003-2013 the Libav developers
  built on Dec 23 2013 20:10:59 with gcc 4.8 (Ubuntu/Linaro 4.8.2-10ubuntu2)
[ogg @ 0x7f6b78005be0] Codec not found

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: libavcodec54 (not installed)
ProcVersionSignature: Ubuntu 3.12.0-7.15-generic 3.12.4
Uname: Linux 3.12.0-7-generic x86_64
ApportVersion: 2.12.7-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Dec 31 09:19:48 2013
SourcePackage: libav
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libav (Ubuntu):
status: New → Confirmed
Daniel Letzeisen (dtl131) wrote :

Doug, user is reporting mpv plays opus okay in Trusty: https://bugs.launchpad.net/ubuntu/+source/audacious-plugins/+bug/1265386

Doug McMahon (mc3man) wrote :

I know Micheal mentioned that to me elsewhere but I don't see it.
Attached log of avplay & mpv failing on a sample opus clip created with opusenc, also shows ffplay having no issue

Note that I've tested on another brand new install of 14.04, straight up with only repo packages

Doug McMahon (mc3man) wrote :

To test one could take any supported file & encode to .opus, a .wav or .flac will do
For convience will attach small clip, encoded with opusenc defaults from a .wav

Is an idea for a new feature.

Changed in libav (Ubuntu):
importance: Undecided → Wishlist
Doug McMahon (mc3man) wrote :
Reinhard Tartler (siretart) wrote :

This patch is included in libav 9.11, which I've uploaded to unstable recently. We really should sync it into ubuntu as well.

Changed in libav (Debian):
status: Unknown → Fix Released

The attachment "add_opus.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libav - 6:9.11-2ubuntu1

---------------
libav (6:9.11-2ubuntu1) trusty; urgency=low

  * Merge from unstable, remaining changes:
    - build-depend on libtiff5-dev rather than libtiff4-dev,
      avoids FTBFS caused by imlib
  * This version of libav supports Opus in Ogg (LP: #1265196)

libav (6:9.11-2) unstable; urgency=low

  * Avoid the use of pipes to not cover segfaulting libavcodecs (cf. #726733)
  * refactor call_and_install_avconv_dump functionality
  * Rebuild against libfreetype 2.5.1 (closes: #731307)
  * i386 shared builds must be optimized for 586, (closes: 728928, #688384)

libav (6:9.11-1) unstable; urgency=low

  * Imported Upstream version 9.11
    - drop patch mathematics-remove-asserts-from-av_rescale_rnd.patch,
      merged upstream
    - mathematics: remove asserts from av_rescale_rnd, (Closes: #718805)
  * Support Opus in Ogg containers (Closes: #733884, 720563)
  * Refactor conffile moving
  * No longer build-depend on libtiff4-dev. Closes: #736020
  * Disable opencv filter because of #737584
  * Check upstream OpenPGP signatures (Closes: #723692)

libav (6:9.10-3) unstable; urgency=low

  * Add upstream patch: mathematics: remove asserts from av_rescale_rnd
    Closes: #718805
  * Remove the makeinfo patch, it just disables generation of the html
    equivalents of the manpages
  * No longer build-depend on libtiff4-dev. Closes: #736020

libav (6:9.10-2) unstable; urgency=low

  [ Fabian Greffrath ]
  * Fix upstream changelog link in previous changelog entry.
  * Transition from the "texi2html" utility to the "makeinfo" utility from the
    texinfo package, fixes build-depends-on-obsolete-package lintian error and
    addresses <https://lists.debian.org/debian-devel/2013/05/msg01516.html>.
  * debhelper (>= 9) is now available in stable and old-bpo.
  * Use "set -e" in the body of the libav-tools maintainer scripts.
  * Fix vcs-field-not-canonical lintian warning.
  * Set executable permissions for qt-faststart, fixes unstripped-binary-or-object
    lintian warning.
  * Fix some spelling errors detected by lintian.

  [ Reinhard Tartler ]
  * compile against libtiff5-dev
  * Drop some special code paths for building the ubuntu flavor
    (no longer necessary over there)
 -- Reinhard Tartler <email address hidden> Sun, 02 Mar 2014 14:57:25 -0500

Changed in libav (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.