Ubuntu

avconv: bad two first frames when mpeg2video encoding

Reported by Ilya Murav'jov on 2012-07-11
52
This bug affects 11 people
Affects Status Importance Assigned to Milestone
libav
Fix Released
High
libav (Ubuntu)
Undecided
Unassigned

Bug Description

The quote from https://ffmpeg.org/trac/ffmpeg/ticket/880 :
"
When I encode using <b>mpeg2video</b>, in resulting video I have first two
frames in very low quality.
"

This bug was introduced in
http://git.videolan.org/?p=ffmpeg.git;a=commit;h=3009f521f390b2bd440d9747a9c6baf648b2087a
and now already fixed in ffmpeg (but not in libav).

P.S. I am the developer of Bombono DVD program, and this bug hurts the users of it, see http://forum.bombono.org/viewtopic.php?f=1&p=15788 . I filled in the issue in libav bugzilla, see http://bugzilla.libav.org/show_bug.cgi?id=222 , but there is no activity about it. Please fix it.

Ilya Murav'jov (muravjov-il) wrote :

The attachment "This patch fixes the bug." of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libav (Ubuntu):
status: New → Confirmed
Bob (b-launchpad-thebellsplace) wrote :

Can this patch be applied? I basically cannot use bombono as-is, and need to look into some manual work-arounds.

Changed in libav:
importance: Unknown → High
status: Unknown → Confirmed
Changed in libav:
status: Confirmed → Fix Released
Tim (traggatt) wrote :

Does anyone have a workaround for this issue?

Bryce Harrington (bryce) wrote :

From the upstream bug, this got fixed in master around Jan 13-15th, 2013. However, I did not find the upstream patch, and the current codebase does not reflect the fix provided in #1.

Perhaps someone should re-open the upstream bug?
Meanwhile, it may not be a bad idea to include this in the Ubuntu package.

Ilya Murav'jov (muravjov-il) wrote :

Hi Bryce,
As far as I understand this bug is fixed in version 9.x and higher, see commit e44d56b18d46957fceaefe7f8840263c5cd12d37 .

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.