libatomic-ops version 7.2~alpha5+cvs20101124-1ubuntu1 failed to build on i386

Bug #765912 reported by Matthias Klose on 2011-04-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libatomic-ops (Debian)
Fix Released
Unknown
libatomic-ops (Ubuntu)
High
Adam Conrad
Oneiric
High
Unassigned
Precise
Undecided
Adam Conrad

Bug Description

libatomic-ops version 7.2~alpha5+cvs20101124-1ubuntu1 failed to build on i386
Link to failed build: https://launchpad.net/ubuntu/+archive/test-rebuild-20110413/+buildjob/2456393

Direct link to the build log: https://launchpad.net/ubuntu/+archive/test-rebuild-20110413/+buildjob/2456393/+files/buildlog_ubuntu-natty-i386.libatomic-ops_7.2%7Ealpha5%2Bcvs20101124-1ubuntu1_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 1194 lines into the build log:

Performing 1000 reversals of 1000 element lists in 10 threads
PASS: test_malloc
===================
1 of 4 tests failed
===================
make[4]: *** [check-TESTS] Error 1
make[4]: Leaving directory `/build/buildd/libatomic-ops-7.2~alpha5+cvs20101124/tests'
make[3]: *** [check-am] Error 2
make[3]: Leaving directory `/build/buildd/libatomic-ops-7.2~alpha5+cvs20101124/tests'
make[2]: *** [check] Error 2
make[2]: Leaving directory `/build/buildd/libatomic-ops-7.2~alpha5+cvs20101124/tests'
make[1]: *** [check-recursive] Error 1
make[1]: Leaving directory `/build/buildd/libatomic-ops-7.2~alpha5+cvs20101124'
make: *** [debian/stamp-makefile-check] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20110416-1216
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/libatomic-ops-7.2~alpha5+cvs20101124

Matthias Klose (doko) on 2011-04-19
Changed in libatomic-ops (Ubuntu):
importance: Undecided → High
Changed in libatomic-ops (Ubuntu):
milestone: none → oneiric-alpha-3
Andreas Moog (ampelbein) wrote :

I can't reproduce this build failure, neither in a chroot nor in pbuilder.

Changed in libatomic-ops (Ubuntu Oneiric):
status: New → Incomplete
tags: added: main
Changed in libatomic-ops (Ubuntu Oneiric):
milestone: oneiric-alpha-3 → none
Matthias Klose (doko) wrote :

this seems to be an issue with the virtualized buildds; see bug #829253

Changed in libatomic-ops (Ubuntu Oneiric):
status: Incomplete → Confirmed
Steve Langasek (vorlon) wrote :

since this is specific to virtualized builders, and all main-archive builds are done on non-virtualized builders, turfing this for oneiric.

Changed in libatomic-ops (Ubuntu Oneiric):
status: Confirmed → Won't Fix
Matthias Klose (doko) wrote :

keeping the report open, so that not a new one is opened for the next test rebuild

Colin Watson (cjwatson) wrote :

I can reproduce this in pbuilder.

Colin Watson (cjwatson) wrote :

Even the latest upstream release doesn't reliably pass this test.

Changed in libatomic-ops (Debian):
status: Unknown → New
Changed in libatomic-ops (Debian):
status: New → Fix Released
Adam Conrad (adconrad) wrote :

This might be worth fixing in precise too, given that the testsuite failure indicates an actual runtime issue.

Changed in libatomic-ops (Ubuntu):
assignee: nobody → Adam Conrad (adconrad)
Changed in libatomic-ops (Ubuntu Precise):
assignee: nobody → Adam Conrad (adconrad)
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libatomic-ops - 7.2~alpha5+cvs20101124-1+deb7u0ubuntu1

---------------
libatomic-ops (7.2~alpha5+cvs20101124-1+deb7u0ubuntu1) quantal; urgency=low

  * Merge from Debian, fixing FTBFS (LP: #765912), remaining changes:
    - src/atomic_ops/sysdeps/gcc/arm.h:
      + Fix inline asm for for data memory barrier on arm.
 -- Adam Conrad <email address hidden> Thu, 11 Oct 2012 01:39:46 -0600

Changed in libatomic-ops (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.