Inverted Arabic subtitle when saa/aas activated

Bug #915777 reported by Mr_NooOooB on 2012-01-13
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
libass (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 11.10 32 bit
smplayer2 0.7.0~pre-0+bzr46+pack6+201112222229~oneiric1
xt7-player 2.9.1042-201201101455~oneiric
libass4 0.9.13-1
========================================================

the bug is the Arabic subtitle show inverted if ssa/ass enabled

there is some screen shots with ssa/aas enabled :

first on smplayer2

http://i.minus.com/ip8hAd9z8Iy4P.png

http://i.minus.com/ibns7PXTqvG8v.png

========================================================

xt7-player

http://i.minus.com/iDRQKNPYXp3rN.png

http://i.minus.com/ibidTfa1DG1hU.png

========================================================

screen shots with no ssa/aas = disabled:

smplayer2

http://i.minus.com/ijTcyZ3y7wMVr.png

http://i.minus.com/iZc0MW4gqiI8H.png

=======

xt7-player

http://i.minus.com/iDRQKNPYXp3rN.png

http://i.minus.com/i3meJ8qqeR4TN.png

========================================================

the font become ugly if ssa/aas disabled..

i uploaded log files from xt7-player

========================================================

i tried to fix this by install this packages:
libass-0.10.0
fontconfig-2.8.0
freetype-2.4.8
fribidi-0.19.2
libxml2-2.7.8

========================================================

i think the fix of this bus is build libass with fribidi support ..

sorry for my english

Mr_NooOooB (dooodbooob) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libass (Ubuntu):
status: New → Confirmed
mrtoolate (mrtoolate) wrote :

hi
this bug effects
ubuntu 11.04 32-bit libass4 0.9.11-1
ubuntu 11.10 64-bit libass4 0.9.13-1

right to left languages like Arabic and Hebrew
not shown correctly because lack of Bidirectional support

to fix this bug build libass with fribidi support

mbz99 (mbz-99) wrote :

the version of libass that exists in 11.10 not working properly with mplayer2 and others.

the version of libass that exists in 12.04 should be release to 11.04 as hotfix since the package has no depenencies at all.

mbz99 (mbz-99) wrote :

The versions needs to released to 11.10:

libass-dev_0.10.0-2_amd64.deb (68.2 KiB)
libass-dev_0.10.0-2_armel.deb (56.7 KiB)
libass-dev_0.10.0-2_armhf.deb (57.1 KiB)
libass-dev_0.10.0-2_i386.deb (64.6 KiB)
libass-dev_0.10.0-2_powerpc.deb (72.2 KiB)
libass4_0.10.0-2_amd64.deb (57.1 KiB)
libass4_0.10.0-2_armel.deb (50.8 KiB)
libass4_0.10.0-2_armhf.deb (50.7 KiB)
libass4_0.10.0-2_i386.deb (58.8 KiB)
libass4_0.10.0-2_powerpc.deb (62.3 KiB)

mbz99 (mbz-99) on 2012-01-18
Changed in libass (Ubuntu):
status: Confirmed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libass (Ubuntu):
status: New → Confirmed
Sebastian Ramacher (s-ramacher) wrote :

Fixed in 0.10.0-2.

Changed in libass (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments