Ubuntu

Please transition libart-lgpl to multi-arch

Reported by Tom Ellis on 2012-04-10
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
libart-lgpl (Debian)
Fix Released
Unknown
libart-lgpl (Ubuntu)
Medium
Unassigned
Precise
Medium
Adam Stokes

Bug Description

[Impact]
Please transition libart-lgpl to support multi-arch.

This package is still required by some third party applications.

[Test Case]
Build and install i386 packages on amd64 and attempt to link against the architecture specific library.

[Regression Potential]
May cause regressions in anything that tries to dynamically load the library by path, due to the change in filesystem location.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libart-2.0-2 2.3.21-1
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
ApportVersion: 2.0-0ubuntu5
Architecture: amd64
Date: Tue Apr 10 12:32:22 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120401)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: libart-lgpl
UpgradeStatus: No upgrade log present (probably fresh install)

Tom Ellis (tellis) wrote :
Changed in libart-lgpl (Debian):
status: Unknown → New
Tom Ellis (tellis) wrote :

There seems to be a package for this waiting on mentorship upstream in Debian according to the debian bug.

Tom Ellis (tellis) wrote :

Updated my experimental multi-arch ppa libart package to include the differences that were added upstream on the debian bug, testing here:
https://launchpad.net/~tellis/+archive/multiarch

Changed in libart-lgpl (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libart-lgpl (Ubuntu):
status: New → Confirmed
Chris J Arges (arges) on 2012-06-14
Changed in libart-lgpl (Ubuntu Precise):
milestone: none → ubuntu-12.04.1
status: New → Confirmed
Changed in libart-lgpl (Ubuntu):
importance: Undecided → Medium
Changed in libart-lgpl (Ubuntu Precise):
importance: Undecided → Medium
Changed in libart-lgpl (Debian):
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

https://launchpad.net/ubuntu/+source/libart-lgpl/2.3.21-2

"libart-lgpl (2.3.21-2) unstable; urgency=low
...
  * Convert to multiarch. Closes: #661714
..."

Changed in libart-lgpl (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → nobody
status: Confirmed → Fix Released
Steve Langasek (vorlon) on 2012-06-18
Changed in libart-lgpl (Ubuntu Precise):
status: Confirmed → Triaged
description: updated
Adam Stokes (adam-stokes) wrote :

SRU and attached debdiff for -proposed done.

Thanks,
Adam

Sebastien Bacher (seb128) wrote :

hum, the upload got rejected, I guess that's by lack of bug reference, reuploading with one

Changed in libart-lgpl (Ubuntu Precise):
assignee: nobody → Adam Stokes (adam-stokes)
Chris Halse Rogers (raof) wrote :

@Seb: Yeah, I rejected the previous upload (and sent an email to Adam) because it had no bug reference.

I'm not thrilled about the superfluous packaging changes in this SRU - switching to DH9, dropping patches in favour of dh_autoreconf, dropping the .la file, and switching to 3.0 (quilt).

Are these changes taken from somewhere else, either Debian or the Quantal package? If so, could this be mentioned in the changelog?
Doesn't dropping the .la files present a risk that rdepends (either in the archive or of 3rd party software) will fail to build?

To what extent have the in-archive rdepends been tested with this? The list, for testing, would be:
  winefish
  sanduhr
  resapplet
  python-renderpm-dbg
  planner
  pegsolitaire
  oregano
  mathwar
  libgnomeuimm-2.6-1c2a
  libgnomeprintui2.2-0
  libgnomeprint2.2-0
  libgnomecanvasmm-2.6-1c2a
  libflowcanvas5
  grcm
  gpiv-mpi
  gpiv
  gnustep-back0.20-art
  gnomekiss
  gniall
  gcursor
  gamazons
  dia-libs
  conglomerate
  atomix
  ardour
  python-renderpm
  libgnomeui-0
  libgnomecanvas2-0
  libbonoboui2-0
  libart2.0-cil

Changed in libart-lgpl (Ubuntu Precise):
status: Triaged → In Progress
Scott Kitterman (kitterman) wrote :

And I rejected it again.

SRU's should be miminal changes to fix the bug in question.

Of these items:

+libart-lgpl (2.3.21-1ubuntu1) precise-proposed; urgency=low
+
+ * Use dpkg source format 3.0 (quilt).
+ * Drop debian/patches/70_relibtoolize.patch and use dh-autoreconf instead to
+ update the build system.
+ * Bump debhelper compat level to 9.
+ * Stip debian/tmp/ from .install files.
+ * Convert to multiarch. Closes: #661714 (lp: #977964)
+ * Drop libtool .la file.
+ * Add Vcs-* fields.
+ * Bump Standards-Version to 3.9.3.
+ * Add symbols file for libart-2.0-2.

As far as I can tell, only "Convert to multiarch." is addressing a bug. Is addressing a bug. There is 186.0 KiB of diff here and only one there's only three lines of code that're changed due to multiarch.

For an SRU, please make it truly minimal.

Scott Kitterman (kitterman) wrote :

Actually I pressed the wrong button by mistake and accepted it. I'll remove it, but you'll have to use a higher version number when you reupload.

Adam Stokes (adam-stokes) wrote :

Thats fine. The question I have is do we want to base the multiarch of quantal's version? If so, then the previous changes apply and we can then backport to precise. Updating the changelog and bumping rev is easy enough to reflect this.

My rdepends testing for libart on quantal build host:

./gnomekiss_2.0-4-amd64-20120807-1512:Status: successful
./dia_0.97.2-8-amd64-20120807-1422:Status: successful
./flowcanvas_0.7.1+dfsg0-0.2-amd64-20120807-1441:Status: successful
./firestarter_1.0.3-11-amd64-20120807-1436:Status: successful
./gmfsk_0.6+0.7pre1-2.3-amd64-20120807-1502:Status: successful
./mathwar_0.2.5-2-amd64-20120807-1623:Status: successful
./gnome-sharp2_2.24.2-2-amd64-20120807-1517:Status: successful
./libgnomeui_2.24.5-2ubuntu2-amd64-20120807-1609:Status: successful
./conglomerate_0.9.1-3.2ubuntu1-amd64-20120807-1415:Status: successful
./python-reportlab_2.5-1.1build1-amd64-20120807-1645:Status: successful
./sanduhr_1.93-4-amd64-20120807-1651:Status: successful
./wxsvg_1.1.8~dfsg0-2-amd64-20120807-1700:Status: successful
./libgnomecanvas_2.30.3-1ubuntu1-amd64-20120807-1551:Status: successful
./libgnomeprintui_2.18.6-3ubuntu1-amd64-20120807-1604:Status: successful
./gpiv_0.6.1-2-amd64-20120807-1531:Status: successful
./pegsolitaire_0.0.4-1-amd64-20120807-1633:Status: successful
./gcursor_0.061-ubuntu5-amd64-20120807-1451:Status: successful
./gnustep-back_0.20.1-2ubuntu1-amd64-20120807-1526:Status: successful
./oregano_0.70-1ubuntu1-amd64-20120807-1628:Status: successful
./winefish_1.3.3-0dl1ubuntu1-amd64-20120807-1656:Status: successful
./gniall_0.7.1-7-amd64-20120807-1508:Status: successful
./gamazons_0.83-4-amd64-20120807-1445:Status: successful
./planner_0.14.6-1ubuntu1-amd64-20120807-1638:Status: successful
./atomix_2.14.0-2ubuntu1-amd64-20120807-1409:Status: successful
./ardour_2.8.12+svn12923-1-amd64-20120807-1352:Status: successful
./libbonoboui_2.24.5-0ubuntu2-amd64-20120807-1542:Status: successful
./gjiten_2.6-2.2ubuntu1-amd64-20120807-1455:Status: successful
./resapplet_0.0.7+cvs2005.09.30-0ubuntu5-amd64-20120807-1647:Status: successful
./grcm_0.1.6-1ubuntu1-amd64-20120807-1538:Status: successful
./libgnomecanvasmm2.6_2.26.0-1build1-amd64-20120807-1555:Status: successful
./libgnomeprint_2.18.8-3ubuntu1-amd64-20120807-1600:Status: successful
./libgnomeuimm2.6_2.28.0-1-amd64-20120807-1616:Status: successful

Adam Stokes (adam-stokes) wrote :

Updated rdeps testing for libart with recent MP

wxsvg_1.1.6~dfsg-1-amd64-20120810-1151:Status: successful
libgnomeprint_2.18.8-3ubuntu1-amd64-20120810-1142:Status: successful
libgnomeprintui_2.18.6-3ubuntu1-amd64-20120810-1146:Status: successful
libgnomecanvas_2.30.3-1ubuntu1-amd64-20120810-1136:Status: successful

Changed in libart-lgpl (Ubuntu Precise):
milestone: ubuntu-12.04.1 → ubuntu-12.04.2

Hello Tom, or anyone else affected,

Accepted libart-lgpl into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libart-lgpl/2.3.21-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in libart-lgpl (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) wrote :

For reference:

> Doesn't dropping the .la files present a risk that rdepends
> (either in the archive or of 3rd party software) will fail to build?

This should only ever be a problem if there are other reverse-dependencies in the archive which reference this .la file in .la files of their own, and that's not the case here.

Cláudio Carvalho (clavalho) wrote :

Bug fixed. I managed to install the i386 within an amd64 environment, no error, no removal, nor unmet dependencies. The i386 and amd64 are now co-installable.
Could you please commit it into mainstream?
Thanks.

Adam Stokes (adam-stokes) wrote :

Thanks for testing it should be making it's way into the main repo soon.

tags: added: verification-done-precise
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libart-lgpl - 2.3.21-1ubuntu0.1

---------------
libart-lgpl (2.3.21-1ubuntu0.1) precise-proposed; urgency=low

  * Add multiarch support (LP: #977964)
 -- Adam Stokes <email address hidden> Fri, 10 Aug 2012 11:47:01 -0400

Changed in libart-lgpl (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.