Please enable ofxdirectconnect backend.

Bug #68351 reported by Matthew Mueller on 2006-10-26
8
Affects Status Importance Assigned to Milestone
libaqbanking (Debian)
Fix Released
Unknown
libaqbanking (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: libaqbanking16

I'd like to use the OFXDirectConnect backend with gnucash, as described here: http://wiki.gnucash.org/wiki/Setting_up_OFXDirectConnect_in_GnuCash_2

But even if GnuCash is compiled with aqbanking support, the aqofxconnect isn't available in Ubuntu.

I think it should be as simple as adding an item to the --with-backends line, some build-deps, and creating a new binary package for it.

Kai Kasurinen (kai-kasurinen) wrote :

libaqbanking (1.6.2-2) unstable; urgency=low

  * Disable OFX backend due to license conflict
    (GPLed libofx agglomerated with OpenSSL in AqBanking)

Changed in libaqbanking:
status: Unknown → Unconfirmed
Reinhard Tartler (siretart) wrote :

See the referenced debian bug. There isn't much we can do from the MOTU side

Changed in libaqbanking:
importance: Undecided → Low
status: Unconfirmed → Confirmed

Rolf Leggewie <email address hidden> writes:

> https://bugs.launchpad.net/gnucash/+bug/31789/comments/4 says
> differently.

That comment is flawed. Of gnucash links indirectly (via libaqbanking)
to OpenSSL without advertising it as required by the OpenSSL
license. Gnucash Upstream is unwilling to relicence (most probably
because they can't), so we have no choice other than hope that someone
joins aqbanking development to port it to GnuTLS.

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Changed in libaqbanking:
status: New → Fix Committed
Changed in libaqbanking:
status: Fix Committed → Fix Released
Saivann Carignan (oxmosys) wrote :

New debian upstream release 3.0.1-1 fix this, I believe that we should merge it before Hardy hit stable.

Reinhard Tartler (siretart) wrote :

fixed:

libaqbanking | 3.3.0+dfsg-1 | hardy/universe | source
libaqbanking | 3.5.0-1 | intrepid/universe | source

Changed in libaqbanking:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.