Please sync libaqbanking 4.1.0-2 (universe) from Debian unstable (main).

Bug #400102 reported by Bhavani Shankar on 2009-07-16
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libaqbanking (Debian)
Fix Released
Unknown
libaqbanking (Ubuntu)
Wishlist
Unassigned
Nominated for Karmic by Micha Lenk

Bug Description

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 affects ubuntu/libaqbanking
 status new
 importance wishlist
 subscribe ubuntu-universe-sponsors

Please sync libaqbanking 4.1.0-2 (universe) from Debian unstable (main).

Explanation of the Ubuntu delta and why it can be dropped:

Please sync the latest version from debian as they have updated their
package to the latest upstream version and have added missing include to
fix ftbfs. (Which was the only ubuntu change)

Changelog since current karmic version 3.8.2-1ubuntu1:

libaqbanking (4.1.0-2) unstable; urgency=low

  * Upload to Debian unstable.
  * Bump version in dependency on libgwenhywfar47-dev in package
    libaqbanking29-dev to match the version in build dependencies.

 -- Micha Lenk <email address hidden> Mon, 13 Jul 2009 19:04:49 +0200

libaqbanking (4.1.0-1) experimental; urgency=low

  * New upstream release.
  * Build-dep on libgwenhywfar47-dev >= 3.8.3.2 as required by ./configure.
  * Update symbols file. New symbols: AB_Banking_ExportToBuffer, AB_Gui_Extend,
    AB_Gui_Unextend, AB_Gui_new and AB_ImExporter_ExportToBuffer.
  * Package is compliant to Debian policy version 3.8.2 (no changes needed).

 -- Micha Lenk <email address hidden> Tue, 23 Jun 2009 14:45:34 +0200

libaqbanking (4.0.0-2) experimental; urgency=low

  * Replace problematic symbols file for libqbanking8 by a simple shlibs file.

 -- Micha Lenk <email address hidden> Thu, 11 Jun 2009 14:40:26 +0200

libaqbanking (4.0.0-1) experimental; urgency=low

  * New upstream release
  * Bump sonames and rename/update files accordingly:
    + libaqbanking28 -> libaqbanking29
    + libaqhbci15 -> libaqhbci16
    + libaqofxconnect4 -> libaqofxconnect5
    + libqbanking7 -> libqbanking8
  * debian/control:
    + Add binary package libaqbanking29-dbg containing debug symbols and
      tighten build-dep on debhelper >= 7.0.50 because of the new use of an
      override target for dh_strip in debian/rules
    + Relax libaqhbci16's dependency on libchipcard-libgwenhywfar47-plugins
      from a "Recommends:"- to a "Suggests:"-dependency to avoid libchipcard
      being installed on every Gnucash installation (closes: #491970)
    + Split (build) dependencies into multiple lines
  * debian/rules: Honour "nodocs" in DEB_BUILD_OPTIONS and skip generation of
    API documentation if it is present.

 -- Micha Lenk <email address hidden> Tue, 09 Jun 2009 13:56:19 +0200

libaqbanking (3.99.13rc7-1) experimental; urgency=low

  * New upstream release
  * Add new binary aqbanking-cli to package aqbanking-tools.
  * Add magic keyword Build-Depends-Package to symbols files which
    were missing it (all except libaqbanking28.symbols).
  * Fix debian/changelog: upstream added missing #include for GCC 4.4
    in AqBanking 3.99.0beta, not before (see #525743 for details).

 -- Micha Lenk <email address hidden> Mon, 11 May 2009 18:02:47 +0200

libaqbanking (3.99.11rc5-1) experimental; urgency=low

  * New upstream release
  * Add symbols files for libaqhbci15, libqbanking7 and libaqofxconnect4.
  * debian/control: Bump standards version (no changes needed).
  * Tweak debian/watch file to detect upstream release candidates too.

 -- Micha Lenk <email address hidden> Fri, 03 Apr 2009 09:54:04 +0200

libaqbanking (3.99.10rc4-1) experimental; urgency=low

  * New upstream release
  * Remove ChangeLog from debian/*.docs files. They get installed by
    dh_installchangelogs and don't get compressed if installed
    additionally by dh_installdocs (see #515601 for discussion).
  * Bump versioned build-dep on libgwenhywfar47-dev for needed symbol
    GWEN_ConfigMgr_GetUniqueId.
  * Drop transitional package aqbanking-tool. Lenny is released now.

 -- Micha Lenk <email address hidden> Sat, 28 Feb 2009 19:20:54 +0100

libaqbanking (3.99.9rc3-1) experimental; urgency=low

  * New upstream release
    - adds missing #include for GCC 4.4 (closes: #504882)
  * Bump sonames: libaqbanking20 -> libaqbanking28, libaqhbci13 -> libaqhbci15,
    libqbanking6 -> libqbanking7 and rename files accordingly. Also several
    files have been changed to reflect this soname bump.

 -- Micha Lenk <email address hidden> Mon, 16 Feb 2009 16:25:32 +0100

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFKXs6xNrEIsZrsMaARAizyAKDlDBSAifnOYfhb11bSt+yy/vdCUwCfeR+v
splV2GjpcA2xBOOSpMm+2UE=
=FlDY
-----END PGP SIGNATURE-----

Micha Lenk (micha) wrote :

If you ask me, I'am all for having libaqbanking 4.1.0 in Ubuntu Karmic.

However this will need updating build dependencies (libaqbanking20-dev -> libaqbanking29-dev) of all packages build-depending on libaqbanking (namely gnucash, qbankmanager and kmymoney2-plugin-aqbanking) because of the bumped soname. The source API should not have changed, so updating the build dependencies should be all what's needed.

Bhavani Shankar (bhavi) wrote :

Okay micha, I ll bump up to the latest versions in karmic

and test out

thanks for the info

Bhavani Shankar (bhavi) wrote :

well sorry for misunderstanding ... you meant bumping up those packages in the archive I think

Ilya Barygin (randomaction) wrote :

For this, we can just sync qbankmanager and kmymoney2-plugin-aqbanking. There's no new version of gnucash in Debian, so it will require a dependency bump.

Daniel Holbach (dholbach) wrote :

ACKed.

Please make sure that all the rdepends are rebuilt in karmic once the new libaqbanking leaves binary new.

Changed in libaqbanking (Ubuntu):
status: New → Confirmed
Bhavani Shankar (bhavi) wrote :

yes daniel

I ll look after it :)

Regards

Bhavani Shankar (bhavi) wrote :

Just a check in

qbankmanager ftbfs on ubuntu... I ll see to rebuild it with a gentoo patch

Regards

Bhavani Shankar (bhavi) wrote :

a min

Please dont sync....

qbankmanager builds now with a applied gentoo patch

http://launchpadlibrarian.net/29270025/buildlog_ubuntu-karmic-i386.qbankmanager_0.9.51beta-4ubuntu1_FULLYBUILT.txt.gz

attached is the relevant diff

Regards

Bhavani Shankar (bhavi) wrote :

Forwarded to debian

Micha, please have a look

Regards

James Westby (james-w) wrote :

Marking Incomplete while the need for the patch is assessed, please
comment and re-confirm if the sync should happen.

Thanks,

James

Changed in libaqbanking (Ubuntu):
status: Confirmed → Incomplete
Bhavani Shankar (bhavi) wrote :

james

Yes the patch should be processed and applied as qbankmanger should build as it depends on this transition

Regards

Steve Langasek (vorlon) wrote :

[Updating] libaqbanking (3.8.2-1ubuntu1 [Ubuntu] < 4.1.0-2 [Debian])
 * Trying to add libaqbanking...
  - <libaqbanking_4.1.0-2.diff.gz: downloading from http://ftp.debian.org/debian/>
  - <libaqbanking_4.1.0.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
  - <libaqbanking_4.1.0-2.dsc: downloading from http://ftp.debian.org/debian/>
I: libaqbanking [universe] -> libaqbanking-doc_3.8.2-1ubuntu1 [universe].
I: libaqbanking [universe] -> aqbanking-tools_3.8.2-1ubuntu1 [universe].
I: libaqbanking [universe] -> libaqbanking-plugins-libgwenhywfar47_3.8.2-1ubuntu1 [universe].
I: libaqbanking [universe] -> libaqbanking-data_3.8.2-1ubuntu1 [universe].

Changed in libaqbanking (Ubuntu):
status: Incomplete → Fix Released
Steve Langasek (vorlon) wrote :

[Updating] libaqbanking (3.8.2-1ubuntu1 [Ubuntu] < 4.1.0-2 [Debian])
 * Trying to add libaqbanking...
  - <libaqbanking_4.1.0-2.diff.gz: cached>
  - <libaqbanking_4.1.0.orig.tar.gz: cached>
  - <libaqbanking_4.1.0-2.dsc: cached>
I: libaqbanking [universe] -> libaqbanking-doc_3.8.2-1ubuntu1 [universe].
I: libaqbanking [universe] -> aqbanking-tools_3.8.2-1ubuntu1 [universe].
I: libaqbanking [universe] -> libaqbanking-plugins-libgwenhywfar47_3.8.2-1ubuntu1 [universe].
I: libaqbanking [universe] -> libaqbanking-data_3.8.2-1ubuntu1 [universe].

Changed in libaqbanking (Debian):
status: Unknown → Fix Released
Steve Langasek (vorlon) wrote :

whoops, sorry, rolling back based on the comments.

Changed in libaqbanking (Ubuntu):
status: Fix Released → Incomplete
Artur Rona (ari-tczew) on 2009-07-27
tags: added: sync
Launchpad Janitor (janitor) wrote :
Download full text (3.3 KiB)

This bug was fixed in the package libaqbanking - 4.1.0-2ubuntu1

---------------
libaqbanking (4.1.0-2ubuntu1) karmic; urgency=low

  * Sync on debian (LP: #400102)
  * Applied a patch from gentoo to fix qbankmanger FTBFS with GCC 4.4

libaqbanking (4.1.0-2) unstable; urgency=low

  * Upload to Debian unstable.
  * Bump version in dependency on libgwenhywfar47-dev in package
    libaqbanking29-dev to match the version in build dependencies.

libaqbanking (4.1.0-1) experimental; urgency=low

  * New upstream release.
  * Build-dep on libgwenhywfar47-dev >= 3.8.3.2 as required by ./configure.
  * Update symbols file. New symbols: AB_Banking_ExportToBuffer, AB_Gui_Extend,
    AB_Gui_Unextend, AB_Gui_new and AB_ImExporter_ExportToBuffer.
  * Package is compliant to Debian policy version 3.8.2 (no changes needed).

libaqbanking (4.0.0-2) experimental; urgency=low

  * Replace problematic symbols file for libqbanking8 by a simple shlibs file.

libaqbanking (4.0.0-1) experimental; urgency=low

  * New upstream release
  * Bump sonames and rename/update files accordingly:
    + libaqbanking28 -> libaqbanking29
    + libaqhbci15 -> libaqhbci16
    + libaqofxconnect4 -> libaqofxconnect5
    + libqbanking7 -> libqbanking8
  * debian/control:
    + Add binary package libaqbanking29-dbg containing debug symbols and
      tighten build-dep on debhelper >= 7.0.50 because of the new use of an
      override target for dh_strip in debian/rules
    + Relax libaqhbci16's dependency on libchipcard-libgwenhywfar47-plugins
      from a "Recommends:"- to a "Suggests:"-dependency to avoid libchipcard
      being installed on every Gnucash installation (closes: #491970)
    + Split (build) dependencies into multiple lines
  * debian/rules: Honour "nodocs" in DEB_BUILD_OPTIONS and skip generation of
    API documentation if it is present.

libaqbanking (3.99.13rc7-1) experimental; urgency=low

  * New upstream release
  * Add new binary aqbanking-cli to package aqbanking-tools.
  * Add magic keyword Build-Depends-Package to symbols files which
    were missing it (all except libaqbanking28.symbols).
  * Fix debian/changelog: upstream added missing #include for GCC 4.4
    in AqBanking 3.99.0beta, not before (see #525743 for details).

libaqbanking (3.99.11rc5-1) experimental; urgency=low

  * New upstream release
  * Add symbols files for libaqhbci15, libqbanking7 and libaqofxconnect4.
  * debian/control: Bump standards version (no changes needed).
  * Tweak debian/watch file to detect upstream release candidates too.

libaqbanking (3.99.10rc4-1) experimental; urgency=low

  * New upstream release
  * Remove ChangeLog from debian/*.docs files. They get installed by
    dh_installchangelogs and don't get compressed if installed
    additionally by dh_installdocs (see #515601 for discussion).
  * Bump versioned build-dep on libgwenhywfar47-dev for needed symbol
    GWEN_ConfigMgr_GetUniqueId.
  * Drop transitional package aqbanking-tool. Lenny is released now.

libaqbanking (3.99.9rc3-1) experimental; urgency=low

  * New upstream release
    - adds missing #include for GCC 4.4 (closes: #504882)
  * Bump sonames: libaqbanking20 -> libaqbanking28, libaqhbci13 -> libaqhbc...

Read more...

Changed in libaqbanking (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.