broken fallback icons for indicators

Bug #820080 reported by Mathieu Trudel-Lapierre on 2011-08-02
58
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Unity Foundations
Medium
Michael Vogt
libappindicator
Fix Released
Medium
Michael Vogt
0.4
Fix Released
Undecided
Unassigned
0.5
Fix Released
Medium
Michael Vogt
jockey (Ubuntu)
Undecided
Unassigned
libappindicator (Ubuntu)
Medium
Unassigned

Bug Description

Starting Xubuntu, etc sessions with indicators (like bluetooth-applet or nm-applet) using libappindicator; if you remove the indicator widget from the panel, "indicators" will fallback to using legacy GtkTrayIcons. However, this appears to fail to load the icons that go with them.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: libgtk-3-0 3.1.10-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
Uname: Linux 3.0.0-7-generic x86_64
Architecture: amd64
Date: Tue Aug 2 17:52:06 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110715)
ProcEnviron:
 LANGUAGE=fr_CA:fr
 PATH=(custom, user)
 LANG=fr_CA.UTF-8
 SHELL=/bin/zsh
SourcePackage: gtk+3.0
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

This might actually be related to the changes in GtkStatusIcons in GTK 3.

The relevant error messages from starting bluetooth-applet or nm-applet:

(bluetooth-applet:5247): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to underallocate toplevel GtkTrayIcon 0x23e4130. Allocation is 18x18, but minimum required size is 48x48.

(bluetooth-applet:5247): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to underallocate GtkTrayIcon's child GtkImage 0x239cc00. Allocation is 18x18, but minimum required size is 48x48.

(bluetooth-applet:5247): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to underallocate toplevel GtkTrayIcon 0x23e4130. Allocation is 18x18, but minimum required size is 48x48.

Changed in libappindicator (Ubuntu):
status: New → Confirmed
dino99 (9d9) wrote :

There is some more similar reports around talking of the same issue or so:

bug #598517 #798455 #798626 #804749 #807530 #817467 #824069

all pointed to: https://mail.gnome.org/archives/commits-list/2011-April/msg10950.html

Erick Brunzell (lbsolost) wrote :

I may need to file a new bug report but I'm testing the Lubuntu 20110830.1-i386 image and I notice that both the network and power management icons in the system tray app within lxpanel appear broken. Please see attached screenshot.

Erick Brunzell (lbsolost) wrote :

Just repeated this with the Lubuntu 20110830.2-i386 image and the behavior is the same.

tags: added: iso-testing
Mario Limonciello (superm1) wrote :

Noticed this happening in Mythbuntu with both the Jockey and the Network Manager icons. Can reproduce it with a simple python script. Same script shows the indicator properly in unity-2d.

#!/usr/bin/python
from gi.repository import AppIndicator3 as AppIndicator
from gi.repository import Gtk
indicator = AppIndicator.Indicator.new('jockey', 'jockey',
                    AppIndicator.IndicatorCategory.HARDWARE)
indicator.set_status(AppIndicator.IndicatorStatus.ATTENTION)

menu = Gtk.Menu()
item = Gtk.MenuItem.new_with_label("Do Stuff")
menu.append(item)
item.show()
item.connect('activate', lambda widget: Gtk.main_quit())
indicator.set_menu(menu)

Gtk.main()

Jeremy Bicha (jbicha) wrote :

I don't think this has anything to do with the new GTK3 sizing (and the related warnings that often flood the console)

Marcin Juszkiewicz (hrw) wrote :
Marcin Juszkiewicz (hrw) wrote :

And again

Changed in libappindicator (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Marcin Juszkiewicz (hrw) wrote :

Any plans to get it fixed for oneiric?

I hope that it will not be like it was previous time - fixed right before natty release and broken right after.

Ted Gould (ted) on 2011-09-19
Changed in unity-foundations:
status: New → Triaged
Changed in libappindicator:
status: New → Triaged
Changed in unity-foundations:
importance: Undecided → Medium
Changed in libappindicator:
importance: Undecided → Medium
Changed in unity-foundations:
assignee: nobody → Ted Gould (ted)
Changed in libappindicator:
assignee: nobody → Ted Gould (ted)
Changed in unity-foundations:
milestone: none → oneiric-beta-2
Erick Brunzell (lbsolost) wrote :

Just testing the Lubuntu alternate (20110920.1-i386) and I notice that the network manager icon is fixed but the xfce4-power-manager icon is still broken. The same was true of the 20110919.1 live image yesterday.

Erick Brunzell (lbsolost) wrote :

I had to do some studying here, but I found a pre-Beta 1 Lubuntu install left on my test machine that was last updated 2011-09-08 06:58:38 and both the network and power-manager icons were fixed at that point in time as shown in the attached screenshot.

Of course the synaptic commit log is now ridiculously long, and I'm not technically savvy enough to know what updates would break the power-manager icon again :^(

Regardless I'll also attach a copy of the available updates in case that's helpful (I just c&p'ed to leafpad), and barring any unforeseen calamity I should be able to leave this installation untouched in case I can help gather some info.

Erick Brunzell (lbsolost) wrote :

Here's that list of updates, one or more of which broke the Lubuntu power-manager icon again.

Ted Gould (ted) on 2011-09-20
Changed in libappindicator:
assignee: Ted Gould (ted) → Javier Jardón (jjardon)
Changed in unity-foundations:
assignee: Ted Gould (ted) → Javier Jardón (jjardon)
Javier Jardón (jjardon) wrote :

@Erick

Could you try the python script of comment #7?

Changed in libappindicator:
status: Triaged → Incomplete
Marcin Juszkiewicz (hrw) wrote :

I got broken icon with #7 Python script.

Javier Jardón (jjardon) wrote :

Tested with GTK+2 and GTK+3 and the problem persist, so unlikely a GtkStatusIcon bug here.

Ted Gould (ted) on 2011-09-21
Changed in unity-foundations:
milestone: oneiric-beta-2 → oneiric-final
Javier Jardón (jjardon) wrote :

Branch ready to review. BTW, the python test case is not correct, should be:

#!/usr/bin/python
from gi.repository import AppIndicator3 as AppIndicator
from gi.repository import Gtk
indicator = AppIndicator.Indicator.new('jockey', 'jockey',
                    AppIndicator.IndicatorCategory.HARDWARE)
indicator.set_status(AppIndicator.IndicatorStatus.ACTIVE) // <- only the active icon is defined with Indicator.new

menu = Gtk.Menu()
item = Gtk.MenuItem.new_with_label("Do Stuff")
menu.append(item)
item.show()
item.connect('activate', lambda widget: Gtk.main_quit())
indicator.set_menu(menu)

Gtk.main()

Changed in libappindicator:
status: Incomplete → In Progress
Marcin Juszkiewicz (hrw) wrote :

Javier: #18 also fails here.

Javier Jardón (jjardon) wrote :

@Marcin:

The fix was still not merged, or Did you test with a libappindicator patched with patch propossed in the branch? http://bazaar.launchpad.net/~jjardon/libappindicator/fix-820080/revision/215

Marcin Juszkiewicz (hrw) wrote :

Sorry, was too fast. Building version with fix now and will inform you did it fixed or not on my system.

Marcin Juszkiewicz (hrw) wrote :

Ok, built libappindicator with your fix. BT applet (gnome-bluetooth) works now. Sound applet (gnome-sound-applet) is broken. Python script is also broken.

Mario Limonciello (superm1) wrote :

The python script code was lifted from Jockey code. I expect Jockey will probably need fixing still if the script is not working.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in jockey (Ubuntu):
status: New → Confirmed
György Balló (ballogy) wrote :

@Javier: your patch fixes the broken libappindicator based icons in Gnome 3 fallback notification area both for gtk2 and gtk3 apps. I tested on Arch Linux. The python script is also works with the patch.

Olli Ries (ories) wrote :

Javier, any updates here? Is this ready to be fixed for Thursday?

Changed in unity-foundations:
status: Triaged → Incomplete
Michael Vogt (mvo) wrote :

I ran into this when porting the update-notifier to libappindicator.

I link to a branch that fixes the behavior. The idea is that in the fallback it fallback to the non fallback icon.
Eh, the idea is that if there is no "-panel" icon, it just uses the regular icon name. That should provide full
backward compatibility plus apps can (if the want) provide different icons but it does not break the case
where there is no "-panel" version of the icon. This assumes that its better to have any icon then a "broken
image" icon.

Michael Vogt (mvo) wrote :

Fwiw, the test in #7 from Mario works for me with the linked branch (without modification) in the lxpanel (I just picked a random one without app-indicator support).

Javier Jardón (jjardon) on 2011-09-30
Changed in jockey (Ubuntu):
status: Confirmed → Invalid
Ted Gould (ted) on 2011-09-30
Changed in libappindicator:
assignee: Javier Jardón (jjardon) → Michael Vogt (mvo)
milestone: none → 0.4.2
status: In Progress → Fix Committed
Changed in unity-foundations:
assignee: Javier Jardón (jjardon) → Michael Vogt (mvo)
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libappindicator - 0.4.1-0ubuntu2

---------------
libappindicator (0.4.1-0ubuntu2) oneiric; urgency=low

  * src/app-indicator.c:
    - fix fallback icon of the GtkStatusIcon (LP: #820080), cherry
      pick of r221 from lp:libappindicator
 -- Michael Vogt <email address hidden> Fri, 30 Sep 2011 22:57:46 +0200

Changed in libappindicator (Ubuntu):
status: Triaged → Fix Released
Erick Brunzell (lbsolost) wrote :

The xfce4-power-manager icon is still broken in Lubuntu /daily-live/20111007/oneiric-desktop-i386. Is this perhaps a separate issue?

Julien Lavergne (gilir) wrote :

@Eric
Yes, it's probably a separate issue. I can't reproduce it on a installed system. Could you open another bug report against xfce4-power-manager please ?

Erick Brunzell (lbsolost) wrote :

Julien, I started bug 871553 but I need a bit of time to add all the pertinent info there.

Strangely I couldn't get apport to respect my choice of Firefox as default browser, but I'll deal with that later ;^)

Just be a bit patient, I'm going as fast as I can.

dino99 (9d9) on 2015-02-12
Changed in unity-foundations:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers