icons in notification area are broken

Bug #741385 reported by Martin-Éric Racine on 2011-03-24
204
This bug affects 39 people
Affects Status Importance Assigned to Milestone
Bisigi Project
Undecided
Unassigned
libappindicator (Ubuntu)
High
Unassigned
Natty
High
Unassigned
ubuntu-mono (Ubuntu)
High
Unassigned
Natty
High
Unassigned

Bug Description

This is also evident with the Universal Access Preferences icon in GDM.

Binary package hint: ubuntu-mono

Since the upload of either ubuntu-mono (0.0.25) or libappindicator (0.3.0-0ubuntu1), icons for most applications that use the notification area are replaced by a square box with a slashed red circle a.k.a. icon missing symbol.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: ubuntu-mono 0.0.25
ProcVersionSignature: Ubuntu 2.6.38-7.38-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
Date: Thu Mar 24 02:45:07 2011
ProcEnviron:
 LANGUAGE=fi_FI:fi_FI.UTF-8:fi
 PATH=(custom, user)
 LANG=fi_FI.UTF-8
 SHELL=/bin/bashSourcePackage: ubuntu-mono
UpgradeStatus: Upgraded to natty on 2009-09-14 (555 days ago)

Martin-Éric Racine (q-funk) wrote :
Harry (harry33) wrote :

The buggy package is libappindicator1_0.3.0-0ububtu1.
The workaround is simple:
downgrade to the previous version 0.2.99_0ubuntu1
and the notification area icons are back.

On Thu, 2011-03-24 at 14:44 +0000, Harry wrote:
> The buggy package is libappindicator1_0.3.0-0ububtu1.
> The workaround is simple:
> downgrade to the previous version 0.2.99_0ubuntu1
> and the notification area icons are back.

Could you confirm which version of the GTK+ package you have?

Pavlo Bohmat (bohm) wrote :

Bug #741620
When to fix it? Or need to fix the version of the package (libappindicator1_0.2.99-0ubuntu1_amd64.deb)? Otherwise, after "apt-get dist-upgrade" will have the same problem.

Harry (harry33) wrote :

Ted,

I have fully upgraded/updated Natty, with GTK+2.0 version 2.24.3-0ubuntu4.
In my both setups (Intel and NVidia graphics cards) the notifications area icons came back by downgrading
libappindicator1_0.3.0-0ubuntu1 to the previous version 0.2.99-0ubuntu1.

Martin-Éric Racine (q-funk) wrote :

Same answers as Harry here.

I'll also add that this is in traditional GNOME, without Unity.

joopbraak (joopbraak) wrote :

Yep, me too, without unity. Up to date.

Harry (harry33) wrote :

The issue is really libappindicator1 and yes with the Classic Gnome session.
In my alptop bot nm-applet and bluetooth icon are gone.

The nm-applet works OK with connman and indicator-network.

Alex Mayorga (alex-mayorga) wrote :

FWIW the broken icons on my system are: wireless, Bluetooth, battery and keyboard layout. Empathy, Dropbox and gnome-do work fine.

You can see a screen capture of my issue in the forums at http://ubuntuforums.org/showthread.php?t=1713430

This issue is pretty apparent in Gnome Shell, or any default Gnome desktop which doesn't use the indicator applets at all. So you're basically stuck with either an invisible nm-applet, or in the case of Shell you get a fallback icon (because it's smarter about that).

Pavlo Bohmat (bohm) wrote :

The same thing in gdm and fluxbox. What does the gnome-shell? Pls, fix it bug.
libappindicator1_0.3.0-0ububtu1: FAIL
libappindicator1_0.2.99-0ubuntu1: OK

Harry (harry33) on 2011-03-27
affects: ubuntu-mono (Ubuntu) → libappindicator (Ubuntu)

I can confirm the issue exists, but I'm not certain it's all that clear that the issue definitely is in libappindicator; downgrading ubuntu-mono 0.0.24 has the icon cache properly generate, which is not the case with ubuntu-mono 0.0.25 and 0.0.26.

I think the error messages that come from configuring ubuntu-mono are the key to this and point to the exact cause: there's something wrong in an icon or the directory structure that yields the cache's hashes to be incorrectly calculated:

gtk-update-icon-cache: The generated cache was invalid.
WARNING: icon cache generation failed for /usr/share/icons/ubuntu-mono-dark
gtk-update-icon-cache: The generated cache was invalid.
WARNING: icon cache generation failed for /usr/share/icons/ubuntu-mono-light

Changed in ubuntu-mono (Ubuntu):
status: New → Confirmed
Changed in libappindicator (Ubuntu):
status: New → Confirmed
Harry (harry33) wrote :

Mathieu,

Surely this may be one issue, but why then the icons are seen correct with the previous libappindicator (0.2.99) and still with the latest ubuntu-mono package (0.0.26) installed?

Also, the whole icon issue can only be seen in the notification area.
If install connman and indicator-network, Il can see network icon (and working menu) with the indicator-applet.

Martin-Éric Racine (q-funk) wrote :

I think that there are two issues involved:

1. The current libappindicator1 version is designed to fall-back on some icon cache.
2. The current ubuntu-mono broke that cache's content in postinst.

As such, if I understand this correctly, downgrading libappdindicator1 reverts display to using non-cached items, which always works, but can be momentarily broken when the menu content is refreshed (it among other things can make nm-applet crash, which was the reason for this bug report in the first place and the current libappindicator1 indeed prevent that crash). This is what makes people think that reverting libappindicator1 is the correct choice, even though it isn't.

Changed in libappindicator (Ubuntu Natty):
importance: Undecided → High
Changed in ubuntu-mono (Ubuntu Natty):
importance: Undecided → High
Changed in libappindicator (Ubuntu Natty):
milestone: none → ubuntu-11.04-beta-2
description: updated

Definitely an issue in ubuntu-mono, not libappindicator; working on it (I think I found a solution)

This issue is tracked in bug 741387, making this one a duplicate of it.

Harry (harry33) wrote :

I think this notification area bug is not a duplicate of the bug 741387,
because that has been already fixed with the update of ubuntu-mono_0.0.27.

However, notification area is still broken.
I cannot see NM-applet icon there, just a broken icon image.
 the only workaround is to downgrade libappindicator1 to the version 0.2.99-0ubuntu1.

Mathieu: The assertion is incorrect about it being simply because of Ubuntu-mono, which I'm not using as my icon set. I'm using Gnome's default icons (with local overrides from my Shell testing).

Harry is correct, this issue still persists.

andrew thomas (atswartz) wrote :

This is kind of weird. I am having this problem on one partition with natty and not on another partition on the same HD.
Also, my Dropbox notification icon is all white on both installs.

Russ Dill (russ-dill) wrote :

gtk-redshift is also affected and the monitor preferences "show monitors in panel".

Valentin Rocher (bishiboosh) wrote :

Same here, downgraded to 0.2.99 and all went well...Not using ubuntu-mono here either. This is kind of annoying however, as there still are many upgrades on various packages these times with Natty being in beta, and I don't really want to downgrade the package each time...Seems like I'll have to put up with the blank icons until this gets fixed.

There was another issue identified in libappindicator 0.3.0 once the issue with ubuntu-mono was fixed: tracking the fallback icon names in bug 746495.

joopbraak (joopbraak) wrote :

Yeah, definitely a dup. Which one should be marked as such?
Also here the same problem with the universal access preferences icon in the logon screen.
Ffixed after downgrading to 0.2.99.

Le Gluon Du Net (legluondunet) wrote :

Just updated natty, I still have no network manager icon in notification area and in gdm login screen too.

tags: added: iso-testing

Just updated, and it's working now

Mikael Nilsson (mini) wrote :

tor 2011-04-14 klockan 20:20 +0000 skrev Bálint Dávid:
> Just updated, and it's working now
>

Not for me.

Harry (harry33) wrote :

This bug now seems to be fixed with the GTK+2 update of 2.0 2.24.4-0ubuntu2
See bug #746495

Mikael Nilsson (mini) wrote :

Now fixed for me too.

majesty (majesty-nashemisto) wrote :

Update gets fix for me. Thanks!

Changed in ubuntu-mono (Ubuntu Natty):
status: Confirmed → Fix Released
Changed in libappindicator (Ubuntu Natty):
status: Confirmed → Fix Released
andrew thomas (atswartz) wrote :

My nm-applet is now fixed, yet my dropbox icon is still all white.

andrew thomas (atswartz) wrote :

I fixed my dropbox icon by updating to the latest development version of dropbox (1.1.28) and adding icons to my ~/.icons directory.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers