libappindicator stops updating the menu after gtk.MenuItem is added

Bug #728503 reported by Roman Yepishev on 2011-03-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Indicator
Invalid
Undecided
Unassigned
libappindicator
Fix Released
High
Ted Gould
libappindicator (Ubuntu)
High
Unassigned

Bug Description

I wanted to add MenuItems dynamically since I don't know the number of simultaneous upload/download entries in Ubuntu One beforehand. However upon addition of the menu entry the whole menu stops reacting to the changes I make via Indicator.

The attached script shows this behavior, it adds a MenuItem before menu is attached and then adds another one after. After this point no changes to the menu are visible, labels stay the same and adding/removing menu items no longer works.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: python-appindicator 0.2.96-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Mar 3 17:27:13 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
SourcePackage: libappindicator
UpgradeStatus: Upgraded to natty on 2010-12-05 (87 days ago)

Related branches

Roman Yepishev (rye) wrote :
description: updated
Roman Yepishev (rye) wrote :

Aha, just ran this test on latest maverick and the test works properly. So it looks like a regression.

Ted Gould (ted) wrote :

This seems to be a parser issue as when I get the menu from d-feet it isn't changing either.

affects: libappindicator (Ubuntu) → libdbusmenu (Ubuntu)
Changed in libdbusmenu (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in dbusmenu:
status: New → Confirmed
importance: Undecided → High
tags: added: parser
Markus Korn (thekorn) wrote :

This also affects gtk-recordmydesktop (LP: #729798), as the menu of this applet there is not updating gtk-recordmydesktop is unusable in natty (it is impossible to stop a recording)

Ted Gould (ted) on 2011-03-07
Changed in dbusmenu:
assignee: nobody → Ted Gould (ted)
Markus Korn (thekorn) wrote :

Just a quick note: the issue described in my last comment is solved with today's updates (of libdbusmenu, I guess), but the reproducer script still fails for me, so both issues seem to be unrelated.

Ted Gould (ted) on 2011-03-08
affects: dbusmenu → libappindicator
Changed in libappindicator:
status: Confirmed → In Progress
affects: libdbusmenu (Ubuntu) → libappindicator (Ubuntu)
Ted Gould (ted) on 2011-03-10
Changed in libappindicator:
milestone: none → 0.2.98
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libappindicator - 0.2.98-0ubuntu1

---------------
libappindicator (0.2.98-0ubuntu1) natty; urgency=low

  * New upstream release.
    ∘ Don't watch signals we don't need to. (LP: #728503)
 -- Ted Gould <email address hidden> Thu, 10 Mar 2011 13:35:59 -0600

Changed in libappindicator (Ubuntu):
status: Confirmed → Fix Released
Roman Yepishev (rye) on 2011-04-12
Changed in one-indicator:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers