layout indicator items are not being updated and not working

Bug #711749 reported by Otus on 2011-02-02
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
libappindicator
Fix Released
Undecided
Michael Terry
libappindicator (Ubuntu)
High
Michael Terry
Natty
High
Michael Terry

Bug Description

Binary package hint: indicator-application

The language indicator shows USA as an option even after I've removed it from keyboard settings. I cannot choose Finland from the menu, but text input works as if Finland is selected. Screenshot attached.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: indicator-application 0.2.92-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic x86_64
Architecture: amd64
Date: Wed Feb 2 10:05:43 2011
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110201.1)
ProcEnviron:
 LANGUAGE=en_US.UTF-8:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_AG.utf8
 SHELL=/bin/bash
SourcePackage: indicator-application

Related branches

Otus (jan-varho) wrote :
affects: indicator-application (Ubuntu) → gnome-settings-daemon (Ubuntu)
Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
affects: gnome-settings-daemon (Ubuntu) → indicator-application (Ubuntu)
Sebastien Bacher (seb128) wrote :

Confirmed, the g-s-d code didn't change in natty though so it's likely to be an indicator stack issue

Changed in indicator-application (Ubuntu):
importance: Low → High
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

The entries to display the configuration dialog or show the current keyboard don't work either, the vino icon is having the same issue

Sebastien Bacher (seb128) wrote :

dbus-monitor shows those error when the indicator is used

" string "type='error'"
method call sender=:1.207 -> dest=:1.353 serial=413 path=/org/ayatana/NotificationItem/gst_keyboard_xkb/Menu; interface=com.canonical.dbusmenu; member=AboutToShow
   int32 0
error sender=:1.353 -> dest=:1.207 error_name=org.freedesktop.DBus.Error.UnknownMethod reply_serial=413
   string "L'interface « com.canonical.dbusmenu » n'existe pas pour l'objet à l'emplacement /org/ayatana/NotificationItem/gst_keyboard_xkb/Menu""

Michael Terry (mterry) on 2011-02-02
Changed in indicator-application:
assignee: nobody → Michael Terry (mterry)
Changed in indicator-application (Ubuntu Natty):
assignee: nobody → Michael Terry (mterry)
milestone: none → natty-alpha-3
summary: - Language indicator has USA even after removing it from keyboard settings
+ layout indicator items are not being updated and not working
Ken VanDine (ken-vandine) wrote :

We are seeing similar errors from indicator-messages and I think Ted thinks it might be related to the bug causing duplicate entries in the messaging menu.

LIBDBUSMENU-GLIB-WARNING **: Getting layout failed: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface `com.canonical.dbusmenu' on object at path /

Also, possibly related:
libindicate-WARNING **: Unable to get property data: Timeout was reached

I know Ted was working on that last night, perhaps it is all being caused by a bug in dbusmenu.

tags: added: iso-testing
Ken VanDine (ken-vandine) wrote :

Ignore my comment #5 that was actually unrelated, only libindicate. But similar symptom it seems.

Ted Gould (ted) wrote :

Odd, this really does work for me. I'm getting the label on the panel not changing, but it does change the keyboard layout internally. Can you guys try with the "simple-client" that is in the libappindicator examples and see if there's any item there that doesn't work consistently?

Ken VanDine (ken-vandine) wrote :

I can't reproduce this bug, only problem I am seeing with switching keyboards is the label in the panel isn't changing. That is likely a unity bug, we are looking into that.

Otus (jan-varho) wrote :

Which part is not reproducible? I can try to run tests if given steps to follow.

To clarify, switching the layout from Keyboard preferences does work for me. The indicator also works fine as long as I don't delete a layout.

Adding any layouts and then deleting one causes the menu to contain extra items and after that even the keyboard preferences item in the menu stops working.

On Fri, 2011-02-04 at 08:56 +0000, Otus wrote:
> Which part is not reproducible? I can try to run tests if given steps to
> follow.

None of those break on my system :) It seems to be dependent on
something we don't yet understand.

Sebastien Bacher (seb128) wrote :

Could someone having the issue describe how to trigger it? The only case when I get it is when removing a layout, the menu should get hidden but doesn't and it broken

David Planella (dpm) wrote :

In my case I can always reproduce it. Here are my settings:

* German layout
* Spanish (Catalan version) layout
* On upgrading to Natty the USA layout was added, but I removed it.

Steps to reproduce:

1. Use the keyboard binding to switch the keyboard layout (in my case it's the Menu key)
2. The keyboard layout changes (i.e. I can type with the new layout)
3. However, the indicator label never changes, it always stays as "Deu" (German layout)

Steps to reproduce (alternative):

1. Click on the keyboard indicator
2. Select a different layout than the current one
3. The keyboard layout changes (i.e. I can type with the new layout)
4. However, the indicator label never changes, it always stays as "Deu" (German layout)

Let me know if I can do anything to help debugging this

Sebastien Bacher (seb128) wrote :

see also bug #712581 and bug #712635, the label not updating is bug #712581, the bug here is rather the menu items not working as they should

Michael Terry (mterry) wrote :

As Seb mentioned, your reproduction steps in comment 12 are good reproduction steps for bug 712581 (for which I just filed a merge request).

But for this bug about menu items not working, the best reproduction steps we have are:

"Adding any layouts and then deleting one causes the menu to contain extra items and after that even the keyboard preferences item in the menu stops working."

Which sounds an awful lot like the reproduction steps for the crasher bug 712635. I'm guessing that when deleting layouts, we're screwing up gnome-settings-daemon and it either crashes or goes crazy as a result. Hopefully both can be fixed in the same stroke. I'm looking.

Michael Terry (mterry) on 2011-02-11
affects: indicator-application → libappindicator
affects: indicator-application (Ubuntu Natty) → libappindicator (Ubuntu Natty)
Michael Terry (mterry) wrote :

Attached branch https://code.launchpad.net/~mterry/libappindicator/unregister-later has a fix for the menu being around and unresponsive. When you delete the second of two layouts, the indicator is actually supposed to disappear. But due to a bug in the libappindicator destruction code, the connection to the indicator was torn down, but the indicator itself was kept around. Thus the menu items that didn't do anything.

I'm not sure if this is related to the crash in bug 712635 or not after all. I'm going to keep digging in that bug's comments as necessary.

Dmitry Shachnev (mitya57) wrote :

Isn't it a duplicate of bug 637360 (selected keyboard map is different
from showed)?

Martin Pitt (pitti) wrote :

Not a milestone blocker; as a bug fix this isn't bound by FF/UIF etc. either.

Changed in libappindicator (Ubuntu Natty):
milestone: natty-alpha-3 → none
Sebastien Bacher (seb128) wrote :

the issue described there has been fixed since, closing it, there is a remaining issue where the selected item in the menu is wrong which is bug #682075

Changed in libappindicator (Ubuntu Natty):
status: Confirmed → Fix Released
Changed in libappindicator:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers