softwares using libappindicator crash with SIGSEGV in theme_changed_cb()

Bug #708188 reported by Rod Davis on 2011-01-26
114
This bug affects 35 people
Affects Status Importance Assigned to Milestone
libappindicator
Fix Released
High
Michael Terry
indicator-application (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned
Natty
Undecided
Unassigned
libappindicator (Ubuntu)
High
Michael Terry
Maverick
Undecided
Unassigned
Natty
High
Michael Terry

Bug Description

Binary package hint: gnome-settings-daemon

Shortly before Apport warned me of this crash, the theme defaulted to the regular GNOME theme (ugly gray with default GNOME icons). This crash was also accompanied by two crashed of PolicyKit, which I will file after I complete this report.

===== SRU Notice =====

This fix is simple and safe for an SRU. It prevents a crash in several apps, notably gnome-bluetooth, gnome-settings-daemon, and policykit-gnome-agent.

It's been patched in natty for a while without ill affects.

======================

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: gnome-settings-daemon 2.32.1-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic x86_64
Architecture: amd64
CrashCounter: 1
Date: Wed Jan 26 12:57:47 2011
ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f2d5a0e9a93: mov 0x80(%rax),%esi
 PC (0x7f2d5a0e9a93) ok
 source "0x80(%rax)" (0xaaaaaaaaaaaaab2a) not located in a known VMA region (needed readable region)!
 destination "%esi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: gnome-settings-daemon
StacktraceTop:
 ?? () from /usr/lib/libappindicator.so.1
 g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
 ?? () from /usr/lib/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
 g_signal_emit () from /usr/lib/libgobject-2.0.so.0
Title: gnome-settings-daemon crashed with SIGSEGV in g_closure_invoke()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (nautilus:1329): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed
 (nm-applet:1339): Gtk-CRITICAL **: IA__gtk_widget_is_toplevel: assertion `GTK_IS_WIDGET (widget)' failed
 (nautilus:1329): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed

Related branches

Rod Davis (ahylianhuman) wrote :
visibility: private → public

StacktraceTop:
 theme_changed_cb (theme=<value optimized out>,
 g_closure_invoke (closure=0x182ff30,
 ?? ()
 ?? ()
 ?? ()

tags: added: apport-failed-retrace
tags: removed: need-amd64-retrace

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
affects: gnome-settings-daemon (Ubuntu) → libappindicator (Ubuntu)
affects: libappindicator (Ubuntu) → indicator-application (Ubuntu)
summary: - gnome-settings-daemon crashed with SIGSEGV in g_closure_invoke()
+ gnome-settings-daemon crashed with SIGSEGV in theme_changed_cb()
summary: - gnome-settings-daemon crashed with SIGSEGV in theme_changed_cb()
+ softwares using libappindicator crash with SIGSEGV in theme_changed_cb()
Sebastien Bacher (seb128) wrote :

the policykit-gnome-agent often crashes this way when using update-manager

Changed in indicator-application (Ubuntu):
status: Incomplete → Triaged
Changed in indicator-application (Ubuntu Natty):
importance: Medium → High
milestone: none → ubuntu-11.04-beta
Kalle Valo (kvalo) on 2011-02-23
Changed in indicator-application:
status: New → Triaged
importance: Undecided → High
David Barth (dbarth) on 2011-02-25
Changed in indicator-application:
assignee: nobody → Ted Gould (ted)
Changed in indicator-application (Ubuntu Natty):
assignee: nobody → Ted Gould (ted)
Michael Terry (mterry) wrote :

I think I know what's wrong -- it should disconnect from that signal when disposing itself.

Changed in indicator-application:
assignee: Ted Gould (ted) → Michael Terry (mterry)
status: Triaged → In Progress
Sebastien Bacher (seb128) wrote :

the issue has been fixed in this upload

libappindicator (0.2.96-0ubuntu2) natty; urgency=low

  * debian/control, debian/rules:
    - Add quilt
  * debian/patches/disconnect-from-theme.patch:
    - Fix crash when switching themes by disconnecting a signal from
      the theme on dispose. LP: #708188

affects: indicator-application (Ubuntu Natty) → libappindicator (Ubuntu Natty)
Changed in libappindicator (Ubuntu Natty):
assignee: Ted Gould (ted) → Michael Terry (mterry)
status: Triaged → Fix Released
affects: indicator-application → libappindicator
Ted Gould (ted) on 2011-03-02
Changed in libappindicator:
status: In Progress → Fix Committed
Changed in libappindicator:
status: Fix Committed → Fix Released
Michael Terry (mterry) wrote :

In maverick, libappindicator was from the indicator-application package. So I'm opening a tracker for that source package in maverick (and invalidating the natty target) for an SRU.

Changed in indicator-application (Ubuntu Natty):
status: New → Invalid
description: updated
Michael Terry (mterry) wrote :

Debdiff for 10.10. Already uploaded to maverick-proposed.

Sebastien Bacher (seb128) wrote :

could need to be put on hold, bug #729150 could be a side effect on that one

Sebastien Bacher (seb128) wrote :

or not; bug #708118 seems similar and not new

Accepted indicator-application into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in indicator-application (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Pedro Villavicencio (pedro) wrote :

I've been testing this package for a few days already and did not see any regression with it, i cannot reproduce the crash though. I'm marking this as verification-done so it can go trough updates, thanks all.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-application - 0.2.9-0ubuntu1.1

---------------
indicator-application (0.2.9-0ubuntu1.1) maverick-proposed; urgency=low

  * debian/patches/10-fix-theme-changed-crash.patch:
    - Don't crash due to theme changes. LP: #708188
 -- Michael Terry <email address hidden> Wed, 16 Mar 2011 15:28:25 -0400

Changed in indicator-application (Ubuntu Maverick):
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2013-07-06
Changed in libappindicator (Ubuntu Maverick):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers