mod_python compiler for python 2.7.1+ instead 2.7.1

Bug #766834 reported by jacquesh on 2011-04-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libapache2-mod-python (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: libapache2-mod-python

When you use this mod with apache, in apache logs, you can see this error

[Wed Apr 20 07:28:12 2011] [error] python_init: Python version mismatch, expected '2.7.1', found '2.7.1+'.
[Wed Apr 20 07:28:12 2011] [error] python_init: Python executable found '/usr/bin/python'.
[Wed Apr 20 07:28:12 2011] [error] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-linux2:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: libapache2-mod-python 3.3.1-9build1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Uname: Linux 2.6.38-8-generic-pae i686
NonfreeKernelModules: fglrx
Architecture: i386
Date: Wed Apr 20 07:32:05 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANGUAGE=fr_FR:en
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: libapache2-mod-python
UpgradeStatus: Upgraded to natty on 2011-04-18 (1 days ago)

jacquesh (jhullu) wrote :
jacquesh (jhullu) wrote :

I've made an mistake in the title's bug reports.

mod_python compiled with python 2.7.1+ instead 2.7.1

tags: added: python27
Barry Warsaw (barry) wrote :

I see that log entry too, but does it prevent mod_python from working? Here's the full log I see:

[Wed Apr 20 16:29:41 2011] [error] python_init: Python version mismatch, expected '2.7.1', found '2.7.1+'.
[Wed Apr 20 16:29:41 2011] [error] python_init: Python executable found '/usr/bin/python'.
[Wed Apr 20 16:29:41 2011] [error] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-linux2:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
[Wed Apr 20 16:29:41 2011] [notice] mod_python: Creating 8 session mutexes based on 6 max processes and 25 max threads.
[Wed Apr 20 16:29:41 2011] [notice] mod_python: using mutex_directory /tmp
[Wed Apr 20 16:29:41 2011] [notice] Apache/2.2.17 (Ubuntu) mod_python/3.3.1 Python/2.7.1+ mod_ssl/2.2.17 OpenSSL/0.9.8o configured -- resuming normal operations
[Wed Apr 20 16:30:25 2011] [notice] caught SIGTERM, shutting down

Matthias Klose (doko) wrote :

no, and a rebuild gets rid of the warning too

Barry Warsaw (barry) wrote :

In any event, a no change rebuild will eliminate this. See attached branch.

Changed in libapache2-mod-python (Ubuntu):
status: New → Confirmed
milestone: none → ubuntu-11.04
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libapache2-mod-python - 3.3.1-9build2

---------------
libapache2-mod-python (3.3.1-9build2) natty; urgency=low

  * No change rebuild to eliminate version mismatch warnings. (LP: #766834)
 -- Barry Warsaw <email address hidden> Wed, 20 Apr 2011 16:35:57 -0400

Changed in libapache2-mod-python (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers