mod-python won't load due to version mismatch with python 2.6.4rc2

Bug #469674 reported by Peter Lyons on 2009-11-01
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libapache2-mod-python (Ubuntu)
Undecided
Unassigned
Karmic
Undecided
Unassigned

Bug Description

Binary package hint: libapache2-mod-python

Upon upgrade to Ubuntu 9.10 Friday 10/31, it seems my apache2 mod-python will no longer load. The following message appears during apache2 startup in /var/log/apache2/error.log:

[Sun Nov 01 15:34:13 2009] [error] python_init: Python version mismatch, expected '2.6.2+', found '2.6.4rc2'.
[Sun Nov 01 15:34:13 2009] [error] python_init: Python executable found '/usr/bin/python'.
[Sun Nov 01 15:34:13 2009] [error] python_init: Python path being used '/usr/lib/python2.6/:/usr/lib/python2.6/plat-linux2:/usr/lib/python2.6/lib-tk:/usr/lib/python2.6/lib-old:/usr/lib/python2.6/lib-dynload'.
[Sun Nov 01 15:34:13 2009] [notice] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
[Sun Nov 01 15:34:13 2009] [notice] mod_python: using mutex_directory /tmp

My mod-python based web app is no longer receiving any connections from apache. I don't know for sure that these error messages in the log and my app not working are related, but it seems plausible and since there have been similar bugs filed in older releases, it seems plausible that this is a real issue in the fact that the python interpreter is 2.6.4rc2 but mod-python is looking for 2.6.2.

lsb_release -rd
Description: Ubuntu 9.10
Release: 9.10

apt-cache policy libapache2-mod-python
libapache2-mod-python:
  Installed: 3.3.1-8
  Candidate: 3.3.1-8
  Version table:
 *** 3.3.1-8 0
        500 http://ubuntu.cs.utah.edu karmic/main Packages
        100 /var/lib/dpkg/status

Matthias Klose (doko) wrote :

package from karmic-proposed can be copied to lucid

Changed in libapache2-mod-python (Ubuntu Karmic):
status: New → In Progress

Accepted libapache2-mod-python into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in libapache2-mod-python (Ubuntu):
status: New → Fix Committed
Changed in libapache2-mod-python (Ubuntu Karmic):
status: In Progress → Fix Committed
tags: added: verification-needed
Peter Lyons (pete-peterlyons) wrote :

OK, well I installed the new python and libapache2-mod-python packages and that did correctly solve the "version mismatch" error message. My application is still not working due to web server<->app server communication issues, but I don't have any evidence that this bug is related to that anymore. I think you can consider this bug verified from my side. Thanks!

Martin Pitt (pitti) on 2009-11-04
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libapache2-mod-python - 3.3.1-8build1

---------------
libapache2-mod-python (3.3.1-8build1) karmic-proposed; urgency=low

  * Rebuild to fix python version check. LP: #469674.

 -- Matthias Klose <email address hidden> Mon, 02 Nov 2009 11:57:24 +0100

Changed in libapache2-mod-python (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

copied to lucid.

Changed in libapache2-mod-python (Ubuntu):
status: Fix Committed → Fix Released
Changed in libapache2-mod-python (Ubuntu Karmic):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libapache2-mod-python - 3.3.1-8build1

---------------
libapache2-mod-python (3.3.1-8build1) karmic-proposed; urgency=low

  * Rebuild to fix python version check. LP: #469674.

 -- Matthias Klose <email address hidden> Mon, 02 Nov 2009 11:57:24 +0100

Changed in libapache2-mod-python (Ubuntu Karmic):
status: Fix Committed → Fix Released
Max J. Chung (max-maxjchung) wrote :

Martin,
nOOb question: Attempting to "apt-get install libapache2-mod-python" tells me it's already at the newest version, though checking the version shows it is "3.3.1-8" rather than "3.3.1-8build1". What might I be doing wrong here?

Thanks,
Max

Martin Pitt (pitti) wrote :

Presumably you don't have karmic-updates enabled in the software sources for some reason?

martin suc (martin-suc) wrote :

this error with version 2.7.2 is here. how to get rid of it ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers