libapache2-mod-python: Port to Python3 needed

Bug #1735368 reported by Matthias Klose on 2017-11-30
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libapache2-mod-python (Debian)
New
Unknown
libapache2-mod-python (Ubuntu)
Undecided
Ubuntu Server

Bug Description

Please consider adding support for Python3, either by using python3 as the
default, or maybe by providing a libapache2-mod-python3 binary package.

Matthias Klose (doko) on 2017-11-30
tags: added: py2-demotion py2-removal
Matthias Klose (doko) on 2017-11-30
Changed in libapache2-mod-python (Ubuntu):
assignee: nobody → Ubuntu Server Team (ubuntu-server)
Changed in libapache2-mod-python (Debian):
status: Unknown → New
Dimitri John Ledkov (xnox) wrote :

Demotion was commited.

Also tasksel has stopped offering to install this a long time ago.

Changed in libapache2-mod-python (Ubuntu):
status: New → Fix Committed
Matthias Klose (doko) wrote :

this is demoted now. Is there a python3 equivalent needed?

tags: added: rls-dd-incoming
Steve Langasek (vorlon) wrote :

This was demoted already in cosmic and no one minded. It was *only* being held in main via the server-ship seed but was not used via the installer so did not belong in server-ship anymore. There is no python3 replacement in the archive. We should consider this resolved.

Changed in libapache2-mod-python (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.