libao defaults to ALSA output, should probably use Pulseaudio

Bug #1075479 reported by machrider on 2012-11-06
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
libao (Ubuntu)
Undecided
Luke Yelavich

Bug Description

When playing sound from an application that uses libao on Ubuntu 12.04 (for example, pianobar), it blocks any other sound-playing application from playing audio (for example, Firefox on YouTube). A little digging showed that /etc/libao.conf sets default_driver=alsa, changing this to default_driver=pulse makes simultaneous audio from multiple programs work perfectly.

1) Ubuntu 12.04
2) libao-common 1.1.0-1ubuntu2
3) Expected audio to play from several apps simultaneously
4) Apps using libao block the sound card so that no one else can play sound

Related branches

machrider (machrider) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libao (Ubuntu):
status: New → Confirmed

This is still a problem in Ubuntu 14.04 (and I'm sure in 14.10 as well). Your suggested change is noted in the Arch Wiki:

https://wiki.archlinux.org/index.php/PulseAudio#libao

Of course, I had to put a comment ('#') in my config, which helpfully is broken:

https://trac.xiph.org/ticket/1971

Changed in libao (Ubuntu):
assignee: nobody → Brian Norris (computersforpeace)
status: Confirmed → In Progress
Luke Yelavich (themuso) on 2015-01-08
Changed in libao (Ubuntu):
assignee: Brian Norris (computersforpeace) → Luke Yelavich (themuso)
Luke Yelavich (themuso) on 2015-01-08
Changed in libao (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libao - 1.1.0-3ubuntu1

---------------
libao (1.1.0-3ubuntu1) vivid; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - Convert to multiarch.
    - Switch libao-common to Architecture: all.
    - Build with dh_autoreconf.
  * debian/libao.conf: Set the default output to pulseaudio (LP: #1075479)

libao (1.1.0-3) unstable; urgency=medium

  * Use linux-any instead of negating specific other arches. Closes: #634625
  * Regenerate build system files, mostly to pull in a later libtool.m4
    which has fixes for building the ppc64le architecture. Closes: #752022
 -- Luke Yelavich <email address hidden> Thu, 08 Jan 2015 12:55:17 +1100

Changed in libao (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.