Ubuntu

package libanyevent-perl (not installed) failed to install/upgrade: trying to overwrite '/usr/share/man/man3/AnyEvent.3pm.gz', which is also in package anyevent-perl 0:1.02-0.2

Reported by Chad A. Davis on 2009-11-02
114
This bug affects 27 people
Affects Status Importance Assigned to Milestone
anyevent (Ubuntu)
Undecided
Unassigned
libanyevent-perl (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libanyevent-perl

Trying to install all packages named 'lib*-perl' in a single apt-get install command.

ProblemType: Package
Architecture: i386
Date: Mon Nov 2 12:20:59 2009
DistroRelease: Ubuntu 9.10
ErrorMessage: trying to overwrite '/usr/share/man/man3/AnyEvent.3pm.gz', which is also in package anyevent-perl 0:1.02-0.2
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: libanyevent-perl (not installed)
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: libanyevent-perl
Title: package libanyevent-perl (not installed) failed to install/upgrade: trying to overwrite '/usr/share/man/man3/AnyEvent.3pm.gz', which is also in package anyevent-perl 0:1.02-0.2
Uname: Linux 2.6.31-14-generic i686

Chad A. Davis (chadadavis) wrote :
Ansgar Burchardt (aburch) wrote :

The anyevent-perl package seems to contain an older version of libanyevent-perl. If this is really the case, it should probably be removed from Ubuntu (it is not part of Debian).

PaulSchulz (paulschulz) wrote :

Workaround:
- Remove the anyevent-perl package (apt-get remove anyevent-perl)
- Install the libanyevent-perl package (apt-get install libanyevent-perl)

Changed in anyevent (Ubuntu):
status: New → Confirmed
fejes (anthony-fejes) wrote :

I attempted PaulSchulz's fix, but was unable to remove anyevent-perl. I required the extra step of removing dvdrip:

sudo apt-get remove dvdrip

Once dvdrip was removed, the rest of the upgrade proceeded smoothly. Performing an autoremove removed anyevent-perl:

sudo apt-get autoremove

and I was successfully able to re-install dvdrip once that was done, which included libanyevent-perl:

sudo apt-get install dvdrip

Tom Pino (metalsmith-rangeweb) wrote :

This happened for me on a 9.10>10.04-testing upgrade that I have been running since the toolchain went up.

I do no have dvdrip installed.

Synaptic calls for the removal of libevent-execflow-perl under the broken packages heading.

Donatas Olsevičius (donatas-o) wrote :

I've had this issue for a few days. Removing dvdrip and autoremoving its deps fixed the problem. Thanks!

Ansgar Burchardt (aburch) wrote :

The "anyevent" package has been removed from Ubuntu [1]. This should fix this issue, if the package is still present it should be removed.

Regards,
Ansgar

[1] https://bugs.launchpad.net/bugs/507767

Changed in anyevent (Ubuntu):
status: Confirmed → Fix Released
Changed in libanyevent-perl (Ubuntu):
status: New → Fix Released
Basil Philipp (basil-philipp) wrote :

This bug occurred to me when upgrading to Lucid Lynx alpha 3 from Ubuntu 9.10. This was serious since it kept the installation from completing and let me hanging in command line mode after booting. I was able to fix it by removing dvdrip and afterwards anyevent-perl.

dist-upgrading 9.10 to 10.04 failed: I had to go
dpkg -r anyevent-perl
which worked for me, since this didn't:
apt-get install libanyevent-perl anyevent-perl-

Chris Olin (chris.olin) wrote :

I also ran into this bug when I upgraded a few days ago from 9.10 to 10.04.

Jonathan Harker's advice (post #9) to dpkg -r anyevent-perl solved my problem since apt-get will spit back errors trying to remove or add anything because of this libanyevent-perl package.

Praxis (ebiow) wrote :

Had the same problem with two upgrades from Karmic to Lucid, I removed libanyevent-perl and dvdrip with 'apt-get remove', and the upgrade continued for a spell. Then I continued with my 'apt-get dist-upgradge' normally. I had the same issue with autofs. Serves me right for having bloated installs.

Kim Kepchar (kimsubscriptions) wrote :

Getting rid of dvdrip through Synaptic Package Manager fixed things for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers