lfm crashes at startup, because of UnicodeDecodeError

Bug #786491 reported by Patrick Sabin
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lfm (Debian)
Fix Released
Unknown
lfm (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Binary package hint: lfm

If I start lfm it raises immediately a UnicodeDecodeError:

Traceback (most recent call last):
  File "/usr/bin/lfm", line 27, in <module>
    lfm_start(sys.argv)
  File "/usr/share/lfm/lfm/lfm.py", line 924, in lfm_start
    path = curses.wrapper(main, prefs, paths1, paths2)
  File "/usr/lib/python2.7/curses/wrapper.py", line 43, in wrapper
    return func(stdscr, *args, **kwds)
  File "/usr/share/lfm/lfm/lfm.py", line 848, in main
    ret = app.run()
  File "/usr/share/lfm/lfm/lfm.py", line 197, in run
    self.display()
  File "/usr/share/lfm/lfm/lfm.py", line 153, in display
    self.lpane.display()
  File "/usr/share/lfm/lfm/lfm.py", line 358, in display
    self.display_files()
  File "/usr/share/lfm/lfm/lfm.py", line 465, in display_files
    buf = tab.get_fileinfo_str_short(res, w, self.pos_col1)
  File "/usr/share/lfm/lfm/lfm.py", line 753, in get_fileinfo_str_short
    buf = '%(type_chr)c%(fname)s %(size)7s %(mtime2)12s' % res

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: lfm 2.2-1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
Date: Sun May 22 12:20:23 2011
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=de_AT:en
 PATH=(custom, user)
 LANG=de_AT.UTF-8
 SHELL=/bin/bash
SourcePackage: lfm
UpgradeStatus: Upgraded to natty on 2011-05-03 (19 days ago)

Related branches

Revision history for this message
Patrick Sabin (patrick-just4fun) wrote :
Revision history for this message
Patrick Sabin (patrick-just4fun) wrote :

I discovered that the program only crashes on some directories. On some others it works fine. I am not yet sure what the reason is. I tried it on a directory with a file named ö and it worked.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lfm (Ubuntu):
status: New → Confirmed
Revision history for this message
Bruno Bigras (brunoqc) wrote :

This bug was fixed upstream in https://bitbucket.org/inigoserna/lfm/changeset/8d2021770794

The attached debdiff fixes the problem for me.

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "lfm-lp786491.diff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Bruno Bigras (brunoqc)
Changed in lfm (Ubuntu Oneiric):
status: Confirmed → Fix Released
Changed in lfm (Ubuntu Natty):
status: New → Confirmed
Revision history for this message
Bruno Bigras (brunoqc) wrote :
Revision history for this message
Bruno Bigras (brunoqc) wrote :
Changed in lfm (Debian):
status: Unknown → New
Revision history for this message
Ruben (info-rubenfelix) wrote : Re: [Bug 786491] Re: lfm crashes at startup, because of UnicodeDecodeError

Hey!

Bedankt voor je mail! Ik ben er even tussenuit geknepen naar een lekker warm land! Ik beantwoord je mail na mijn vakantie (11 oktober).

Groetjes!

Ruben

Changed in lfm (Ubuntu Maverick):
status: New → Fix Committed
Changed in lfm (Ubuntu Natty):
status: Confirmed → Fix Committed
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello Patrick, or anyone else affected,

Accepted lfm into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Revision history for this message
Martin Pitt (pitti) wrote :

Hello Patrick, or anyone else affected,

Accepted lfm into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Revision history for this message
Bruno Bigras (brunoqc) wrote :

I confirm that the updated package from natty-proposed fixes the crash on Natty.

Martin Pitt (pitti)
tags: added: verification-done-natty
Changed in lfm (Ubuntu Maverick):
status: Fix Committed → Won't Fix
tags: added: verification-done
removed: verification-done-natty verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lfm - 2.2-1ubuntu0.11.04.1

---------------
lfm (2.2-1ubuntu0.11.04.1) natty-proposed; urgency=low

  * Fix a crash at startup, because of UnicodeDecodeError (LP: #786491)
 -- Bruno Bigras <email address hidden> Sat, 17 Sep 2011 22:19:56 -0400

Changed in lfm (Ubuntu Natty):
status: Fix Committed → Fix Released
Changed in lfm (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.