Lernid Package Upstream Merge Request (Universe)

Bug #844923 reported by John S. Gruber
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lernid (Ubuntu)
Undecided
Unassigned

Bug Description

Upstream Lernid has undergone several releases since it has been merged into Ubuntu. It contains many bug fixes that the Ubuntu version lacks.

It is a native package, but is not included in the Debian repositories. With the exception of the pycentral removal patch, all Ubuntu patches have been applied upstream.

Related branches

Revision history for this message
John S. Gruber (jsjgruber) wrote :

I'm maintaining this package upstream.

In Oneiric please replace the current version with lp:lernid merged with lp:~jsjgruber/lernid/lernid.dh_python2 . A build of this combination is the upstream Lernid release at ppa:lernid-devs/lernid-releases in the Oneiric pocket. The build log is at https://launchpad.net/~lernid-devs/+archive/lernid-releases/+build/2764065/+files/buildlog_ubuntu-oneiric-i386.lernid_0.8.2.2%7Elr2%7Eoneiric1_BUILDING.txt.gz

We intend to merge the dh_python2 (pycentral removal) patch once its result can be built on Lucid and Maverick.

Revision history for this message
John S. Gruber (jsjgruber) wrote :

Note that this software, as proposed, has been tested as part of the upstream release. It provides the Lernid part of the fix of LP: #795138, and, at present, Lernid doesn't run at all under Oneiric--I believe due https://bugs.launchpad.net/bugs/780972 .

Please advise if I should subscribe anyone else or if additional information or steps are needed.

Revision history for this message
John S. Gruber (jsjgruber) wrote :

To be clearer, this merge will allow Lernid to run under Oneiric. LP: #795138 is believed to be a duplicate of LP: #780972. The Lernid fix referenced above circuments this by allowing Lernid to run if it can't get to the desktopcouch database due to these or other desktopcouch related bugs.

Revision history for this message
Martin Pitt (pitti) wrote :

No reverse dependencies, and new version got some testing, so this is low risk. Approved, please go ahead.

Changed in lernid (Ubuntu):
status: New → Confirmed
Revision history for this message
Daniel Holbach (dholbach) wrote :

Can you please roll this in a release of Lernid? There's a versioning problem, because 0.8.2.2 > 0.8.2.2~lr2 . Maybe you can call it 0.8.2.3 or something?

Revision history for this message
John S. Gruber (jsjgruber) wrote :

I'm not sure what you mean by rolling this in a release of Lernid--I think it already is. I assumed anything released under Ubuntu would naturally have a greater version than what we have in the upstream PPA at the moment, and since their contents match that would be fine, and customary, but eventually would involve a Ubuntu package download.

lp: lernid + lp:~jsjgruber/lernid/lernid.dh_python2 + dummy temporary version-setting debian/changelog setting for ~lr2~oneiric1 == 0.8.2.2~lr2~oneiric1 in the release ppa. (temporary meaning build-recipe style). I assumed when it was released into Ubuntu and the two bazaar branches were merged we would have lp:lernid + lp:~jsjgruber/lernid/lernid.dh_python2 + permanent version-setting debian/changelog setting for 0.8.2.2-ubuntu1, and that, on release, our students, if/when running oneiric, would get the Ubuntu repo version containing the same code as the ppa has now in its Oneiric pocket. (lp:lernid's current debian/changelog entry says 0.8.2.2, by the way, and doesn't contain a "~" release number entry anywhere in its history). Same thing if there were a backport to Natty.

If backported to Lucid and Maverick without a merge, I also assumed the Ubuntu release would be 0.8.2.2 and that that would still override the PPA version while matching their (different from Natty/Oneiric) contents.

This is the first time I've done this, and it's very likely I have messed up. Please, please, set me straight. How should this be done now, and what should I have done differently?

I'm certainly willing to release a 0.8.2.3 upstream to bazaar, or to bazaar and the upstream PPA Oneiric pocket, if that would help--the only reservation I have being about not merging a pycentral--dh-python2 branch into the upstream source until it can be built on all four versions of Ubuntu we are supporting (L-O), not that I'm implacable on that. How should a new release be different from what is there now? How can I make this right (and easy for you)?

Thanks for your help, Daniel. I'm sorry I don't understand this better than I do. It's both my inexperience as well as the (temporary, I hope) merge consideration and resulting need for Ubuntu version divergence that is complicating this for me.

Revision history for this message
Daniel Holbach (dholbach) wrote :

Ok, what I'll do in that case is just update the version number in the changelog to 0.8.2.3+bzr<revno> and get it into Oneiric.

Revision history for this message
Daniel Holbach (dholbach) wrote :

Sorry, 0.8.2.2+bzr<revno>, so 0.8.2.3 can override that version in the next release again.

Revision history for this message
Daniel Holbach (dholbach) wrote :

Ok, nevermind. The release number was fine all along. I misread the version in current oneiric to be 0.8.2.2 in which case the release number of the version we want to get into oneiric would have needed to be higher. It's all fine. It was just my mistake. Sorry. I'll upload it as 0.8.2.2~lr2.

Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (8.2 KiB)

This bug was fixed in the package lernid - 0.8.2.2~lr2

---------------
lernid (0.8.2.2~lr2) oneiric; urgency=low

  * Oneiric release. (LP: #844923)
  * Merge changes to convert from python-central to dh_python2

lernid (0.8.2.2) natty; urgency=low

  * Ready for release

lernid (0.8.2.1) natty; urgency=low

  * Make schedule a bit easier to read by making font used for instructors one size smaller

lernid (0.8.2) natty; urgency=low

  * Add 'avoid-desktopcouch' debugging option.

  * Remove #ubuntu-classroom-es. Assign correct calendar to #ubuntu-charlas

  * Document the following merges in debian/changelog:

  * Add instructor names to schedule.

  * Add option -d (--debug) for message received and members changed events as
      well as for all other verbose messages. Makes --verbose less verbose.
      Fixes LP: #816080.

  * Couch desktopcouch in try: clause; ignore desktopcouch database if
      unavailable. Fixes LP: #795138 and LP: #516619 by this circumvention.

  * Use a config file as backup for desktopcouch. Window sizes and pane settings
      will not be restored. The config file is recreated each time lernid
      is run, whether or not desktopcouch is available.

  * Get the events from /etc/lernid-classrooms.d/* rather than from the
      Internet. Remove all but the last weeks events and scroll down
      to the current time. LP: #528870.

  * Add /etc/lernid-classrooms.d/ubuntu-classroom and
      /etc/lernid-classrooms.d/ubuntu-classroom-es

  * Add ubuntu-charlas chatroom choice. These implement the
      lernid-config-file-improvements blueprint
      basic requirements. Also fix LP: #533279 and LP: #793033.

  * Add button to open the slide file in the user's (external) browser.
      Add tooltip text to slide window giving the slide url.
      Resolves LP: #830856 and LP: #530817.

  * Add new [slidefile url] and [slidefile url 3] instructor commands to
      load a slide file during a session, and to load the slide file and then
      switch to the page.

  * Load slide file asynchronously using gio (rather than using threads).
      Again fixes LP: #530119. Fixes LP: #795347. Report downloading progress.
      Restablishes these two functions originally created by Peeyoosh
      Sangolekar.

  * Remove bold effect from the room names in the classroom and chatroom label.
      Include the '#' in the name, if someone had abbreviated it.
      Fixes LP: #806797.

  * Add a ZERO WIDTH SPACE and SIX-PER-EM SPACE following "QUESTION: " to help
      classbot pick out questions without regard to the word "QUESTION" as its
      language might not match the one lernid is using. Addresses LP: 808570.

  * Look for classbot messages in a case-insensitive manner. Mark its messages
      by making them italic. Fixes LP: #794126

  * Retrieve the value of "QUESTION:" from the session or the event. Look first
      for a question_token value in the session, then for a locale for the
      session, then for a question_token value for the event, then for a locale
      value for the event.

  * If locale is used and begins with es, translate QUESTION to spanish, otherwise
      leave as english.

  * Added a server variable to e...

Read more...

Changed in lernid (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Scott Kitterman (kitterman) wrote : Re: [Bug 844923] Re: Lernid Package Upstream Merge Request (Universe)

Bzr revision numbers aren't guaranteed to be stable, so I'd use <date> instead of <revno>.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers