lernid freezes after displaying a web page using flash--interference with threading used for slides

Bug #749848 reported by John S. Gruber
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Lernid
High
John S. Gruber
lernid (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: lernid

If a web page is brought up because a url in the chat (or entered in the Event->Open Url dialog) that contains flash, and if the adobe plugin is installed, lernid freezes.

To reproduce be sure that the adobe plugin is installed, start lernid, Use Event->Open url to open http://youtube.com

Uninstalling adobe flash avoids the freeze, but flash media, of course, isn't available.

Installing lightspark allows chrome-browser to use flash, but not the browser in lernid, but this flash plugin doesn't seem to hang lernid.

In normal operation last week, lernid ran for a day full of sessions only to fail (presumably on this error) in the last 15 minutes.

The problem is that the slides process uses Python threads to download slides files asynchronously, but adobe flash doesn't seem to be compatible with it.

Slides also do not render, due to a poppler call problem.

Related branches

Changed in lernid:
importance: Undecided → High
description: updated
description: updated
summary: - lernid freezes after displaying a web page using flash
+ lernid freezes after displaying a web page using flash--interference
+ with improperly rendering slides
summary: lernid freezes after displaying a web page using flash--interference
- with improperly rendering slides
+ with threading used for slides
Changed in lernid:
assignee: nobody → John S. Gruber (jsjgruber)
Changed in lernid (Ubuntu):
assignee: nobody → John S. Gruber (jsjgruber)
Revision history for this message
John S. Gruber (jsjgruber) wrote :

To reproduce make sure that the aobe flash plugin is installed in your system and then connect to a session and use the Event->Open URL menu item to open a youtube video. For example the following URL fails with the current code:

http://www.youtube.com/watch?v=yi3erdgVVTw

Changed in lernid (Ubuntu):
assignee: John S. Gruber (jsjgruber) → nobody
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lernid - 0.8.0.1

---------------
lernid (0.8.0.1) natty; urgency=low

  * Closes: LP: #749848: Revert the slide loading function to run synchronously
            rather than using python threads.
  * Closes: LP: #751019: Handle case where web page has no title.
  * Closes: LP: #764069: Revise size parameters passed to poppler page render
            call.
 -- John S Gruber <email address hidden> Mon, 18 Apr 2011 23:58:23 -0400

Changed in lernid (Ubuntu):
status: New → Fix Released
Changed in lernid:
status: New → Fix Committed
Changed in lernid:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers