lernid crashed with TypeError in __init__(): could not convert tag property 'foreground' to correct type

Bug #716937 reported by Daniel Holbach
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Lernid
Critical
John S. Gruber
lernid (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: lernid

Crashes on startup in natty.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: lernid 0.7
ProcVersionSignature: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
Uname: Linux 2.6.38-3-generic i686
Architecture: i386
Date: Fri Feb 11 12:12:31 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/lernid
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100816)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/lernid
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LC_MESSAGES=de_DE.utf8
 LANG=en_US.UTF-8
 LANGUAGE=de_DE:de:en_GB:en
PythonArgs: ['/usr/bin/lernid']
SourcePackage: lernid
Title: lernid crashed with TypeError in __init__(): could not convert tag property 'foreground' to correct type
UserGroups: adm admin audio cdrom dialout lpadmin plugdev sambashare

Related branches

Revision history for this message
Daniel Holbach (dholbach) wrote :
visibility: private → public
tags: removed: need-duplicate-check
Revision history for this message
John S. Gruber (jsjgruber) wrote :

Set as confirmed as it is reported to affect four people.

Changed in lernid (Ubuntu):
status: New → Confirmed
Revision history for this message
stefaan walleghem (stefwal) wrote :

apport gave following message. (translated from dutch)

Problem cannot be reported

seems there are some older packages installed. Following packages have to be upgraded. Afterwards check whether the problem persists.

gir1.2-glib-2.0, libdb4.8, libdbus-1-3, libgirepository-1.0-1, libgmp3c2, libgmpxx4ldbl, libthai-data, libthai0, libtiff4, python-gobject, x11-common

Revision history for this message
stefaan walleghem (stefwal) wrote :

check comment above

after upgrading the asked packages the report showed it was a duplicate of this bug.

I just wonder as I'm using the 11.04 why the system didn't upgrade everything as it should.

Revision history for this message
John S. Gruber (jsjgruber) wrote :

stefan: could you just be running into the lag that's caused by the update manager loading data only daily? I have had a case where I would get a refusal to report due to out of date software and I was able to start synaptic (or was it update manager?), tell it to reload its data, mark and install the available updates, and then get the crash report to go through. On my system I'm using the default for the update-manager frequency--once daily.

Just now, after asking update-manager to start and then telling it to reload its data caused the upgradeable packages to almost double from 48 to 95 packages available for upload.

You may have already done something like what I describe above, or I may be misunderstanding you, but I thought I'd comment just in case it might help.

Changed in lernid (Ubuntu):
assignee: nobody → John S. Gruber (jsjgruber)
Changed in lernid (Ubuntu):
assignee: John S. Gruber (jsjgruber) → nobody
Revision history for this message
Duane Hinnen (duanedesign) wrote :

I can confirm these changes fix the bug and Lernid launches in Natty

Revision history for this message
John S. Gruber (jsjgruber) wrote :

Thanks for checking them, duanedesign.

Actually, for the record, unless package desktopcouch happens to be already installed, the fix for LP #727232 is also needed for sucessfully launching lernid in Natty.

Revision history for this message
John S. Gruber (jsjgruber) wrote :

A corrected lernid is available in my ppa (ppa:jsjgruber/ppa) for this and for LP #727232.

Changed in lernid:
status: New → Confirmed
assignee: nobody → John S. Gruber (jsjgruber)
Revision history for this message
John S. Gruber (jsjgruber) wrote :

Please see lp: 727232 for natty merge request information, including location of build log and debdiff

Please note that my ppa:~jsjgruber/ppa contains an update to 0.7.1 while ppa:jsjgruber/ppatwo contains 0.7ubuntu1, the proposed update to natty.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lernid - 0.8

---------------
lernid (0.8) natty; urgency=low

  * Fix Significant bugs
    (LP: #716937) - Correct specification of text tags colors
    (LP: #727232) - Add desktopcouch as dependency
 -- John S Gruber <email address hidden> Tue, 29 Mar 2011 16:22:10 -0400

Changed in lernid (Ubuntu):
status: Confirmed → Fix Released
Changed in lernid:
importance: Undecided → Critical
Changed in lernid:
status: Confirmed → In Progress
Changed in lernid:
status: In Progress → Fix Committed
Changed in lernid:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers