Inappropriately appears in Ubuntu Software Center "Developer Tools" > "Python"

Bug #546968 reported by Matthew Paul Thomas
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Lernid
Undecided
Unassigned
One Hundred Papercuts
Low
Andrew
lernid (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: lernid

Ubuntu Lucid, all updates installed

1. In Ubuntu Software Center, select "View" > "All Software".
2. Navigate to "Get Software" > "Developer Tools" > "Python".
3. Scroll down to L.

What happens: "Lernid" appears in the list.
What should happen: It shouldn't be there.

This is because the lernid package has "Section: universe/python", which it should not, since it's nothing particularly to do with Python.

Since it seems to be targeted at helping Ubuntu developers in general, I suggest "Section: universe/devel".

tags: added: metadata
Vish (vish)
Changed in hundredpapercuts:
milestone: none → maverick-round-9-sc-metadata
status: New → Confirmed
Changed in lernid (Ubuntu):
status: New → Confirmed
Changed in hundredpapercuts:
importance: Undecided → Low
Changed in lernid (Ubuntu):
importance: Undecided → Low
Revision history for this message
Andrew (and471) wrote :

I would argue it isn't for developers, but for all users. I feel it would be more appropriate for it to be in 'Internet'.

Could we have an agreement and then the patch can be made.

Changed in hundredpapercuts:
assignee: nobody → Andrew (and471)
Revision history for this message
Danny Roberts (dannyroberts-personal) wrote :

Perhaps 'Education' would be a better fit for this as the tool is designed to educate users (not just developers like Andrew said).

Revision history for this message
Matthew Paul Thomas (mpt) wrote :

Sure, I have no problem with it being in Education if that's more appropriate. A simple solution would be to add a .desktop file that puts it in "Education"; then it would disappear from "Python" once bug 554180 was fixed.

Revision history for this message
Andrew (and471) wrote :

I will make the patch however I need to know whether we want it in Internet or education. The reason is it is currently in Internet in the applications menu and I don't want to have it in separate places in the SC and the menu.

So are we going for Education globally?

Changed in lernid:
status: New → Confirmed
assignee: nobody → Andrew (and471)
Changed in hundredpapercuts:
status: Confirmed → In Progress
Changed in lernid:
status: Confirmed → In Progress
Revision history for this message
Andrew (and471) wrote :

Okay attached is the patch. Lernid should now be in Education and Internet (as opposed to Dev>Python)

Changed in lernid:
assignee: Andrew (and471) → nobody
Revision history for this message
Andrew (and471) wrote :

Can someone apply this fix to trunk?

tags: added: patch
Revision history for this message
Vish (vish) wrote :

Fix got committed in the upstream branch.

We either need a new package upload or a debdiff for this to get actually fixed in Ubuntu SC..

Changed in hundredpapercuts:
status: In Progress → Fix Committed
Changed in lernid:
status: In Progress → Fix Committed
tags: added: patch-accepted
removed: patch
Changed in hundredpapercuts:
status: Fix Committed → In Progress
Changed in lernid (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Andrew (and471) wrote :

Here is a debdiff to update the package from version 0.6 to 0.8, this has with it a lot of bug fixes (as mentioned in the changelog) as well as this bug fix.

Revision history for this message
Michael Budde (mbudde) wrote :

Thanks for your work, Andrew. I have some things I'd like to point out though:

  * Why is there some bazaar stuff in that debdiff? That doesn't seem right.
  * Where did you get 0.8 from? The version in the repo has the version number 0.7 and I don't see any reason to skip a version number.

Revision history for this message
Andrew (and471) wrote :

@Michael Budde

Forgot about this, I shall fix it

I couldn't find a version number and so I just chose a random one, I shall change this to 0.7

Revision history for this message
Andrew (and471) wrote :

Here is a debdiff that solves the problems above and updates the package from version 0.6 to 0.7, this has with it a lot of bug fixes (as mentioned in the changelog) as well as this bug fix.

Revision history for this message
Andrew (and471) wrote :

Okay here is a final debdiff, with a perfected debian/changelog thanks to didrocks :D

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lernid - 0.7

---------------
lernid (0.7) maverick; urgency=low

  * New upstream version, fixes bugs:
    (LP: #530119) - Don't block UI when downloading slides
    (LP: #500495) - Should support other IRC channel prefixes than '#'
    (LP: #510003) - Warnings in the terminal when closing Lernid
    (LP: #530115) - exit in terminal
    (LP: #514733) - Preload the default page in browser
    (LP: #503224) - Lernid opens too small
    (LP: #530810) - URLs in chat area should be clickable
    (LP: #530821) - Add an xchat-type separator line for new text in
                    classroom
    (LP: #531492) - missing copy menu entries for browser widget
  * debian/control, change section:
    (LP: #546968) - Inappropriately appears in Ubuntu Software Center
                    "Developer Tools" > "Python"
 -- Andrew Higginson <email address hidden> Sat, 31 Jul 2010 08:42:13 +0100

Changed in lernid (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Vish (vish) wrote :

Nice work Andrew! :)

Changed in hundredpapercuts:
status: In Progress → Fix Released
Changed in lernid:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers