lernid: depends on python-webkit which is deprecated

Bug #1591343 reported by Jeremy Bicha
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Lernid
Undecided
Unassigned
lernid (Ubuntu)
Low
Unassigned

Bug Description

[Impact]

lernid depends on python-webkit, which is deprecated and going
to be removed from the Debian archive. lernid should switch to using
the GObject Introspection bindings for webkit, ideally
gir1.2-webkit2-3.0 for Webkit2 and gtk+3 as upstream has already
dropped WebKit1 (so gir1.2-webkit-1.0 and gir1.2-webkit-3.0 are
likely to be dropped from Debian in the near future).

[Other Info]

As reported at https://bugs.debian.org/790218 the Debian developers would like to remove python-webkit from the repositories because it uses libwebkitgtk-1.0-0 which is no longer maintained.

The developers recommend you port lernid to GTK3 and then build against gir1.2-webkitgtk-3.0, or preferably gir1.2-webkit2-4.0.

There's some additional info at https://bugs.debian.org/749258

Related branches

Jeremy Bicha (jbicha)
description: updated
Jeremy Bicha (jbicha)
summary: - Please port to newer webkit bindings
+ Please remove lernid from Ubuntu
Jeremy Bicha (jbicha)
description: updated
description: updated
Revision history for this message
John S. Gruber (jsjgruber) wrote : Re: Please remove lernid from Ubuntu

Did you try connecting to the spanish chatroom set? That seems to be working, as do the parameters to choose other chatrooms. (See the man page). You are probably right that chatroom forwarding is throwing off telepathy, which lernid uses for the IRC connections.

The calendar only tries to present recent and future events.

It's also my understanding that #ubuntu-classroom is defunct. I haven't inquired about #ubuntu-charlas, but I'm not aware of recent use of it.

My last upload was 1/28/16 to change the build for dh-python2.

Lernid may never be used again but I haven't actually abandoned it yet.

I'm don't know anything about the policy for removing programs from universe when they are considered no longer important and I guess that's the issue as your bug report stands now.

Revision history for this message
Jeremy Bicha (jbicha) wrote :

You said that you haven't abandoned it, but the app doesn't really do anything now.

Here's a list of some things it needs:
* Not use python-webkit since I think there's a good chance python-webkit will be removed from Ubuntu this year.
I believe this basically means porting to GTK3 and the gir bindings, and ultimately to WebKit 2. I did some pygtk porting years ago but it seems like a lot of work if the app won't be used when the work is done.

* It shouldn't default to #ubuntu-classroom (unless you get the IRC Council to reopen that channel).
* It shouldn't open a wiki page that says the project is obsolete.
* If it has a calendar tab, the calendar should probably do something.

Revision history for this message
Jeremy Bicha (jbicha) wrote :

Yes the Spanish channel works.

Changed in lernid:
assignee: nobody → John S. Gruber (jsjgruber)
Changed in lernid:
assignee: John S. Gruber (jsjgruber) → nobody
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lernid - 1.0.7

---------------
lernid (1.0.7) yakkety; urgency=medium

  * Release 1.0.7
    Straighten out tag and setup.py and lernidconfig.py versions
    Update debian standards to 3.9.7

 -- John S Gruber <email address hidden> Wed, 28 Sep 2016 12:55:30 -0400

Changed in lernid (Ubuntu):
status: New → Fix Released
Revision history for this message
Mathew Hodson (mhodson) wrote :

I don't think this was resolved. The complaint was that lernid depends on python-webkit, and looking at the control file, it still does.

Changed in lernid (Ubuntu):
status: Fix Released → New
summary: - Please remove lernid from Ubuntu
+ lernid: depends on python-webkit which is deprecated
Mathew Hodson (mhodson)
description: updated
Revision history for this message
John S. Gruber (jsjgruber) wrote :

@Mathew Thanks for making the upload.

@Mathew and @Jeremy:

This bug seems to have an identity crisis. At one time it was about the deprecation of python-webkit and then it was about the state of Lernid itself. I don't see where that middle description went. Now it's only about python-webkit again. I would have preferred having one bug per issue rather than switching titles and descriptions and issues around.

Nevertheless I've done my best, within reason, to address all of this in the new release. Lernid mentions that #ubuntu-classroom is inactive, matching the web page it launches, and it brings all past sessions to the schedule tab allowing one to click for the IRC logs for previous sessions of interest. They go back to about 2010.

I'm grateful to Jeremy for bringing the schedule up in particular. There were objections to listing old sessions in the schedule but I don't imagine they still apply.

The last classroom opened is the default to be opened the next time.

I didn't want lernid to be an impediment to the evolution of the Ubuntu repos so the largest change to upstream is to tolerate the absence of python-webkit. Lernid detects that situation and browser tabs are launched externally in the user's preferred browser rather than in the Session tab. The Session tab still contains slides if they are being used.

Most would far prefer the traditional behaviour if available so I prefer to keep the hard dependency on python-webkit until python-webkit disappears from the Ubuntu repo. At that point changing debian/control should be the only change necessary.

Since the latest upstream Lernid addresses the other points as well as python-webkit, but the packaging doesn't remove the dependency, I'm going to mark this bug as fixed on upstream and leave the bug on Lernid (Ubuntu) as New.

When I checked a couple of days ago python-webkit was still in Sid, but I don't know whether it will remain so until Ubuntu z-series is populated from Debian. Whenever it does disappear from the repo if you want me to be the one to adjust the debian/control file please let me know, perhaps by marking lernid (Ubuntu) affects as confirmed above. Feel free to drop me an email or to open a new bug report if you prefer.

Changed in lernid:
status: In Progress → Fix Released
Mathew Hodson (mhodson)
Changed in lernid (Ubuntu):
importance: Undecided → Low
tags: added: packaging
Changed in lernid (Ubuntu):
assignee: nobody → John S. Gruber (jsjgruber)
status: New → In Progress
Revision history for this message
John S. Gruber (jsjgruber) wrote :

As maintainer I've just released upstream version 1.0.8 removing the debian packaging dependency on python-webkit. Upstream is at ppa:lernid-devs/lernid-releases and on Ubuntu is in the universe repo. No further changes should be required for Ubuntu. Lernid is not in debian.

The corresponding source branch is at lp:lernid

The build page is at https://launchpad.net/~lernid-devs/+archive/ubuntu/lernid-releases/+build/12367731 and the buildlog is at https://launchpadlibrarian.net/313029893/buildlog_ubuntu-zesty-amd64.lernid_1.0.8_BUILDING.txt.gz .

I've tested the package from the above repo on zesty.

@Jeremy, please let me know if there is anything else you need from me. Thanks.

Changed in lernid (Ubuntu):
status: In Progress → Fix Committed
assignee: John S. Gruber (jsjgruber) → nobody
Revision history for this message
Jeremy Bicha (jbicha) wrote :

Thank you!

I have uploaded to zesty and am unsubscribing ubuntu-sponsors. Feel free to resubscribe if you have something else that needs sponsoring.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lernid - 1.0.8

---------------
lernid (1.0.8) zesty; urgency=medium

  * Move python-webkit from a dependency to a suggestion in debian/control.
    Fixes lp: #1591343

  * Release as version 1.0.8

 -- John S Gruber <email address hidden> Mon, 27 Mar 2017 15:19:48 -0400

Changed in lernid (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers