Lein repl completion not working

Bug #1176641 reported by mydoghasworms on 2013-05-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
leiningen (Ubuntu)
Undecided
Unassigned

Bug Description

I start up the clojure REPL using "lein repl".

When I do TAB-completion, it seems to take previous output from standard out or something:

me@my-home:~$ lein repl
REPL started; server listening on localhost port 28699
user=>
28699 REPL listening localhost on port server started
user=> (print "hello")
hellonil
user=>
28699 REPL hello hellonil listening localhost on port print server started
user=>

As you see, continued output to standard out is then incorporated into the tabbed completion.

I am using Oracle JDK 7 (as per Webupd8 method) if that makes any difference.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: leiningen 1.7.1-1ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-19.30-generic 3.8.8
Uname: Linux 3.8.0-19-generic x86_64
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
Date: Sun May 5 21:22:25 2013
InstallationDate: Installed on 2013-05-03 (2 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: leiningen
UpgradeStatus: No upgrade log present (probably fresh install)

mydoghasworms (dumace) wrote :
mydoghasworms (dumace) wrote :

Just to confirm, running the clojure repl directly with 'clojure' from the command line does completion properly.

Jackson Doak (noskcaj) on 2013-08-05
summary: - Lein repl completion doing weird $h!7
+ Lein repl completion not working
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers