Leafpad clean up GTK Include

Bug #405576 reported by Jones D. Le on 2009-07-28
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
leafpad (Debian)
Confirmed
Unknown
leafpad (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: leafpad

http://live.gnome.org/GnomeGoals/CleanupGTKIncludes

Only 1 file is affected is src/gtksourceiter.h; this bug is very simple to fix. Simply modify src/gtksourceiter.h and change line 25 to #include <gtk/gtk.h>

Remove use of GTK+ deprecated symbols

mac9416 (mac9416) wrote :

I forwarded the bug and patch upstream. You can look at the report here: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=590583

tags: added: patch-forwarded-debian
Changed in leafpad (Debian):
status: Unknown → Confirmed
Hans Joachim Desserud (hjd) wrote :

Hello again.

I intially found this bug report when I saw it contained a patch and attached a bug watch to the corresponding Debian bug. Looking a bit closer, I discovered that this issue seems to have been resolved when version 0.8.18.1-1 was synced from Debian. See the diff at http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/wily/leafpad/wily/revision/13 for details, particularly the changes to src/gtksourceiter.h which are identical to the proposed patch.

Presumably the forwarded patch reached its destination or someone else applied a similar patch upstream. In any case it looks like this issue can be marked fixed.

Thanks again for your patch. :)

Changed in leafpad (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.