ldm-server hangs on installation

Bug #557519 reported by Jonathan Carter on 2010-04-07
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ldm (Debian)
Fix Released
Unknown
ldm (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: ldm-server

On a fresh server or desktop i386 or amd64 installation, when installing ltsp-server/ltsp-server-standalone/ldm-server, it hangs on:
Setting up ldm-server (2:2.1.1-0ubuntu1) ...

Sample strace output:
pselect6(25, [0 24], NULL, NULL, {1, 0}, {[], 8}) = 1 (in [24], left {0, 973844790})
read(24, "processing: trigproc: man-db\n", 1024) = 29
waitpid(8292, 0xbfa77bb0, WNOHANG) = 0
pselect6(25, [0 24], NULL, NULL, {1, 0}, {[], 8}) = 1 (in [24], left {0, 999855778})
read(24, "status: man-db: half-configured\n", 1024) = 32
waitpid(8292, 0xbfa77bb0, WNOHANG) = 0
pselect6(25, [0 24], NULL, NULL, {1, 0}, {[], 8}) = 0 (Timeout)

The last two lines are repeated indefinitely.

This bug is marked high priority since it makes LTSP uninstallable.

Related branches

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ldm - 2:2.1.1-0ubuntu2

---------------
ldm (2:2.1.1-0ubuntu2) lucid; urgency=low

  * Drop debconf from ldm-server.postinst, fixes hanging (LP: #557519)
 -- Stephane Graber <email address hidden> Wed, 07 Apr 2010 16:08:39 -0400

Changed in ldm (Ubuntu):
status: Confirmed → Fix Released
Vagrant Cascadian (vagrantc) wrote :

this looks to be the same bug reported in debian:

http://bugs.debian.org/552031

Changed in ldm (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.